Bug 72427 - RHN update run has problems with "to be skipped" pkgs
RHN update run has problems with "to be skipped" pkgs
Status: CLOSED DUPLICATE of bug 72116
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 13:54 EDT by James Manning
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 16:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-08-23 13:54:08 EDT
doing a null install, current in firstboot - machine rhn_registered fine and is
now popping up a dialog saying that "these packages are marked to be skipped by
your configuration - if you wanna override, select them".  It's 5 kernel
packages, but whether they're all selected or deselected or any combination, the
dialog's "Forward" button continues to be grayed out!  Hence, I'm stuck (AFAICT)
and can't complete this step without canceling out.
Comment 1 James Manning 2002-08-23 13:56:43 EDT
This may be a hint - since I couldn't click Forward, I clicked on the "View
Advisory" button - the cursor went to the watch symbol (so it's trying to
execute something) but nothing else has happened - no other dialog popping up or
anything.

Note that this is the same machine with the High firewall setting, which may be
causing this kind of symptom (although since all of RHN is tcp/443 traffic, I
don't see how)
Comment 2 James Manning 2002-08-23 13:59:06 EDT
The Cancel button still worked (even though the cursor was still in the "watch"
state) so I was able to at least complete firstboot (although that RHN thing
would have died in the middle).  I'll attach up2date logs in case helpful stuff
got logged
Comment 3 James Manning 2002-08-23 14:40:39 EDT
same behavior seen after firstboot, so changing component

also, when "view advisory" is clicked and "hangs", there's a traceback.

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 934, in showAdvisory
    advisories = rhnErrata.getAdvisoryInfo(rowData[1])
TypeError: unsubscriptable object

However, the "main bug" here is that the Forward button is grayed out and I
can't continue.
Comment 4 James Manning 2002-08-23 16:32:30 EDT
now THIS is interesting
- start up2date
- go forward to this screen (can't go forward any more)
- go back to the "welcome to" - takes about 7 or 8 back clicks through all the
RHN setup stuff formerly of rhn_register - no filling out anything (everything's
empty), just keep going back
- go forward again to this screen
- NOW the Forward button is active, and the Back is grayed out!
- now going forward and continuing to install updates works great!

- NOTE: during download (yes, oddly enough) the terminal output happens of:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a
although this only happened once (not once for each of the 5 kernel packages)

I remember this getting tagged by jbj as NOTABUG (I think? - this true, Jeff?),
but anything that says "warning" is going to scare people when it's important
stuff like package updates (I got scared, even, of course :)

adding daryll to cc since he saw this behavior as well (well, the Forward not
active the first time around).  Daryll - can you confirm that the above "works"
for you to get the button active and allow pkg updates?

Comment 5 Daryll 2002-08-23 16:39:25 EDT
Yep, going all the way and then forward does allow the packages to be installed.
Also I get the following errors while backing up:
TypeError: hide() takes no arguments (1 given)
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 655, in onProfilePageBack
    if self.alreadyRegistered:
AttributeError: Gui instance has no attribute 'alreadyRegistered'
Comment 6 Adrian Likins 2002-08-23 16:43:20 EDT
the #SUBJECT of this bug is fixed in 2.9.49
also, dup of #72116

the header/nokey stuff deserves a second bug
(it's currently being worked on, but a bug report wouldnt hurt)

also, the errata advisory sub thread is a dup of  #72120

*** This bug has been marked as a duplicate of 72116 ***

Note You need to log in before you can comment on or make changes to this bug.