Bug 7249 - locale not supported by C library
locale not supported by C library
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 7248 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-23 00:28 EST by vijay
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 14:36:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vijay 1999-11-23 00:28:07 EST
from a terminal when I call linuxconf the linuxconf window popsup, but
on the terminal I find a message from the remadmin saying "locale not
supported by C library". If I try changing the configuration now , it
gives me the following error message repeatedly

           " Error message from remadmin: Gtk-Critical: file gtkwidget.c:
line1584 (gtk_widget_map):assertion 'GTK_WIDGET_VISIBLE (widget) == TRUE'
failed"

         and eventually tells that gnome-linuxconf has crashed.

We previously had Redhat Linux 6.0. We didnt face any problem with that
version.
Comment 1 Michael K. Johnson 1999-11-23 11:44:59 EST
*** Bug 7248 has been marked as a duplicate of this bug. ***
Comment 2 Alec Voropay 1999-11-25 14:54:59 EST
What is your current locale ? Try :

$ locale
Comment 3 Anonymous 1999-11-25 23:43:59 EST
~$ locale
LANG=en
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_ALL=en_US

Hm, should probably be en_AU for me. Where do I change this (Both for myself and
the system default)?

I see this problem as well, but I'm running linuxconf-1.16r6-1, from the
linuxconf site, which may or may not be relevent.
Comment 4 Anonymous 1999-12-01 12:36:59 EST
This locale problem also appears to cause a number of RedHat 6.1 SRPMS not to
build with locale support.  Since they build without locale support and the spec
files list the /usr/share/locale/*/*/* (or something similar) they fail to build
RPMS.  For instance, shadow-utils will not build on RedHat 6.1 as well as most
of Gnome and KDE.
Comment 5 Michael K. Johnson 1999-12-01 16:06:59 EST
The locale message is not related to the Gtk-Critical message.
This is also completely unrelated to the locale build issue
that dath mentions.
Comment 6 Nalin Dahyabhai 2000-01-20 08:37:59 EST
Please try this again with linuxconf-1.17r1-2 and gnome-linuxconf-0.24-1
from Raw Hide.  The GTK errors should be gone.

Upgrading to the latest errata version of initscripts (4.70-1) should fix part
of the locale problem.  Your LANG variable should include a country code; if
it doesn't, modifying the LANG variable in /etc/sysconfig/i18n should change
the system default.  (I've checked with the latest versions of linuxconf and
gnome-linuxconf and despite the locale warning from GDK, it appears to continue
running without problems.)

Please let me know if this solves your problems.

Note You need to log in before you can comment on or make changes to this bug.