This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 725229 - Can not enable "Save" button when input simplify Chinese/traditional Chinese in Firefox 3.6.18
Can not enable "Save" button when input simplify Chinese/traditional Chinese ...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4
  Show dependency treegraph
 
Reported: 2011-07-24 08:24 EDT by James Ni
Modified: 2011-09-11 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 22:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Ni 2011-07-24 08:24:49 EDT
Description of problem:
Can not enable "Save" button when input simplify Chinese/traditional Chinese in Firefox 3.6.18

Steps to Reproduce:
1.Go to http://hudson.englabe.bne.redhat.com
2.Select any project
3.Select zh-Hans in any version
4.Select one document
5.Click target cell and enable target cell editor
6.Enable simplify/traditional Chinese input method
7.input simplify/traditional Chinese character
  
Actual results:
After input Chinese character, the "Save" button still not be enabled. 

Expected results:
After input Chinese character, the "Save" button will be enabled and user can click it to save.

Additional info:
This error doesn't happens on Chrome browser, it doesn't affect Firefox 5 on Fedora 15, it only affect Firefox 3.6.13 on RHEL 5.6 and Firefox 3.6.18 on Fedora 14.

In the source code, i enable the "Save" button based on keyup event, it seems FireFox 3.6 doesn't receive any key event through input method (keyup, keydown, and keypress event), but it do receive key event through keyboard. 

I also try valueChangeEvent, but Firefox only fire valueChangeEvent when editor lose focus.
Comment 1 Ding-Yi Chen 2011-07-25 19:49:58 EDT
I cannot reproduce your bug with
RHEL 5: firefox-3.6.17, scim-1.4.4-41, scim-chewing-0.3.1-11
RHEL 6: firefox-3.6.17, ibus-1.3.4-5, ibus-chewing-1.3.10-1, ibus-pinyin-1.3.8-1
Fedora 14: firefox-3.6.18-1, ibus-1.3.9-4, ibus-chewing-1.3.9.2

Is your locale a Chinese one?
Comment 2 Sean Flanigan 2011-08-11 21:09:11 EDT
James, what is the status of this one?
Comment 3 James Ni 2011-08-11 21:31:34 EDT
The save button is set to enabled when editor is activated now. So we don't need to detect the change of content to enable the save button now. I once try to use polling to detect the change of the content, but it is not efficient.
 
Sean, do we still need that save button only enabled when content is changed? if we want, i think i still have to use polling method, i didn't find a better solution yet. 

(Ding did test after i added polling, so maybe not correct)
Comment 4 Sean Flanigan 2011-08-11 21:51:36 EDT
Alright.  Since save is always enabled now, this particular bug no longer applies.

At some point we should revisit the problem of efficiently enabling Save only when something has changed.
Comment 5 Ding-Yi Chen 2011-08-11 22:36:43 EDT
This bug is no longer valid, as we changed the UI and make Save buttons always activated.

I have filed Bug 730177 regarding activate/deactivate save icons according whether there are changes.

Note You need to log in before you can comment on or make changes to this bug.