This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 725347 - virtuoso-opensource-6.1.3-1.fc16 fails self checks on ppc64
virtuoso-opensource-6.1.3-1.fc16 fails self checks on ppc64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virtuoso-opensource (Show other bugs)
rawhide
powerpc Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 749550 (view as bug list)
Depends On:
Blocks: F16Betappc
  Show dependency treegraph
 
Reported: 2011-07-25 05:22 EDT by Karsten Hopp
Modified: 2012-03-14 09:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: virtuoso-opensource-6.1.4-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-19 18:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2011-07-25 05:22:07 EDT
Description of problem:
VAD Sticker vad_dav.xml creation...
VAD Sticker vad_fs.xml creation...
Virtuoso.ini creation...
Waiting Virtuoso Server start on port 1111...
PASSED: Virtuoso Server successfully started on port 1111
***FAILED: starting DB.DBA.VAD_PACK('vad_fs.xml', '.', 'rdf_mappers_filesystem.vad')
***FAILED: starting commit work
***FAILED: starting checkpoint
***FAILED: starting DB.DBA.VAD_PACK('vad_dav.xml', '.', 'rdf_mappers_dav.vad')
***FAILED: starting commit work
***FAILED: starting checkpoint
Shutdown Virtuoso Server...
chmod: cannot access `rdf_mappers_dav.vad': No such file or directory
=====================================================================
=  Checking log file /builddir/build/BUILD/virtuoso-opensource-6.1.3/binsrc/rdf_mappers/make_rdf_mappers_vad.log for statistics:
=
=  Total number of tests PASSED  : 1
=  Total number of tests FAILED  : 6
=  Total number of tests ABORTED : 0

Version-Release number of selected component (if applicable):
virtuoso-opensource-6.1.3-1.fc16

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch dist-f16 virtuoso-opensource-6.1.3-1.fc16.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=259607
Comment 1 Rex Dieter 2011-10-12 10:00:09 EDT
confirmed still occurs with 6.1.3-3 (with gawk4 patch),
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=299243

):
Comment 2 Karsten Hopp 2011-10-27 09:49:02 EDT
*** Bug 749550 has been marked as a duplicate of this bug. ***
Comment 3 Karsten Hopp 2011-10-27 10:25:43 EDT
seems to be a 64bit problem only, ppc32 completed: 
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=306634
Comment 4 Rex Dieter 2011-10-27 11:47:03 EDT
What's your primary arch for ppc?  32 or 64bit?

(Hoping perhaps we could get away with ExcludeArch: ppc in the short-term).
Comment 5 Karsten Hopp 2011-11-02 12:37:49 EDT
our primary arch is ppc64. 
But here are the packages that require virtuoso-opensource, those and its dependants need to be either patched to not require virtuoso or the need to be disabled, too:

avogadro
ghemical
gnome-chemistry-utils  
kalzium                                                             
kdeedu                                                                           
soprano                                                                           
xdrawchem

At least soprano can't be removed from the ppc as we'd have to drop the whole KDE stack.
Comment 6 Rex Dieter 2011-11-02 14:23:36 EDT
Fwiw, only soprano should depend on virtuoso-opensource according to my repo query (though there's a fair number of kde apps that pulls in soprano, and thus virtuoso indirectly).

Anyway, I'll redouble my efforts to resolve this.
Comment 7 Rex Dieter 2011-11-02 15:06:00 EDT
Short-term (hopefully) workaround it seems is to build with --disable-all-vads like older virtuoso builds did (that didn't FTBFS on ppc/ppc64),

%changelog
* Wed Nov 02 2011 Rex Dieter <rdieter@fedoraproject.org> 6.1.4-2
- --disable-all-vads on ppc/ppc64 to workaround FTBFS (#725347)

build underway:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=311921
Comment 8 Fedora Update System 2011-11-04 08:45:30 EDT
virtuoso-opensource-6.1.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virtuoso-opensource-6.1.4-2.fc16
Comment 9 Fedora Update System 2011-11-04 17:48:17 EDT
Package virtuoso-opensource-6.1.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virtuoso-opensource-6.1.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15428
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-11-19 18:30:41 EST
virtuoso-opensource-6.1.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.