Bug 725757 - NameError: name 'setupProgressDisplay' is not defined
NameError: name 'setupProgressDisplay' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 727810 (view as bug list)
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-07-26 09:37 EDT by James Laska
Modified: 2014-09-30 19:40 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-16.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 20:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1009 bytes, patch)
2011-07-26 09:37 EDT, James Laska
no flags Details | Diff
error log of anaconda 16.14.3 (26.38 KB, image/png)
2011-08-09 03:18 EDT, Tao Wu
no flags Details
screen shot of error message (24.70 KB, image/png)
2011-08-16 04:58 EDT, Tao Wu
no flags Details
error log of anaconda 16.14.5 (4.14 KB, text/x-log)
2011-08-16 05:00 EDT, Tao Wu
no flags Details

  None (edit)
Description James Laska 2011-07-26 09:37:51 EDT
Created attachment 515282 [details]
proposed patch

Description of problem:

cmdline mode kickstart install failure

Version-Release number of selected component (if applicable):
 * anaconda-16.13

Steps to Reproduce:
1. https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Cmdline
  
Actual results:

Running anaconda 16.13, the Fedora system installer - please wait.             
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 747, in <module>
    setupDisplay(anaconda, opts)
  File "/usr/sbin/anaconda", line 537, in setupDisplay
    anaconda.initInterface()
  File "/tmp/updates/pyanaconda/__init__.py", line 255, in initInterface
    from cmdline import InstallInterface
  File "/tmp/updates/pyanaconda/cmdline.py", line 37, in <module>
    stepToClasses = { "install" : setupProgressDisplay }
NameError: name 'setupProgressDisplay' is not defined


Expected results:

No traceback

Additional info:

 * This impacts the F16 Beta release criteria regarding installation automation - "Any installation method or process designed to run unattended must do so (there should be no prompts requiring user intervention) "
Comment 1 James Laska 2011-07-26 09:41:05 EDT
Seems related to commit 8b6d7f89
Comment 2 Radek Vykydal 2011-07-26 09:58:13 EDT
Ales has patch for it.
Comment 3 Ales Kozumplik 2011-07-26 10:12:44 EDT
Hi James,

Can you please retest with http://akozumpl.fedorapeople.org/bz725757.img ?

The patch is here: https://www.redhat.com/archives/anaconda-devel-list/2011-July/msg00153.html

Thank you.
Ales
Comment 4 James Laska 2011-07-26 11:23:36 EDT
(In reply to comment #3)
> Hi James,
> 
> Can you please retest with http://akozumpl.fedorapeople.org/bz725757.img ?

Resolves the reported problem, thanks!
Comment 5 Ales Kozumplik 2011-07-27 02:27:43 EDT
Thanks for testing, pushed as 6caf7e595148a329b4cce915f9d872e196447f9e.
Comment 6 Radek Vykydal 2011-08-03 06:46:03 EDT
*** Bug 727810 has been marked as a duplicate of this bug. ***
Comment 7 Tao Wu 2011-08-08 02:22:23 EDT
It seems still happen in F16-alpha-RC1.
Comment 8 Ales Kozumplik 2011-08-08 02:29:13 EDT
(In reply to comment #7)
> It seems still happen in F16-alpha-RC1.

Can you please attach the complete traceback? Thanks.
Comment 9 Tao Wu 2011-08-09 03:18:27 EDT
Created attachment 517354 [details]
error log of anaconda 16.14.3
Comment 10 Tao Wu 2011-08-09 03:18:45 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > It seems still happen in F16-alpha-RC1.
> 
> Can you please attach the complete traceback? Thanks.

Hi Ales,

I have just test F16-alpha-RC2(anaconda 16.14.3), and still meet this error. The attachment is the screen shot of the error on F16-alpha-RC2. Pleas have a look, thanks.
Comment 11 Ales Kozumplik 2011-08-09 03:40:55 EDT
Hi,

it looks like my change hasn't been merged to the f16-alpha-branch. Can you please retest with post-alpha Anaconda?

Ales
Comment 12 Tao Wu 2011-08-09 03:48:17 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > It seems still happen in F16-alpha-RC1.
> 
> Can you please attach the complete traceback? Thanks.

Hi Ales,

I have just test F16-alpha-RC2(anaconda 16.14.3), and still meet this error. The attachment is the screen shot of the error on F16-alpha-RC2. Pleas have a look, thanks.
Comment 13 Tao Wu 2011-08-09 03:50:04 EDT
(In reply to comment #11)
> Hi,
> 
> it looks like my change hasn't been merged to the f16-alpha-branch. Can you
> please retest with post-alpha Anaconda?
> 
> Ales

Okay, I will test with post-alpha Anaconda, thanks!
Comment 14 Tao Wu 2011-08-16 04:57:26 EDT
Hi Ales,

It seems still happen in F16-alpha-RC4, i386 dvd install.  The screen shot and anaconda log are in the attachment.
Comment 15 Tao Wu 2011-08-16 04:58:36 EDT
Created attachment 518429 [details]
screen shot of error message
Comment 16 Tao Wu 2011-08-16 05:00:32 EDT
Created attachment 518432 [details]
error log of anaconda 16.14.5
Comment 17 Adam Williamson 2011-08-16 05:20:27 EDT
tao: it's expected to happen in all Alpha builds. this bug is not Alpha critical, so the fix is not in any Alpha builds. you'd need to build a test ISO with an anaconda build 16.15 or later - not a build on the 16.14 branch - to check this. 16.14 is the branch for Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Tim Flink 2011-09-01 13:15:07 EDT
Discussed in the 2011-08-26 blocker review meeting. Accepted as a Fedora 16 beta blocker as it violates the following beta release criterion [1]:

Any installation method or process designed to run unattended must do so (there should be no prompts requiring user intervention) 

[1] https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 19 Adam Williamson 2011-09-07 17:18:05 EDT
Tao and/or James: can you please confirm that this is fixed in Beta TC1? Thanks!
Comment 20 Adam Williamson 2011-09-12 20:02:47 EDT
I was able to complete an unattended, cmdline kickstart-based minimal install of Beta TC2 using the ks http://www.happyassassin.net/extras/ordered_unattended.ks . BobLFoot also reported a 'pass' for this test case in the matrix. So I'm closing this as ERRATA (the fixed anaconda was already pushed to stable).

Note You need to log in before you can comment on or make changes to this bug.