Bug 725821 - [abrt] gnome-activity-journal-0.6.0-2.fc15: client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
Summary: [abrt] gnome-activity-journal-0.6.0-2.fc15: client.py:105:_disconnection_safe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zeitgeist
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3d51cf7d974a46d9b55819a483e...
: 737378 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-26 16:38 UTC by Luya Tshimbalanga
Modified: 2011-11-10 17:26 UTC (History)
38 users (show)

Fixed In Version: zeitgeist-0.8.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-22 08:16:27 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 830634 0 None None None Never

Description Luya Tshimbalanga 2011-07-26 16:38:18 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        
comment:        Gnome-activity-journal crashed while running it.
component:      gnome-activity-journal
executable:     /usr/bin/gnome-activity-journal
kernel:         3.0.0-1.fc16.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        gnome-activity-journal-0.6.0-2.fc15
reason:         client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
time:           Tue Jul 26 09:36:38 2011
uid:            500
username:       luya

backtrace:
:client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
:
:Traceback (most recent call last):
:  File "/usr/bin/gnome-activity-journal", line 96, in <module>
:    if CLIENT.get_version() < [0, 3, 9, 99]:
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 450, in get_version
:    return [int(i) for i in self._iface.version()]
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 207, in version
:    self.INTERFACE_NAME, "version")
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 105, in _disconnection_safe
:    meth = getattr(self.__iface, method_name)
:TypeError: getattr(): attribute name must be string
:
:Local variables in innermost frame:
:self: <zeitgeist.client._DBusInterface object at 0x16dc0d0>
:args: ('org.gnome.zeitgeist.Log', 'version')
:method_name: <dbus.proxies._ProxyMethod instance at 0x16a9440>
:reconnecting_error_handler: <function reconnecting_error_handler at 0x16e1398>
:custom_error_handler: None
:kwargs: {}
:original_kwargs: {}

Comment 1 Theodore Lee 2011-07-27 06:18:56 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
This crash occurs when I start GNOME Activity Journal with zeitgeist 0.8.1.

Comment 2 Adrian Wyssmann 2011-07-29 21:44:51 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
start of activity journal endend directly with a crash

Comment 3 Sebastian 2011-08-08 10:35:57 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Opening Activity-journal results in an instant Crash.

Comment 4 Garrett Mitchener 2011-08-10 16:41:50 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I just tried to start it.

Comment 5 Clyde E. Kunkel 2011-08-11 14:01:11 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
booting into desktop

Comment 6 panos 2011-08-12 15:47:59 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
gnome-activity-journal fails to start. Every time.

Comment 7 vikashagrawal1990 2011-08-15 04:57:43 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Clicked on gnome activity joirnal

Comment 8 Jörn Dreyer 2011-08-15 09:50:25 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
gnome-activity-journal fails to start with "attribute name must be string"

Comment 9 Manish Sinha 2011-08-15 15:18:47 UTC
To track down the problem, I need a few more information

zeitgeist daemon version. Can be found by
$ zeitgeist-daemon --version

Then I need daemon log when starting GAJ
Run
$ zeitgeist-daemon --replace

and then start activity journal. Please post the daemon log here.

Comment 10 Theodore Lee 2011-08-16 04:34:52 UTC
$ zeitgeist-daemon --version
0.8.1

$ zeitgeist-daemon --replace
[DEBUG - singleton] Checking for another running instance...
[INFO - zeitgeist.sql] Using database: /home/antiaircraft/.local/share/zeitgeist/activity.sqlite
[DEBUG - zeitgeist.sql] Core schema is good. DB loaded in 15.9571170807ms
[DEBUG - zeitgeist.extension] Searching for system extensions in: /usr/share/zeitgeist/_zeitgeist/engine/extensions
[DEBUG - zeitgeist.extension] Searching for user extensions in: /home/antiaircraft/.local/share/zeitgeist/extensions
[DEBUG - zeitgeist.extension] No extra extensions
[DEBUG - zeitgeist.extension] Found extensions: [<class '_zeitgeist.engine.extensions.storagemonitor.StorageMonitor'>, <class '_zeitgeist.engine.extensions.gnome_activity_journal.ActivityJournalExtension'>, <class '_zeitgeist.engine.extensions.datasource_registry.DataSourceRegistry'>, <class '_zeitgeist.engine.extensions.blacklist.Blacklist'>]
[DEBUG - zeitgeist.extension] Loading extension 'StorageMonitor'
[DEBUG - zeitgeist.storagemonitor] Setting storage medium 900C0FAC0C0F8C82 'SYSTEM' as available
[DEBUG - zeitgeist.storagemonitor] Setting storage medium 64DCC0A3DCC0713A '55 GB File system' as available
[DEBUG - zeitgeist.storagemonitor] Creating NetworkManager network monitor
[DEBUG - zeitgeist.storagemonitor] NetworkManager network state: 70
[DEBUG - zeitgeist.storagemonitor] Setting storage medium net as not available
[DEBUG - zeitgeist.extension] Loading extension 'ActivityJournalExtension'
[DEBUG - zeitgeist.extension] Loading extension 'DataSourceRegistry'
[DEBUG - zeitgeist.datasource_registry] Loaded data-source data from /home/antiaircraft/.local/share/zeitgeist/datasources.pickle
[DEBUG - zeitgeist.extension] Loading extension 'Blacklist'
[DEBUG - zeitgeist.blacklist] No existing blacklist config found
[INFO - root] Trying to start the datahub
[DEBUG - root] Running datahub (/usr/bin/zeitgeist-datahub) with PID=4960
[INFO - root] Starting Zeitgeist service...

$ gnome-activity-journal
Traceback (most recent call last):
  File "/usr/bin/gnome-activity-journal", line 96, in <module>
    if CLIENT.get_version() < [0, 3, 9, 99]:
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 450, in get_version
    return [int(i) for i in self._iface.version()]
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 207, in version
    self.INTERFACE_NAME, "version")
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 105, in _disconnection_safe
    meth = getattr(self.__iface, method_name)
TypeError: getattr(): attribute name must be string

Oddly enough, nothing new seems to show up in the daemon log when starting GAJ for me...

Comment 11 Abhishek Singh 2011-08-19 07:45:07 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
1. Start Gnome Activity Journal

Comment 12 Alex Lancaster 2011-08-20 22:52:30 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Try to start gnome-activity-journal (either from Favorites or from the command-line) get the crash.

Comment 13 Alex Lancaster 2011-08-21 15:26:48 UTC
Ping?  Is this package still being maintained?  Not a single response from package maintainer and this was reported over 3 weeks ago.

Comment 14 Mads Villadsen 2011-08-21 18:05:45 UTC
Sorry. Just not a lot of time right now. I reported the bug upstream here:

https://bugs.launchpad.net/gnome-activity-journal/+bug/830634

Comment 15 Alex Lancaster 2011-08-22 05:22:33 UTC
Thanks, hopefully they will fix it and we can backport a patch.

Comment 16 adriano 2011-08-22 13:56:57 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
launch for the first time from package-kit

Comment 17 Michael Knepher 2011-08-22 15:39:11 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Tried launching gnome activity journal using the gnome-shell overview. The crash occurs immediately, with no ui.

Comment 18 Manish Sinha 2011-08-22 19:27:45 UTC
Hi, I am an upstream co-developer of gnome-activity-journal. I am investigating the bug. It is also happening on Ubuntu 11.10.

Comment 19 savailonei 2011-08-23 08:03:14 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Trying to start the app for the first time after install

Comment 20 Michael Fischer 2011-08-23 12:00:26 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
All you have to do is try to start the app.

Comment 21 Simone Baldelli 2011-08-25 10:05:44 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Start the program

Comment 22 Simone Baldelli 2011-08-25 10:06:20 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Start the program

Comment 23 Matteo Settenvini 2011-08-25 22:02:35 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Every time I try to start the program, it crashes. See the debug output below.

Comment 24 Martijn Faassen 2011-08-29 22:17:47 UTC
I hacked up a fix which I've reported upstream:

https://bugs.launchpad.net/gnome-activity-journal/+bug/830634/comments/3

It's just an ugly hack as I don't really know what's going on, but it seems to make the thing start up.

Comment 25 Matthieu Gautier 2011-08-30 09:16:55 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Just launching activity journal (not sure of the name, I'm in french)
There is no windoz displayed. Just a crash at the beginning.

Everything is up to date.

Comment 26 H. U. Bongartz 2011-08-31 19:27:57 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Just started gnome-activity-journal. Then it crashed.

Comment 27 Fabrício Godoy 2011-09-07 03:12:09 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Just open.

Comment 28 fred 2011-09-07 19:41:10 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
tried to start the app

Comment 29 Ronaldo Nascimento 2011-09-08 22:49:46 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
just tried to open activity journal

Comment 30 Alessandro 2011-09-10 13:50:53 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
starting..

Comment 31 Alessandro 2011-09-10 13:51:30 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
starting..

Comment 32 Alessandro 2011-09-10 13:52:18 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
starting..

Comment 33 Alessandro 2011-09-10 13:53:06 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
starting..

Comment 34 Manish Sinha 2011-09-10 16:45:38 UTC
A new version of gnome-activity-journal (0.8.0) is available. 
https://launchpad.net/gnome-activity-journal/+download

By the time I am looking into the solution provided in this comment
https://bugzilla.redhat.com/show_bug.cgi?id=725821#c24

Comment 35 Manish Sinha 2011-09-10 17:58:13 UTC
The actual problem was not in activity journal but in zeitgeist. In upstream release 0.8.1.1 this issue is fixed

More details from the release manager of zeitgeist
https://bugs.launchpad.net/gnome-activity-journal/+bug/830634/comments/4

Comment 36 Mads Villadsen 2011-09-11 09:59:05 UTC
Moving bug to zeitgeist to track the fix in zeitgeist 0.8.1.1.

Will package gnome-activity-journal 0.8.0 soon.

Comment 37 Manish Sinha 2011-09-11 13:05:45 UTC
Thanks Mads,
If there is a problem with latest version of zeitgeist and gnome-activity-journal then do reopen this bug or file a new one(in this case subscribe me)

Comment 38 Mads Villadsen 2011-09-22 15:24:31 UTC
*** Bug 737378 has been marked as a duplicate of this bug. ***

Comment 39 Juan Francisco Fernández 2011-09-25 15:56:08 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
1.- Try to open Gnome Activity Journal

Comment 40 kbridger 2011-09-26 20:29:11 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Launch Activity Journal

Comment 41 hugotrip 2011-09-29 22:01:55 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
just installed zeitgeist and gnome-activity-journal via yum, and then tried to launch gnome-activity-journal.
And it crashed.
And it crashes every time I try.
(so I've never seen what gnome-activity-journal looks like on my system...)

Comment 42 Clyde E. Kunkel 2011-09-30 03:52:13 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
booted into G-3 desktop with activity journal set to auto start via gnome-session-properties

Comment 43 Ronaldo Nascimento 2011-10-01 00:31:46 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
tried to start

Comment 44 Josip 2011-10-02 21:32:37 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
1. Started the app.
2. BOOM

Comment 45 James Cape 2011-10-04 03:54:48 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Crash on start.

Comment 46 James Cape 2011-10-04 04:04:18 UTC
Bug is fixed in upstream, can it get pushed to updates-testing?

Comment 47 Manish Sinha 2011-10-04 18:07:08 UTC
I have a sincere request - Can you please stop "me too", "crashes on start" etc comments. It doesn't add any value. I am waiting for packager to package 0.8.0 and  push it as update

Comment 48 kbridger 2011-10-04 19:13:28 UTC
Hi Manish - the problem is that these can be reported via ABRT, which has no means of informing the user that the crash is ready for fixing and no further filings will help.

It might be interesting to look at how ABRT deals with duplicates when submitting a crash report to bugzilla.  Perhaps it could tell the user that a duplicate exists, give them a little summary of its state, and then ask if the user wants to continue to submit a "Me too" comment, or maybe just get subscribed.

Anyhow, the ABRT team would be the place to start with this feature idea.  I'm going to point them to this bug to see if they want to consider this feature (or already have it planned).

Comment 49 kbridger 2011-10-04 19:22:00 UTC
In speaking with the ABRT team they already have this idea on the map: https://fedorahosted.org/abrt/ticket/345

Sorry for the mail spam all who are subscribed.

Comment 50 Manish Sinha 2011-10-04 19:44:31 UTC
Hi kbridger,

I think the best way would be to make ABRT find the correct bug and tell them "This bug has already been logged. If you want to receive updates, please subscribe to this bug"

The worst situation I have ever seen was this
http://code.google.com/p/android/issues/detail?id=9392

Comment 51 John O'Dwyer 2011-10-05 20:38:38 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Gnome activity journal crashed on opening

Comment 52 William Lovaton 2011-10-10 03:36:07 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Just installed g-a-j from the fedora repos with yum and started the application.  This is the output from the command line:

[william@xps420 ~]$ gnome-activity-journal 
Traceback (most recent call last):
  File "/usr/bin/gnome-activity-journal", line 88, in <module>
    from src.external import CLIENT, CLIENT_VERSION
  File "/usr/share/gnome-activity-journal/src/external.py", line 88, in <module>
    CLIENT_VERSION = CLIENT.get_version()
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 450, in get_version
    return [int(i) for i in self._iface.version()]
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 207, in version
    self.INTERFACE_NAME, "version")
  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 105, in _disconnection_safe
    meth = getattr(self.__iface, method_name)
TypeError: getattr(): attribute name must be string

Comment 53 Fidtiriadi H. 2011-10-12 03:40:06 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
try to open activity-journal.

Comment 54 jtang613 2011-10-12 20:25:56 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
- Installed it via yum on F16 beta
- Ran it
- Immediately crashed

Comment 55 Alexander Korsunsky 2011-10-12 20:35:03 UTC
Package: gnome-activity-journal-0.8.0-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
1) Start Activity journal from the gnome shell

Comment 56 Michael 2011-10-14 12:06:30 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
i will start the app at the first time

Comment 57 Alessandro 2011-10-15 20:09:33 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
starting...

Comment 58 Manish Sinha 2011-10-15 22:06:15 UTC
Hey kbridger, are you the package maintainer? Please catch me on #zeitgeist on irc://irc.freenode.net as m4n1sh if this bug still persists. 

I  want this issue to be solved for most of the people

Comment 59 Fedora Update System 2011-10-21 02:33:26 UTC
zeitgeist-0.8.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/zeitgeist-0.8.2-1.fc15

Comment 60 Lukas Bezdicka 2011-10-21 17:50:04 UTC
Package: gnome-activity-journal-0.8.0-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Just installed activity journal and tried to run it.

Comment 61 Mads Villadsen 2011-10-22 08:16:27 UTC
Make sure you have upgraded to gnome-activity-journal-0.8.0 and zeitgeist-0.8.2 as well and then try again. It should work now.

Comment 62 Fabrício Godoy 2011-10-22 18:20:15 UTC
(In reply to comment #59)
> zeitgeist-0.8.2-1.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/zeitgeist-0.8.2-1.fc15

Update transaction hangs, must Ctrl+C.

. . .
# yum --enablerepo=updates-testing update zeitgeist
Plugins carregados: auto-update-debuginfo, presto, protectbase, refresh-
                  : packagekit
updates-testing/metalink                                 |  33 kB     00:00     
updates-testing                                          | 4.7 kB     00:00     
updates-testing/primary_db                               | 774 kB     00:03     
0 packages excluded due to repository protections
Configurando o processo de atualização
Resolvendo dependências
--> Executando verificação da transação
---> Package zeitgeist.noarch 0:0.8.1-1.fc15 will be atualizado
---> Package zeitgeist.noarch 0:0.8.2-1.fc15 will be an update
--> Resolução de dependências finalizada

Dependências resolvidas

================================================================================
 Pacote          Arq.         Versão                Repo                   Tam.
================================================================================
Atualizando:
 zeitgeist       noarch       0.8.2-1.fc15          updates-testing       259 k

Resumo da transação
================================================================================
Upgrade       1 Package(s)

Tamanho total do download: 259 k
Correto? [s/N]:s
Baixando pacotes:
Setting up and reading Presto delta metadata
updates-testing/prestodelta                              | 6.3 kB     00:00     
Processing delta metadata
Package(s) data still to download: 259 k
zeitgeist-0.8.2-1.fc15.noarch.rpm                        | 259 kB     00:01     
Executando o rpm_check_debug
Executando teste de transação
Teste de transação completo
Executando a transação
  Atualizando  : zeitgeist-0.8.2-1.fc15.noarch                              1/2

Comment 63 Fabrício Godoy 2011-10-22 18:24:07 UTC
# LANG=C yum --enablerepo=updates-testing update zeitgeist
Loaded plugins: auto-update-debuginfo, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package zeitgeist.noarch 0:0.8.1-1.fc15 will be updated
---> Package zeitgeist.noarch 0:0.8.2-1.fc15 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch         Version               Repository             Size
================================================================================
Updating:
 zeitgeist       noarch       0.8.2-1.fc15          updates-testing       259 k

Transaction Summary
================================================================================
Upgrade       1 Package(s)

Total size: 259 k
Is this ok [y/N]: n
Exiting on user Command
Complete!
[root@fabriciopc ~]# LANG=C yum-complete-transaction
Loaded plugins: auto-update-debuginfo, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 2 elements left to run
--> Running transaction check
---> Package zeitgeist.noarch 0:0.8.1-1.fc15 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package
       Arch   Version      Repository                                      Size
================================================================================
Removing:
 zeitgeist
       noarch 0.8.1-1.fc15 @anaconda-InstallationRepo-201105131943.x86_64 1.3 M

Transaction Summary
================================================================================
Remove        1 Package(s)

Installed size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
alchemist-1.0.37-8.fc12.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
alchemist-1.0.37-8.fc12.x86_64 has missing requires of python-abi = ('0', '2.6', None)
openbios-ppc-1.0-2.fc12.noarch has missing requires of openbios-common = ('0', '1.0', '2.fc12')
rhpl-0.221-2.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
rhpl-0.221-2.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
system-config-display-2.2-1.fc12.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
system-config-display-2.2-1.fc12.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
tsclient-2.0.2-7.fc13.x86_64 has missing requires of libnm-glib.so.2()(64bit)
  Erasing    : zeitgeist-0.8.1-1.fc15.noarch                                1/1 

Removed:
  zeitgeist.noarch 0:0.8.1-1.fc15                                               

Complete!
Cleaning up completed transaction file
[root@fabriciopc ~]# LANG=C yum-complete-transaction
Loaded plugins: auto-update-debuginfo, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
No unfinished transactions left.
[root@fabriciopc ~]# LANG=C yum --enablerepo=updates-testing update zeitgeist
Loaded plugins: auto-update-debuginfo, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Setting up Update Process
No Packages marked for Update
[root@fabriciopc ~]# rpm -qa | grep zeitgeist
libzeitgeist-0.3.10-1.fc15.x86_64
zeitgeist-0.8.2-1.fc15.noarch
zeitgeist-datahub-0.7.0-2.fc15.x86_64

Comment 64 Fabrício Godoy 2011-10-22 18:26:42 UTC
gnome-activity-journal is just running now.

I don't know if I should increase package karma.

Comment 65 Fedora Update System 2011-11-10 17:26:11 UTC
zeitgeist-0.8.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.