Bug 737378 - [abrt] gnome-activity-journal-0.6.0-2.fc15: client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
Summary: [abrt] gnome-activity-journal-0.6.0-2.fc15: client.py:105:_disconnection_safe...
Keywords:
Status: CLOSED DUPLICATE of bug 725821
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-activity-journal
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mads Villadsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3d51cf7d974a46d9b55819a483e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 17:30 UTC by Alessandro
Modified: 2011-09-22 15:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 15:24:30 UTC


Attachments (Terms of Use)

Description Alessandro 2011-09-11 17:30:33 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        
comment:        starting again...
component:      gnome-activity-journal
executable:     /usr/bin/gnome-activity-journal
kernel:         2.6.40.4-5.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        gnome-activity-journal-0.6.0-2.fc15
reason:         client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
time:           Sun Sep 11 19:29:53 2011
uid:            500
username:       alex

backtrace:
:client.py:105:_disconnection_safe:TypeError: getattr(): attribute name must be string
:
:Traceback (most recent call last):
:  File "/usr/bin/gnome-activity-journal", line 96, in <module>
:    if CLIENT.get_version() < [0, 3, 9, 99]:
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 450, in get_version
:    return [int(i) for i in self._iface.version()]
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 207, in version
:    self.INTERFACE_NAME, "version")
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 105, in _disconnection_safe
:    meth = getattr(self.__iface, method_name)
:TypeError: getattr(): attribute name must be string
:
:Local variables in innermost frame:
:self: <zeitgeist.client._DBusInterface object at 0x1b47850>
:args: ('org.gnome.zeitgeist.Log', 'version')
:method_name: <dbus.proxies._ProxyMethod instance at 0x1c85128>
:reconnecting_error_handler: <function reconnecting_error_handler at 0x1b54668>
:custom_error_handler: None
:kwargs: {}
:original_kwargs: {}

Comment 1 Alessandro 2011-09-14 13:43:20 UTC
Package: gnome-activity-journal-0.6.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
doesn't start

Comment 2 Russell Harrison 2011-09-22 00:26:59 UTC
I'm also seeing the same issue

Comment 3 Mads Villadsen 2011-09-22 15:24:30 UTC

*** This bug has been marked as a duplicate of bug 725821 ***


Note You need to log in before you can comment on or make changes to this bug.