Bug 725933 - fwbackups tries to back up non-existent file <fdopen> at end of backup operation
Summary: fwbackups tries to back up non-existent file <fdopen> at end of backup operation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 732274 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-27 02:55 UTC by Brent R. Moore
Modified: 2011-09-07 03:42 UTC (History)
3 users (show)

Fixed In Version: fwbackups-1.43.4-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 01:26:01 UTC


Attachments (Terms of Use)
Debugging info from fwbackups run seeking non-existent file: <fdopen>. (9.22 KB, text/plain)
2011-07-27 02:55 UTC, Brent R. Moore
no flags Details

Description Brent R. Moore 2011-07-27 02:55:15 UTC
Created attachment 515401 [details]
Debugging info from fwbackups run seeking non-existent file: <fdopen>.

Description of problem:

I am trying to back up key directories in the Fedora 15 file system.  The /home directory is excluded (I use a separate backup set for that).  I also exclude /dev, /media, /mnt, /proc, /run, and /tmp.  The backup is saved to the directory /media/Linux Backup/Fedora, which is a directory residing on an ext4 partition on an external hard drive.  The folders /sys/module and /lib/udev/devices, as well as the file /selinux/null, are excluded explicitly under the advanced options tab.  (These seem to be excluded twice in the rsync command generated by fwbackups, for some reason.)

I am doing a direct copy of the files and folders, full backups every time (incremental not selected).  All backup options are selected except 'Follow links'.

The backup completes, then a file with the list of packages is written to /tmp in the backup destination folder, as expected, since the 'Print installed packages to a text file' option was selected.

However, after this is done, fwbackups tries to read the non-existent file in <fdopen> in the directory "/media/Linux Backup".  At least, in this instance, it looked in that directory for <fdopen>.  When running it at other times, it has looked for this "file" in other directories.  I think it looks for the file in whatever directory I happened to be in when I invoked the 'fwbackups' command as superuser (or in /root if it was running automatically as a cron job).

After failing to find the file <fdopen>, fwbackups exits with an error message.  However, fwbackups did seem to back up the data successfully, so I consider the severity to be low.


Version-Release number of selected component (if applicable):
Fedora 15, fwbackups 1.43.4


How reproducible:
Seems to happen consistently.


Steps to Reproduce:
1.  Set fwbackups to back up file system.
2.  Select 'Direct copy of the files and folders' with 'Backups are incremental' de-selected.
3.  Select all backup options except 'Follow links'.
4.  Run backup set manually, or let run as a automatically at a chosen time.
  

Actual results:

fwbackups should back up everything, write a text file containing the list of packages, and exit normally.


Expected results:

fwbackups backs up everything, writes a text file containing the list of packages, but tries to read a non-existent file called "<fdopen>", then exits with an error.


Additional info:

See file attachment for debugging info (from fwbackups --verbose run).

Comment 1 Stewart Adam 2011-08-21 19:52:49 UTC
*** Bug 732274 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2011-08-22 19:51:26 UTC
fwbackups-1.43.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-3.fc15

Comment 3 Fedora Update System 2011-08-22 19:51:33 UTC
fwbackups-1.43.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-3.fc16

Comment 4 Fedora Update System 2011-08-22 19:51:41 UTC
fwbackups-1.43.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-2.fc14

Comment 5 Stewart Adam 2011-08-22 19:54:15 UTC
Thanks for reporting this. I have submitted updates to updates-testing that should fix the problem. If the update works well for you, please consider leaving positive feedback on the update for your release to have it pushed through to stable more quickly.

Comment 6 Fedora Update System 2011-08-23 04:26:36 UTC
Package fwbackups-1.43.4-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fwbackups-1.43.4-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-2.fc14
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-08-31 01:25:56 UTC
fwbackups-1.43.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-08-31 01:42:38 UTC
fwbackups-1.43.4-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-09-07 03:42:27 UTC
fwbackups-1.43.4-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.