Bug 72602 - use "-e" option to xmms in gnome mime setup
use "-e" option to xmms in gnome mime setup
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
Reported: 2002-08-25 19:27 EDT by Gordon Messmer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-22 09:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2002-08-25 19:27:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Nautilus is really dumb about detecting double clicks:  Click on one file, and
then another too soon, it thinks you've double clicked the second file.

Combined with the default action for mp3's and ogg's (xmms), this destroys the
user's playlist.  The default action should be changed to "xmms -e" to be nicer
to users.  This is normally what they want when they double click on files.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Double click a music file while xmms has a playlist loaded.  The playlist will
be reduced to the file you double-clicked.

Additional info:
Comment 1 Gordon Messmer 2002-08-25 19:31:16 EDT
I'm not sure I understand GNOME's mime system correctly.  This bug might be more
appropriate against XMMS, in which case
/usr/share/applications/redhat-audio-player.desktop should be modified to use:

Exec=xmms -e %F
rather than:
Exec=xmms %F
Comment 2 Havoc Pennington 2002-08-25 19:41:02 EDT
The .desktop file mime info would be used for KDE, while 
gnome is in /usr/share/mime-info.
Comment 3 Brent Fox 2002-10-15 15:13:54 EDT
This is actually a few bugs in one.  The first is that nautilus does indeed
count two separate clicks on two different items as a double click on the second

I think that that's the first issue to address.  The xmms problem is annoying
too, but lets do one thing at a time.  In the future, it would be better to file
separate bug reports for different problems and use the "Dependencies" tag in
Bugzilla to link them together.
Comment 4 Brent Fox 2002-10-15 15:23:59 EDT
The nautilus double click issue is in Gnome bugzilla at:
Comment 5 Michael Lee Yohe 2003-08-21 18:35:04 EDT
This has been labeled as RESOLVED FIXED upstream.

Confirming that it is fixed in Nautilus Rawhide (nautilus-2.3.8-1).

Comment 6 Ray Strode [halfline] 2005-05-12 11:53:37 EDT
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 7 Gordon Messmer 2005-05-16 19:49:19 EDT
The problem is still present.  I think that Brent focused on Nautilus' broken
double-click behavior described in this bug report, but I only included that
information to illustrate one way that the xmms bug could be very irritating.

Double-clicking on a music file, or right-clicking and opening with xmms will
still wipe out the playlist.
Comment 8 Ray Strode [halfline] 2005-05-16 22:28:37 EDT
Hi Gordon,

I'm going to reassign this bug to the XMMS component so that the problem has the
opportunity of getting looked at.

This behavior can be changed by editing the .desktop file that ships with XMMS.  
Comment 9 John (J5) Palmieri 2005-07-07 18:00:46 EDT
xmms is part of extras now
Comment 10 Matthias Saou 2005-07-08 03:37:18 EDT
Gordon : I've just checked xmms 1.2.10-15 which I have on my system, and the
Exec line does already have -e %F, and opening a file from nautilus appends it
to the playlist already.

Can you please tell me what version you are using now? It seems to me that this
has been fixed upstream in the bundled .desktop file already.
Comment 11 Matthias Saou 2005-07-22 09:37:59 EDT
Closing this bug CURRENTRELEASE, since as I wrote above, the current desktop
file does have the -e switch. Note also that the desktop file is actually the
"redhat-audio-player.desktop" file from the "redhat-menus" package, so :
- This was in fact probably a bug in "redhat-menus" previously (can't find any
info as to when exactly it might have been fixed).
- Things will break when/if redhat-menus decides to drop that entry, since it is
now pointing to an application which is no longer in Core but in Extras.

Note You need to log in before you can comment on or make changes to this bug.