Bug 72615 - Clicking on /dev from Nautilus's "Tree View" Causes Nautilus to hang at 100% cpu
Clicking on /dev from Nautilus's "Tree View" Causes Nautilus to hang at 100% cpu
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-26 01:18 EDT by Shane R. Stixrud
Modified: 2015-01-07 18:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 04:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shane R. Stixrud 2002-08-26 01:18:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
When using Nautilus to view files I noticed that opening /dev from 
Nautilus's "Tree View" causes the file manager to hang at 100% cpu 
utilization.  Viewing the same directoy by double clicking the directory ICON 
merely causes Nautilus that there are too many files and that some will not be 
displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open Nautilus
2.Click on Tree view
3.Point treeview to /dev
	

Actual Results:  Application hangs at full cpu utlization until killed.

Expected Results:  Display the directory without error.

Additional info:
Comment 1 Havoc Pennington 2002-08-26 01:35:57 EDT
Last time I tried this, it did recover if you waited long enough... it was just
really really slow. I haven't tried with latest though.
Comment 2 Elliot Lee 2002-08-28 15:19:22 EDT
The problem occurs when expanding the tree view for /dev, not simply clicking on /dev in 
the tree view.

And, it does come back eventually like Havoc says.
Comment 3 Elliot Lee 2002-08-28 15:23:33 EDT
Hmm, I got it to hang forever, the second time I tried it.
Comment 4 Alexander Larsson 2003-08-06 11:20:11 EDT
I can't get it do hang at all with the recent rawhide nautilus. Can you repeat
this with nautilus 2.2.5?
Comment 5 Ben Hsu 2003-08-20 01:51:42 EDT
I tried this with the Nautilus in 9.0.93 (2.2.4-4). I opened the side pane,
selected "tree" from the pulldown, and clicked on dev. I also tried navigating
up to / and down to /dev in the main pane. Both actions worked normally.
Nautilus took <5 seconds to open all of /dev (~7500 items)
Comment 6 Alexander Larsson 2003-08-20 04:18:51 EDT
The 2.3.8 in now should be even faster, so I'm closing this.
Comment 7 Michael Lee Yohe 2003-08-21 18:36:20 EDT
Confirming 2.3.8-1 is indeed MUCH faster.

Note You need to log in before you can comment on or make changes to this bug.