Bug 72633 - text going out of the margin boundaries
text going out of the margin boundaries
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Mike McLean
:
: 74218 75217 76941 79596 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 02:42 EDT by Jens Knutson
Modified: 2007-04-18 12:46 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 03:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot to show WTF I'm talking about ;-) (32.13 KB, image/png)
2002-08-26 02:43 EDT, Jens Knutson
no flags Details
Running Dia with ISO-8859-1 (5.32 KB, image/png)
2002-10-02 10:05 EDT, Håvard Wigtil
no flags Details
Running Dia with UTF-8 (5.58 KB, image/png)
2002-10-02 10:06 EDT, Håvard Wigtil
no flags Details

  None (edit)
Description Jens Knutson 2002-08-26 02:42:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
This is a strange one, but I hope I describe it well...

In Abiword, when typing out the first line of a sentance, when I reach the
rightmost margin of the page, it keeps typing beyond the edge of the margin.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type a line in Abiword that hits the end of the right hand margin
2. Keep typing and watch it keep trailing past the edge of the margin
	
Additional info:

I've tried this on multiple machines, one with a Matrox G400, and the other 2
with ATI cards, so it doesn't *seem* to be an X driver bug...

Marking as High because without this getting fixed, Abi is basically useless.
Comment 1 Jens Knutson 2002-08-26 02:43:45 EDT
Created attachment 72944 [details]
Screenshot to show WTF I'm talking about ;-)
Comment 2 Samuel Flory 2002-09-08 18:17:06 EDT
  I'm seeing this issue as well.
Comment 3 Jeremy Katz 2002-09-20 17:10:12 EDT
*** Bug 74218 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-09-20 17:11:07 EDT
Okay, seems to be related to UTF-8 locales.  Looking at it a little more to see
how to fix it properly.
Comment 5 Håvard Wigtil 2002-10-02 10:04:14 EDT
It's also present in 8.0, and it also affetcs Dia.
Workaround: set locale to a ISO-8859-1 one ("LANG=en_GB.ISO-8859-1 dia").

I'm attaching two screenshots, one with LANG=en_GB.UTF-8 and one with
en_GB.ISO-8859-1.
Comment 6 Håvard Wigtil 2002-10-02 10:05:21 EDT
Created attachment 78086 [details]
Running Dia with ISO-8859-1
Comment 7 Håvard Wigtil 2002-10-02 10:06:22 EDT
Created attachment 78087 [details]
Running Dia with UTF-8
Comment 8 Kenneth Rawlings 2002-10-11 14:21:50 EDT
*** Bug 75217 has been marked as a duplicate of this bug. ***
Comment 9 Need Real Name 2002-10-15 09:45:20 EDT
I've also tried upgrading to version 1.3 of Abiword with Abiword's RPM (Redhat
8.0 ships with Abiword 1.2) and that did not solve word wrap issue.
Comment 10 Jeremy Katz 2002-10-30 15:00:43 EST
*** Bug 76941 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2002-12-29 04:01:18 EST
*** Bug 79596 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2002-12-29 14:02:31 EST
Worked around for 1.0.3-1 by making the locale non-utf8 in the abiword wrapper
script.  Abiword 1.1.x handles this better but isn't yet ready for release.
Comment 13 Evan Clarke 2003-02-15 07:38:41 EST
Just letting people know that I am seeing this as well - and it is making using
Abiword/Dia quite fruitless task.

I am running RH 8.0 will all updates installed - a fairly standard install
(aside from the MS core fonts and the Mozilla 1.3B RPMs).

Is there a work around (comment #12 seemed to have something that may work - but
I am afraid that I do not know what he means) - or (preferably) an updated RPM
to install.

This does seem like quite a common problem (google searching lead to lots of
people asking but no solutions) that is still affecting people.

Is there anything that I can do to help (do tests/etc)?  This really does need
to be solved.
Comment 14 Keith 2003-02-18 14:46:39 EST
 Jeremy Katz writes:

>Worked around for 1.0.3-1 by making the locale non-utf8 in the abiword wrapper
script.

Where is the wrapper script?

Note You need to log in before you can comment on or make changes to this bug.