Bug 72639 - gnome-terminal: Control-J (^J) does not work in pine or pico
gnome-terminal: Control-J (^J) does not work in pine or pico
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 74331 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-26 04:21 EDT by Barry K. Nathan
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 21:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2002-08-26 04:21:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823

Description of problem:
Pressing Control-J in pine is supposed to Justify the current paragraph, but
when it's pressed when using pine through gnome-terminal, it does the same thing
as carriage return instead.

Version-Release number of selected component (if applicable):
gnome-terminal 2.0.1-3 (from rawhide)

How reproducible:
Always

Steps to Reproduce:
1. Install pine, or SSH into another box which has pine (Solaris machines in my
case, but it probably doesn't matter).
2. Start pine, start a new message, and type a few words.
3. Hit left arrow a few times, to go back into the middle of a word.
4. Hit control-J.

Actual Results:  New line started in the middle of a word

Expected Results:  It should justify the paragraph (so if there are only a few
words, you'll probably just go to the next line *without* adding a line break in
the middle of a word).

Additional info:

This happens no matter whether pine (4.44-11 from rawhide) is running locally or
whether pine (not sure what versions) is accessed via SSH on a remote machine.
It does not happen at the text console. It does not happen with Konsole instead
of GNOME Terminal. If you need any locale-related info, please tell me how to
find it if possible. (Any locale-related settings were left to their defaults. I
did a US English-only install.)
Comment 1 Barry K. Nathan 2002-08-26 04:23:14 EDT
Ugh, I knew I was forgetting something. :(

I had the same problem in limbo2 as well, but I didn't get around to reporting
it then.
Comment 2 Nalin Dahyabhai 2002-08-27 21:52:44 EDT
Fixing in 0.8.10 -- cr/lf substitition should only be performed when pasting,
not when the user directly inputs text.
Comment 3 Barry K. Nathan 2002-08-30 03:14:04 EDT
I've verified that 0.8.10 indeed fixes it.
Comment 4 Barry K. Nathan 2002-09-21 03:45:30 EDT
changing summary because I saw a dupe of this (bug 74331)
Comment 5 Nalin Dahyabhai 2003-01-13 23:32:17 EST
*** Bug 74331 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.