Bug 726777 - RHEL 6.1 Cluster schema included into cman package does not support suborg option for fence_cisco_ucs agent
Summary: RHEL 6.1 Cluster schema included into cman package does not support suborg op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 728247
TreeView+ depends on / blocked
 
Reported: 2011-07-29 19:03 UTC by Aleksandr Brezhnev
Modified: 2012-10-27 14:38 UTC (History)
9 users (show)

Fixed In Version: cluster-3.0.12.1-6.el6
Doc Type: Bug Fix
Doc Text:
Cause: the relaxng schema used to validate cluster.conf was missing a section to describe the suborg option for fence_cisco_ucs agent Consequence: cluster.conf would fail to validate even if perfectly valid Fix: added suborg section to the relaxng schema Result: cluster.conf validates correctly
Clone Of:
Environment:
Last Closed: 2011-12-06 14:52:40 UTC
ghost518: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1516 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-12-06 00:51:09 UTC

Description Aleksandr Brezhnev 2011-07-29 19:03:26 UTC
Description of problem:

The fence_cisco_ucs agent in RHEL 6.1 Cluster supports the "suborg" option but it is not allowed by the cluster configuration schema defined in the /usr/share/cluster/cluster.rng file.

The problem is similar to BZ #725722 but in this case it is caused by the schema files included into the cman package. 

Version-Release number of selected component (if applicable):
cman-3.0.12-41.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a cluster configuration file as described in BZ #725722
2. Try to verify it with ccs_config_verify

cs_config_validate -f cluster.conf 
Relax-NG validity error : Extra element fence in interleave
tempfile:5: element fence: Relax-NG validity error : Element clusternode failed to validate content
tempfile:4: element clusternode: Relax-NG validity error : Element clusternodes has extra content: clusternode
Configuration fails to validate
  
Actual results:
Configuration fails to validate

Expected results:
The configuration file should validate without errors.

Additional info:
The file validates after adding the same "suborg" definition to /usr/share/cluster/cluster.rng as described in BZ #725722

Comment 3 Nate Straz 2011-08-04 13:33:33 UTC
Development needs to provide unit test results.

https://wiki.test.redhat.com/ClusterStorage/WhyNeedDevTestResults

Comment 4 Fabio Massimo Di Nitto 2011-08-04 13:45:11 UTC
Unit test results for 6.2:

[root@rhel6-node2 ~]# grep -C 1 suborg /usr/share/cluster/cluster.rng 
        <optional>
          <attribute name="suborg" rha:description="Additional path needed to access suborganization" />
        </optional>
[root@rhel6-node2 ~]# 

the generated schema (see bz#680930) contains the suborg information as expected.

For 6.1 an ad-hoc patch to the schema needs to be done and another set of test needs to be performed.

Comment 5 Fabio Massimo Di Nitto 2011-08-04 13:53:17 UTC
  <fencedevices>
    <fencedevice name="xvm" agent="fence_xvm"/>
    <fencedevice name="ucs" agent="fence_ucs" suborg="/org-MyOrg/org-MySubOrg/"/>
  </fencedevices>

[root@rhel6-node2 ~]# ccs_config_validate 
Configuration validates

Comment 9 Fabio Massimo Di Nitto 2011-10-27 08:19:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: the relaxng schema used to validate cluster.conf was missing a section to describe the suborg option for fence_cisco_ucs agent
Consequence: cluster.conf would fail to validate even if perfectly valid
Fix: added suborg section to the relaxng schema
Result: cluster.conf validates correctly

Comment 10 errata-xmlrpc 2011-12-06 14:52:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1516.html


Note You need to log in before you can comment on or make changes to this bug.