Bug 727153 - kde printer applet crashing with new system-config-printer
kde printer applet crashing with new system-config-printer
Status: CLOSED DUPLICATE of bug 726938
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
15
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 08:53 EDT by Sammy
Modified: 2011-08-01 19:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 19:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2011-08-01 08:53:59 EDT
After installing system-config-printer version 1.3.5 the kde gives
a crash of printer-applet message right after login. Going back
to system-config-printer 1.3.4 seems to solve the problem.
Comment 1 Kevin Kofler 2011-08-01 18:12:35 EDT
What kind of crash? An "out of memory" exception? I.e. is this the same as bug #726938?
Comment 2 Sammy 2011-08-01 18:59:58 EDT
When config-system-printer 1.3.5 is installed....immediately aftre login into
the kde session you get a KDE crash message for application printer-applet,
which never starts.

If you try to start from the command line via "python /usr/bin/printer-applet"
you get:
KCrash: Application 'printer-applet' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/home/umar/.kde/socket-localhost/kdeinit4__0

The KDE crash report (no debug symbols) is:
====================================================================
Application: Printer Applet (python), signal: Segmentation fault
[KCrash Handler]
#6  0x000000362d36acac in QObject::startTimer(int) () from /usr/lib64/libQtCore.so.4
#7  0x00007fcf765983a0 in ?? () from /usr/lib/python2.7/site-packages/dbus/mainloop/qt.so
#8  0x000000387c82294d in ?? () from /lib64/libdbus-1.so.3
#9  0x000000387c80f220 in dbus_connection_send_with_reply () from /lib64/libdbus-1.so.3
#10 0x000000387c80f489 in dbus_connection_send_with_reply_and_block () from /lib64/libdbus-1.so.3
#11 0x00007fcf769b0c95 in ?? () from /usr/lib64/python2.7/site-packages/_dbus_bindings.so
#12 0x00000038ceadfae8 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#13 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#14 0x00000038ceadfa86 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#15 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#16 0x00000038ceadfa86 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#17 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#18 0x00000038cea6daa3 in ?? () from /usr/lib64/libpython2.7.so.1.0
#19 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#20 0x00000038cea9a2bd in ?? () from /usr/lib64/libpython2.7.so.1.0
#21 0x00000038cea9d893 in ?? () from /usr/lib64/libpython2.7.so.1.0
#22 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#23 0x00000038ceade0a3 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#24 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#25 0x00000038cea6d9ac in ?? () from /usr/lib64/libpython2.7.so.1.0
#26 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#27 0x00000038cea57b6f in ?? () from /usr/lib64/libpython2.7.so.1.0
#28 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#29 0x00000038cea9dc76 in ?? () from /usr/lib64/libpython2.7.so.1.0
#30 0x00000038cea9d8d8 in ?? () from /usr/lib64/libpython2.7.so.1.0
#31 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#32 0x00000038ceade0a3 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#33 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#34 0x00000038cea6d9ac in ?? () from /usr/lib64/libpython2.7.so.1.0
#35 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#36 0x00000038cea57b6f in ?? () from /usr/lib64/libpython2.7.so.1.0
#37 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#38 0x00000038cea9dc76 in ?? () from /usr/lib64/libpython2.7.so.1.0
#39 0x00000038cea9d8d8 in ?? () from /usr/lib64/libpython2.7.so.1.0
#40 0x00000038cea48fe3 in PyObject_Call () from /usr/lib64/libpython2.7.so.1.0
#41 0x00000038ceade0a3 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.7.so.1.0
#42 0x00000038ceae1125 in PyEval_EvalCodeEx () from /usr/lib64/libpython2.7.so.1.0
#43 0x00000038ceae1252 in PyEval_EvalCode () from /usr/lib64/libpython2.7.so.1.0
#44 0x00000038ceafb3ac in ?? () from /usr/lib64/libpython2.7.so.1.0
#45 0x00000038ceafc1e0 in PyRun_FileExFlags () from /usr/lib64/libpython2.7.so.1.0
#46 0x00000038ceafcc5f in PyRun_SimpleFileExFlags () from /usr/lib64/libpython2.7.so.1.0
#47 0x00000038ceb0e285 in Py_Main () from /usr/lib64/libpython2.7.so.1.0
#48 0x0000003d50c2139d in __libc_start_main () from /lib64/libc.so.6
#49 0x0000000000400651 in _start ()
===========================================================================
Comment 3 Sammy 2011-08-01 19:12:24 EDT
Perhaps, I installed debug file but did not get anything useful. However,
sometimes you get the out of memory message (at the end):
====================================================================
$ python /usr/bin/printer-applet
QObject::startTimer: QTimer can only be used with threads started with QThread
Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1163, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 300, in __init__
    notification = NewPrinterNotification(bus, self)
  File "/usr/bin/printer-applet", line 1052, in __init__
    bus_name = dbus.service.BusName (PDS_OBJ, bus=bus)
  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 129, in __new__
    retval = bus.request_name(name, name_flags)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 306, in request_name
    'su', (name, flags))
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoMemory: Not enough memory
================================================================
Comment 4 Sammy 2011-08-01 19:15:24 EDT
Switching to system-config-printer 1.3.4 all works fine:

=======================================================
$ python /usr/bin/printer-applet
=======================================================

no crash, the daemon is running.
Comment 5 Kevin Kofler 2011-08-01 19:20:14 EDT
Looks like this is the same bug then, thanks for the additional details.

*** This bug has been marked as a duplicate of bug 726938 ***

Note You need to log in before you can comment on or make changes to this bug.