Bug 726938 - [abrt] kdeutils-printer-applet-4.6.5-2.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoMemory: Not enough memory
Summary: [abrt] kdeutils-printer-applet-4.6.5-2.fc15: connection.py:630:call_blocking:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ff779d54a17499764d17b736c3c...
: 727153 727681 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-31 08:06 UTC by Mateusz M.
Modified: 2011-08-12 18:19 UTC (History)
14 users (show)

Fixed In Version: system-config-printer-1.3.5-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-12 10:58:16 UTC


Attachments (Terms of Use)

Description Mateusz M. 2011-07-31 08:06:22 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        python /usr/bin/printer-applet
comment:        run system
component:      kdeutils
executable:     /usr/bin/printer-applet
kernel:         3.0.0-git13
os_release:     Fedora release 15 (Lovelock)
package:        kdeutils-printer-applet-4.6.5-2.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoMemory: Not enough memory
time:           Sun Jul 31 09:04:05 2011
uid:            500
username:       blink

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoMemory: Not enough memory
:
:Traceback (most recent call last):
:  File "/usr/bin/printer-applet", line 1163, in <module>
:    applet = JobManager()
:  File "/usr/bin/printer-applet", line 300, in __init__
:    notification = NewPrinterNotification(bus, self)
:  File "/usr/bin/printer-applet", line 1052, in __init__
:    bus_name = dbus.service.BusName (PDS_OBJ, bus=bus)
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 129, in __new__
:    retval = bus.request_name(name, name_flags)
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 306, in request_name
:    'su', (name, flags))
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.NoMemory: Not enough memory
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SystemBus (system) at 0x26ae770>
:args: ('com.redhat.NewPrinterNotification', 0)
:utf8_strings: False
:bus_name: 'org.freedesktop.DBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/freedesktop/DBus'
:timeout: -1.0
:signature: 'su'
:dbus_interface: 'org.freedesktop.DBus'
:message: <dbus.lowlevel.MethodCallMessage object at 0x283e8d0>
:method: 'RequestName'

Comment 1 Kevin Kofler 2011-07-31 17:44:37 UTC
It's kinda normal that an exception gets thrown if you run out of memory. ;-)

Comment 2 Ian Pilcher 2011-08-01 22:06:04 UTC
Hardly normal to run out of memory when logging in after a reboot on a x86_64
system with 16GB of memory, however.

Comment 3 Kevin Kofler 2011-08-01 22:11:13 UTC
False memory error? What the heck?

Might this be caused by a system-config-printer update? See also (the unfortunately very vague on details) bug #727153.

Comment 4 Kevin Kofler 2011-08-01 23:20:15 UTC
*** Bug 727153 has been marked as a duplicate of this bug. ***

Comment 5 Kevin Kofler 2011-08-01 23:22:52 UTC
As per bug #727153, this is caused by system-config-printer 1.3.5.

Comment 6 Tim Waugh 2011-08-02 14:49:08 UTC
Fixed upstream in b1420ee264d6c462454919492f53a506d7bce0e1.

Comment 7 Sammy 2011-08-02 15:12:50 UTC
Confirmed....rebulding system-config-printer with the above patch fixes the
crash.

Comment 8 Kevin Kofler 2011-08-02 15:23:25 UTC
Can you please update the update in updates-testing with the fix?

Comment 9 Fedora Update System 2011-08-02 15:27:33 UTC
system-config-printer-1.3.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.5-3.fc15

Comment 10 GoinEasy9 2011-08-02 20:29:51 UTC
I also had the symptoms described in Bug #727153 with printer applet segfaulting at boot.  Installation of system-config-printer, udev and libs 1.3.5-3 solved the problem, thank you.

Comment 11 Kevin Kofler 2011-08-02 22:09:16 UTC
*** Bug 727681 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2011-08-03 02:31:14 UTC
Package system-config-printer-1.3.5-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.5-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.5-3.fc15
then log in and leave karma (feedback).

Comment 13 Edgar Hoch 2011-08-03 09:12:23 UTC
system-config-printer-1.3.5-3.fc15 solves the problem I had with system-config-printer-1.3.5-1.fc15. That was that when starting adding a new printer, then there was no network printer and no network methods found (I could enter a url only).

But system-config-printer-1.3.5-3.fc15.i686 on a fresh (today) installed system shows me another error when adding a new printer with system-config-printer, but only on this i686 system, not on another x86_64 system (installed some weeks ago, but with automatic updates and system-config-printer-1.3.5-3.fc15):

ERROR:dbus.proxies:Introspect error on :1.11:/org/freedesktop/PackageKit: dbus.exceptions.IntrospectionParserException: Error parsing introspect data: <class 'xml.parsers.expat.ExpatError'>: unbound prefix: line 5, column 4

I am not sure if this is an independent bug which needs a new bug report.

Another note: When there is a remote network printer automatically found from cups then I cannot add a new local printer with the same name. This was possible at least with fedora 14. But after creation of the new local printer with another name I can rename that printer to the same name as a already existing remote network printer. Then that already existing remote printer will be renamed to that name concatenated with "@" and the ip address of the remote print server. (I am not sure if this also should be a new bug report?)

Comment 14 Tim Waugh 2011-08-03 12:02:29 UTC
(In reply to comment #13)
> ERROR:dbus.proxies:Introspect error on :1.11:/org/freedesktop/PackageKit:
> dbus.exceptions.IntrospectionParserException: Error parsing introspect data:
> <class 'xml.parsers.expat.ExpatError'>: unbound prefix: line 5, column 4

Could this be bug #630931?

> Another note: When there is a remote network printer automatically found from
> cups then I cannot add a new local printer with the same name. This was
> possible at least with fedora 14. But after creation of the new local printer
> with another name I can rename that printer to the same name as a already
> existing remote network printer. Then that already existing remote printer will
> be renamed to that name concatenated with "@" and the ip address of the remote
> print server. (I am not sure if this also should be a new bug report?)

A new bug report please.  It should prevent you from adding a queue with the same name as an already existing local queue, but if there is a remote queue with the same name that should be allowed (and it will create an implicit class of the two).

Comment 15 Fedora Update System 2011-08-12 10:57:21 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-08-12 18:18:34 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.