Bug 727247 - should not depend on MAKEDEV
should not depend on MAKEDEV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 734505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 12:16 EDT by Lennart Poettering
Modified: 2011-09-30 15:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.12.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:48:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2011-08-01 12:16:21 EDT
On F16 libguestfs seems to be pulled in by virtmanager and pulls in MAKEDEV.

MAKEDEV is entirely obsolete and should not be used anymore. In times of udev and dynamic major/minor numbers it has no use at all, and is a source of confusion. Please drop the dependency on MAKEDEV, as that tool should not be around on any new installation.

In fact, MAKEDEV should be removed entirely from the distribution.
Comment 1 Richard W.M. Jones 2011-08-01 14:38:18 EDT
We're probably going to drop the virt-manager -> libguestfs
dependency.  It's a shame RPM doesn't support optional
deps like dpkg.

As for the libguestfs -> MAKEDEV dependency, it shouldn't
be there.  It's for a fallback case when udev doesn't exist,
but since udev always exists, there's no reason to have it.
I'll remove it soon.
Comment 2 Cole Robinson 2011-08-02 10:57:42 EDT
FYI, virt-manager in rawhide and f16-updates has dropped the libguestfs dep
Comment 3 Richard W.M. Jones 2011-08-30 13:47:03 EDT
*** Bug 734505 has been marked as a duplicate of this bug. ***
Comment 4 Richard W.M. Jones 2011-08-30 13:48:04 EDT
This is now fixed in
libguestfs 1:1.13.10-2.fc17
libguestfs 1:1.12.5-3.fc16

These packages are still building.
Comment 5 Fedora Update System 2011-08-30 14:10:59 EDT
libguestfs-1.12.5-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libguestfs-1.12.5-3.fc16
Comment 6 Fedora Update System 2011-08-30 16:46:06 EDT
Package libguestfs-1.12.5-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libguestfs-1.12.5-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libguestfs-1.12.5-3.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-09-01 16:00:28 EDT
libguestfs-1.12.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libguestfs-1.12.6-1.fc16
Comment 8 Fedora Update System 2011-09-30 15:47:37 EDT
libguestfs-1.12.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.