Bug 727402 - fileconflicts failure in 16-Alpha.TC1 DVDs - kate/kdesdk
fileconflicts failure in 16-Alpha.TC1 DVDs - kate/kdesdk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kate (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker 727583
  Show dependency treegraph
 
Reported: 2011-08-01 23:35 EDT by Andre Robatino
Modified: 2011-08-06 00:26 EDT (History)
10 users (show)

See Also:
Fixed In Version: kdesdk-4.7.0-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 727583 (view as bug list)
Environment:
Last Closed: 2011-08-06 00:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-08-01 23:35:34 EDT
Description of problem:

On i386:

Getting complete filelist for:
file:///media/
383516 files found.

Looking for duplicated filenames:
335 duplicates found.

Doing more advanced checks to see if these are real conflicts:
  5% complete (    16/   335,   119/sec),    2 found - eta 0:00:02
 10% complete (    32/   335,    95/sec),    4 found - eta 0:00:02
 14% complete (    48/   335,   143/sec),    6 found - eta 0:00:02
 19% complete (    64/   335,   154/sec),    8 found - eta 0:00:02
 24% complete (    80/   335,   139/sec),   10 found - eta 0:00:02
 29% complete (    96/   335,   151/sec),   13 found - eta 0:00:01
 33% complete (   112/   335,   133/sec),   15 found - eta 0:00:01
 38% complete (   128/   335,   131/sec),   20 found - eta 0:00:01
 43% complete (   144/   335,   125/sec),   24 found - eta 0:00:01
 48% complete (   160/   335,   252/sec),   25 found - eta 0:00:01
 53% complete (   176/   335,   116/sec),   31 found - eta 0:00:01
 57% complete (   192/   335,   303/sec),   34 found - eta 0:00:01
 62% complete (   208/   335,   130/sec),   36 found - eta 0:00:00
 67% complete (   224/   335,   168/sec),   37 found - eta 0:00:00
 72% complete (   240/   335,    72/sec),   40 found - eta 0:00:00
 76% complete (   256/   335,   120/sec),   43 found - eta 0:00:00
 81% complete (   272/   335,   200/sec),   45 found - eta 0:00:00
 86% complete (   288/   335,   118/sec),   48 found - eta 0:00:00
 91% complete (   304/   335,   127/sec),   52 found - eta 0:00:00
 96% complete (   320/   335,   104/sec),   57 found - eta 0:00:00
61 file conflicts found.
1 package conflicts found.

== Package conflicts ==
kate-libs-4.7.0-1.fc16.i686
kdesdk-libs-4.6.95-1.fc16.i686


== File conflicts, listed by conflicting packages ==
libreport-python-2.0.5-2.fc16.i686
report-newt-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/NewtIO.py
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyc
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyo

kate-4.7.0-1.fc16.i686
kdesdk-4.6.95-1.fc16.i686
  /usr/bin/kate
  /usr/bin/ktesnippets_editor
  /usr/lib/kde4/kate_kttsd.so
  /usr/lib/kde4/katebacktracebrowserplugin.so
  /usr/lib/kde4/katebuildplugin.so
  /usr/lib/kde4/katectagsplugin.so
  /usr/lib/kde4/kateexternaltoolsplugin.so
  /usr/lib/kde4/katefilebrowserplugin.so
  /usr/lib/kde4/katefiletemplates.so
  /usr/lib/kde4/katefiletreeplugin.so
  /usr/lib/kde4/katefindinfilesplugin.so
  /usr/lib/kde4/kategdbplugin.so
  /usr/lib/kde4/katekonsoleplugin.so
  /usr/lib/kde4/katemailfilesplugin.so
  /usr/lib/kde4/kateopenheaderplugin.so
  /usr/lib/kde4/katequickdocumentswitcherplugin.so
  /usr/lib/kde4/katesearchplugin.so
  /usr/lib/kde4/katesnippets_tngplugin.so
  /usr/lib/kde4/katesqlplugin.so
  /usr/lib/kde4/katesymbolviewerplugin.so
  /usr/lib/kde4/katetabbarextensionplugin.so
  /usr/lib/kde4/katetabifyplugin.so
  /usr/lib/kde4/katetextfilterplugin.so
  /usr/lib/kde4/katexmlcheckplugin.so
  /usr/lib/kde4/katexmltoolsplugin.so
  /usr/lib/kde4/plasma_applet_katesession.so
  /usr/lib/libkdeinit4_kate.so
  /usr/share/applications/kde4/kate.desktop
  /usr/share/applications/kde4/ktesnippets_editor.desktop
  /usr/share/doc/HTML/en/kate/index.cache.bz2
  /usr/share/kde4/services/kate_kttsd.desktop
  /usr/share/kde4/services/katebacktracebrowserplugin.desktop
  /usr/share/kde4/services/katebuildplugin.desktop
  /usr/share/kde4/services/katectagsplugin.desktop
  /usr/share/kde4/services/kateexternaltoolsplugin.desktop
  /usr/share/kde4/services/katefilebrowserplugin.desktop
  /usr/share/kde4/services/katefiletemplates.desktop
  /usr/share/kde4/services/katefiletreeplugin.desktop
  /usr/share/kde4/services/katefindinfilesplugin.desktop
  /usr/share/kde4/services/kategdbplugin.desktop
  /usr/share/kde4/services/katekonsoleplugin.desktop
  /usr/share/kde4/services/katemailfilesplugin.desktop
  /usr/share/kde4/services/kateopenheader.desktop
  /usr/share/kde4/services/katequickdocumentswitcher.desktop
  /usr/share/kde4/services/katesearch.desktop
  /usr/share/kde4/services/katesnippets_tngplugin.desktop
  /usr/share/kde4/services/katesql.desktop
  /usr/share/kde4/services/katesymbolviewer.desktop
  /usr/share/kde4/services/katetabbarextension.desktop
  /usr/share/kde4/services/katetabifyplugin.desktop
  /usr/share/kde4/services/katetextfilter.desktop
  /usr/share/kde4/services/katexmlcheck.desktop
  /usr/share/kde4/services/katexmltools.desktop
  /usr/share/kde4/services/plasma-applet-katesession.desktop
  /usr/share/kde4/servicetypes/kateplugin.desktop

libreport-python-2.0.5-2.fc16.i686
report-gtk-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/GTKIO.py
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyc
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyo


On x86_64:

Getting complete filelist for:
file:///media/
383394 files found.

Looking for duplicated filenames:
341 duplicates found.

Doing more advanced checks to see if these are real conflicts:
  5% complete (    17/   341,   135/sec),    1 found - eta 0:00:02
 10% complete (    34/   341,   117/sec),    3 found - eta 0:00:02
 15% complete (    51/   341,   163/sec),    4 found - eta 0:00:02
 20% complete (    68/   341,   210/sec),    6 found - eta 0:00:01
 25% complete (    85/   341,   100/sec),   14 found - eta 0:00:01
 30% complete (   102/   341,   149/sec),   18 found - eta 0:00:01
 35% complete (   119/   341,   105/sec),   19 found - eta 0:00:01
 40% complete (   136/   341,   146/sec),   23 found - eta 0:00:01
 45% complete (   153/   341,   176/sec),   25 found - eta 0:00:01
 50% complete (   170/   341,   180/sec),   28 found - eta 0:00:01
 55% complete (   187/   341,   387/sec),   31 found - eta 0:00:01
 60% complete (   204/   341,   193/sec),   33 found - eta 0:00:00
 65% complete (   221/   341,   124/sec),   37 found - eta 0:00:00
 70% complete (   238/   341,   124/sec),   38 found - eta 0:00:00
 75% complete (   255/   341,   178/sec),   43 found - eta 0:00:00
 80% complete (   272/   341,   200/sec),   44 found - eta 0:00:00
 85% complete (   289/   341,   102/sec),   49 found - eta 0:00:00
 90% complete (   306/   341,   105/sec),   54 found - eta 0:00:00
 95% complete (   323/   341,   134/sec),   59 found - eta 0:00:00
100% complete (   340/   341,   126/sec),   61 found - eta 0:00:00
61 file conflicts found.
1 package conflicts found.

== Package conflicts ==
kate-libs-4.7.0-1.fc16.x86_64
kdesdk-libs-4.6.95-1.fc16.x86_64


== File conflicts, listed by conflicting packages ==
kate-4.7.0-1.fc16.x86_64
kdesdk-4.6.95-1.fc16.x86_64
  /usr/bin/kate
  /usr/bin/ktesnippets_editor
  /usr/lib64/kde4/kate_kttsd.so
  /usr/lib64/kde4/katebacktracebrowserplugin.so
  /usr/lib64/kde4/katebuildplugin.so
  /usr/lib64/kde4/katectagsplugin.so
  /usr/lib64/kde4/kateexternaltoolsplugin.so
  /usr/lib64/kde4/katefilebrowserplugin.so
  /usr/lib64/kde4/katefiletemplates.so
  /usr/lib64/kde4/katefiletreeplugin.so
  /usr/lib64/kde4/katefindinfilesplugin.so
  /usr/lib64/kde4/kategdbplugin.so
  /usr/lib64/kde4/katekonsoleplugin.so
  /usr/lib64/kde4/katemailfilesplugin.so
  /usr/lib64/kde4/kateopenheaderplugin.so
  /usr/lib64/kde4/katequickdocumentswitcherplugin.so
  /usr/lib64/kde4/katesearchplugin.so
  /usr/lib64/kde4/katesnippets_tngplugin.so
  /usr/lib64/kde4/katesqlplugin.so
  /usr/lib64/kde4/katesymbolviewerplugin.so
  /usr/lib64/kde4/katetabbarextensionplugin.so
  /usr/lib64/kde4/katetabifyplugin.so
  /usr/lib64/kde4/katetextfilterplugin.so
  /usr/lib64/kde4/katexmlcheckplugin.so
  /usr/lib64/kde4/katexmltoolsplugin.so
  /usr/lib64/kde4/plasma_applet_katesession.so
  /usr/lib64/libkdeinit4_kate.so
  /usr/share/applications/kde4/kate.desktop
  /usr/share/applications/kde4/ktesnippets_editor.desktop
  /usr/share/doc/HTML/en/kate/index.cache.bz2
  /usr/share/kde4/services/kate_kttsd.desktop
  /usr/share/kde4/services/katebacktracebrowserplugin.desktop
  /usr/share/kde4/services/katebuildplugin.desktop
  /usr/share/kde4/services/katectagsplugin.desktop
  /usr/share/kde4/services/kateexternaltoolsplugin.desktop
  /usr/share/kde4/services/katefilebrowserplugin.desktop
  /usr/share/kde4/services/katefiletemplates.desktop
  /usr/share/kde4/services/katefiletreeplugin.desktop
  /usr/share/kde4/services/katefindinfilesplugin.desktop
  /usr/share/kde4/services/kategdbplugin.desktop
  /usr/share/kde4/services/katekonsoleplugin.desktop
  /usr/share/kde4/services/katemailfilesplugin.desktop
  /usr/share/kde4/services/kateopenheader.desktop
  /usr/share/kde4/services/katequickdocumentswitcher.desktop
  /usr/share/kde4/services/katesearch.desktop
  /usr/share/kde4/services/katesnippets_tngplugin.desktop
  /usr/share/kde4/services/katesql.desktop
  /usr/share/kde4/services/katesymbolviewer.desktop
  /usr/share/kde4/services/katetabbarextension.desktop
  /usr/share/kde4/services/katetabifyplugin.desktop
  /usr/share/kde4/services/katetextfilter.desktop
  /usr/share/kde4/services/katexmlcheck.desktop
  /usr/share/kde4/services/katexmltools.desktop
  /usr/share/kde4/services/plasma-applet-katesession.desktop
  /usr/share/kde4/servicetypes/kateplugin.desktop

libreport-python-2.0.5-2.fc16.x86_64
report-gtk-0.23-0.fc16.x86_64
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.py
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.pyc
  /usr/lib64/python2.7/site-packages/report/io/GTKIO.pyo

libreport-python-2.0.5-2.fc16.x86_64
report-newt-0.23-0.fc16.x86_64
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.py
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.pyc
  /usr/lib64/python2.7/site-packages/report/io/NewtIO.pyo


Version-Release number of selected component (if applicable):
16-Alpha.TC1 DVDs
Comment 1 Hongqing Yang 2011-08-02 01:53:38 EDT
Looking for duplicated filenames:
335 duplicates found.

Doing more advanced checks to see if these are real conflicts:
  5% complete (    16/   335,   229/sec),    2 found - eta 0:00:01
 10% complete (    32/   335,   224/sec),    4 found - eta 0:00:01
 14% complete (    48/   335,   265/sec),    6 found - eta 0:00:01
 19% complete (    64/   335,   290/sec),    8 found - eta 0:00:01
 24% complete (    80/   335,   235/sec),   10 found - eta 0:00:01
 29% complete (    96/   335,   276/sec),   13 found - eta 0:00:00
 33% complete (   112/   335,   209/sec),   15 found - eta 0:00:00
 38% complete (   128/   335,   263/sec),   20 found - eta 0:00:00
 43% complete (   144/   335,   252/sec),   24 found - eta 0:00:00
 48% complete (   160/   335,   472/sec),   25 found - eta 0:00:00
 53% complete (   176/   335,   277/sec),   31 found - eta 0:00:00
 57% complete (   192/   335,   534/sec),   34 found - eta 0:00:00
 62% complete (   208/   335,   300/sec),   36 found - eta 0:00:00
 67% complete (   224/   335,   325/sec),   37 found - eta 0:00:00
 72% complete (   240/   335,   167/sec),   40 found - eta 0:00:00
 76% complete (   256/   335,   306/sec),   43 found - eta 0:00:00
 81% complete (   272/   335,   366/sec),   45 found - eta 0:00:00
 86% complete (   288/   335,   247/sec),   48 found - eta 0:00:00
 91% complete (   304/   335,   213/sec),   52 found - eta 0:00:00
 96% complete (   320/   335,   194/sec),   57 found - eta 0:00:00
61 file conflicts found.
1 package conflicts found.

== Package conflicts ==
kate-libs-4.7.0-1.fc16.i686
kdesdk-libs-4.6.95-1.fc16.i686


== File conflicts, listed by conflicting packages ==
libreport-python-2.0.5-2.fc16.i686
report-newt-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/NewtIO.py
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyc
  /usr/lib/python2.7/site-packages/report/io/NewtIO.pyo

kate-4.7.0-1.fc16.i686
kdesdk-4.6.95-1.fc16.i686
  /usr/bin/kate
  /usr/bin/ktesnippets_editor
  /usr/lib/kde4/kate_kttsd.so
  /usr/lib/kde4/katebacktracebrowserplugin.so
  /usr/lib/kde4/katebuildplugin.so
  /usr/lib/kde4/katectagsplugin.so
  /usr/lib/kde4/kateexternaltoolsplugin.so
  /usr/lib/kde4/katefilebrowserplugin.so
  /usr/lib/kde4/katefiletemplates.so
  /usr/lib/kde4/katefiletreeplugin.so
  /usr/lib/kde4/katefindinfilesplugin.so
  /usr/lib/kde4/kategdbplugin.so
  /usr/lib/kde4/katekonsoleplugin.so
  /usr/lib/kde4/katemailfilesplugin.so
  /usr/lib/kde4/kateopenheaderplugin.so
  /usr/lib/kde4/katequickdocumentswitcherplugin.so
  /usr/lib/kde4/katesearchplugin.so
  /usr/lib/kde4/katesnippets_tngplugin.so
  /usr/lib/kde4/katesqlplugin.so
  /usr/lib/kde4/katesymbolviewerplugin.so
  /usr/lib/kde4/katetabbarextensionplugin.so
  /usr/lib/kde4/katetabifyplugin.so
  /usr/lib/kde4/katetextfilterplugin.so
  /usr/lib/kde4/katexmlcheckplugin.so
  /usr/lib/kde4/katexmltoolsplugin.so
  /usr/lib/kde4/plasma_applet_katesession.so
  /usr/lib/libkdeinit4_kate.so
  /usr/share/applications/kde4/kate.desktop
  /usr/share/applications/kde4/ktesnippets_editor.desktop
  /usr/share/doc/HTML/en/kate/index.cache.bz2
  /usr/share/kde4/services/kate_kttsd.desktop
  /usr/share/kde4/services/katebacktracebrowserplugin.desktop
  /usr/share/kde4/services/katebuildplugin.desktop
  /usr/share/kde4/services/katectagsplugin.desktop
  /usr/share/kde4/services/kateexternaltoolsplugin.desktop
  /usr/share/kde4/services/katefilebrowserplugin.desktop
  /usr/share/kde4/services/katefiletemplates.desktop
  /usr/share/kde4/services/katefiletreeplugin.desktop
  /usr/share/kde4/services/katefindinfilesplugin.desktop
  /usr/share/kde4/services/kategdbplugin.desktop
  /usr/share/kde4/services/katekonsoleplugin.desktop
  /usr/share/kde4/services/katemailfilesplugin.desktop
  /usr/share/kde4/services/kateopenheader.desktop
  /usr/share/kde4/services/katequickdocumentswitcher.desktop
  /usr/share/kde4/services/katesearch.desktop
  /usr/share/kde4/services/katesnippets_tngplugin.desktop
  /usr/share/kde4/services/katesql.desktop
  /usr/share/kde4/services/katesymbolviewer.desktop
  /usr/share/kde4/services/katetabbarextension.desktop
  /usr/share/kde4/services/katetabifyplugin.desktop
  /usr/share/kde4/services/katetextfilter.desktop
  /usr/share/kde4/services/katexmlcheck.desktop
  /usr/share/kde4/services/katexmltools.desktop
  /usr/share/kde4/services/plasma-applet-katesession.desktop
  /usr/share/kde4/servicetypes/kateplugin.desktop

libreport-python-2.0.5-2.fc16.i686
report-gtk-0.23-0.fc16.i686
  /usr/lib/python2.7/site-packages/report/io/GTKIO.py
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyc
  /usr/lib/python2.7/site-packages/report/io/GTKIO.pyo
Comment 2 Kevin Kofler 2011-08-02 10:30:00 EDT
Ugh, we only have kdesdk-4.6.95-1.fc16 in f16, kdesdk-4.7.0-1.fc16 is stuck in f16-updates-candidate.
Comment 3 Kevin Kofler 2011-08-02 10:33:52 EDT
The problem is that kdesdk contains Umbrello which currently doesn't build with Qt 4.8. We now have https://admin.fedoraproject.org/updates/kdesdk-4.7.0-1.fc16 which "fixes" this by not including Umbrello, which surely can't be the solution. But I guess there isn't much choice for the Alpha. (The alternative would be to undo the standalone Kate packaging, which also affects at least kdebase.)
Comment 4 Fedora Update System 2011-08-02 11:32:59 EDT
kdesdk-4.7.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kdesdk-4.7.0-1.fc16
Comment 5 Fedora Update System 2011-08-02 16:51:00 EDT
Package kdesdk-4.7.0-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdesdk-4.7.0-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kdesdk-4.7.0-1.fc16
then log in and leave karma (feedback).
Comment 6 Tim Flink 2011-08-04 16:21:13 EDT
This bug hits the following Fedora 16 alpha release criterion [1]:

There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install

+1 Alpha Blocker

[1] http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 7 Tim Flink 2011-08-05 14:06:17 EDT
Discussed in the 2011-08-05 blocker review meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install 

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 8 Kevin Kofler 2011-08-05 16:50:56 EDT
Fix here:
https://admin.fedoraproject.org/updates/kdesdk-4.7.0-2.fc16

Already queued for stable, please pull this into the Alpha.
Comment 9 Fedora Update System 2011-08-06 00:26:01 EDT
kdesdk-4.7.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.