Bug 727428 - Unable to read group information from repositories
Summary: Unable to read group information from repositories
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Bill Nottingham
URL:
Whiteboard:
: 728422 (view as bug list)
Depends On:
Blocks: F16Alpha, F16AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2011-08-02 06:31 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-05 17:34:18 UTC


Attachments (Terms of Use)
Unable to read group information from repositories (11.59 KB, image/png)
2011-08-02 06:31 UTC, Tao Wu
no flags Details
error log of anaconda 16.14 (17.20 KB, text/plain)
2011-08-02 06:34 UTC, Tao Wu
no flags Details

Description Tao Wu 2011-08-02 06:31:43 UTC
Created attachment 516256 [details]
Unable to read group information from repositories

Description of problem:
anaconda 16.14 does not try to grab its inside URL such as  "http://mirrors.fedoraproject.org/metalink?repo=fedora-16&arch=i386" when it can not find the install source on the iso image, which stops the installation process.

Version-Release number of selected component (if applicable):
16.14 

How reproducible:
always

Steps to Reproduce:
1. Install the Fedora-16-Alpha.TC1-i386-netinst.iso on "Virtual Machine Manager 0.8.7"
2. Do not pass any boot argument which can change the default repo, like " repo=http://download.englab.nay.redhat.com/..... "
  
Actual results:
anaconda reports an error like the attachment looks

Expected results:
anaconda work correctly

Additional info:

Comment 1 Tao Wu 2011-08-02 06:34:02 UTC
Created attachment 516257 [details]
error log of anaconda 16.14

Comment 2 Frank Murphy 2011-08-02 08:57:44 UTC
Maybe related to:
http://lists.fedoraproject.org/pipermail/test/2011-August/101588.html

Mirrormanager?

Comment 3 James Laska 2011-08-02 11:59:04 UTC
> http://mirrors.fedoraproject.org/metalink?repo=fedora-16&arch=i386

According to mirrormanager, there is no fedora-16 repo configured yet.  This should have been completed when F16 branched from rawhide.  CC'ing dgilmore for help completing this task.

# repo=fedora-16, arch=i386
# repo=fedora-16, arch=s390x
# repo=fedora-16, arch=sparc
# repo=fedora-16, arch=x86_64

This qualifies as a blocker in that it is an incomplete task included in the branching process, it introduces unnecessary work arounds for a large portion of the installation test matrix, and it just needs to be completed.

Comment 4 James Laska 2011-08-02 14:57:35 UTC
I think this is the same core problem from 727510.  The mirrorlink? script isn't acknowledging fedora-16 as a valid repo= value.

Comment 5 Frank Murphy 2011-08-02 15:09:35 UTC
Will the alpha freeze hold any fix up?
http://lists.fedoraproject.org/pipermail/infrastructure/2011-August/010635.html

Maybe a heads up about this  bug to the test list?

Comment 6 James Laska 2011-08-02 15:49:18 UTC
(In reply to comment #5)
> Will the alpha freeze hold any fix up?
> http://lists.fedoraproject.org/pipermail/infrastructure/2011-August/010635.html

No, there was an additional change needed so that the MirrorManager understood "repo=fedora-16".  That change should be rolled out to production shortly.

> Maybe a heads up about this  bug to the test list?

Thanks, I mentioned the issue on test@ (http://lists.fedoraproject.org/pipermail/test/2011-August/101596.html).

Comment 7 Tim Flink 2011-08-04 19:41:15 UTC
(In reply to comment #3) 
> This qualifies as a blocker in that it is an incomplete task included in the
> branching process, it introduces unnecessary work arounds for a large portion
> of the installation test matrix, and it just needs to be completed.

Agreed. +1 Alpha Blocker

Comment 8 Hongqing Yang 2011-08-05 05:39:22 UTC
*** Bug 728422 has been marked as a duplicate of this bug. ***

Comment 9 Tim Flink 2011-08-05 17:34:18 UTC
This bug has been confirmed fixed with a change to MirrorManager configuration. If it reoccurs, please re-open this bug or open a new one.

Comment 10 Michael Schwendt 2011-08-05 20:30:48 UTC
How has it been confirmed? - F16 Alpha TC1 netinstall ISO still failed for me half an hour ago.


Note You need to log in before you can comment on or make changes to this bug.