Bug 727551 - Createrepo in updates requires a yum from updates-testing
Summary: Createrepo in updates requires a yum from updates-testing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: createrepo
Version: 15
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 727582 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 12:50 UTC by Patrick
Modified: 2016-09-20 02:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 17:51:04 UTC


Attachments (Terms of Use)

Description Patrick 2011-08-02 12:50:02 UTC
Description of problem:
Createrepo-0.9.9-4.fc15.noarch.rpm in updates requires yum-3.2.29-8.fc15.noarch.rpm which is in updates-testing

Version-Release number of selected component (if applicable):
0.9.9-4.fc15

How reproducible:
Do a kickstart install of F15 x86_64 with the updates repo included

Steps to Reproduce:
1. start kickstart install of F15 x86_64 on laptop
2. wait for error message that createrepo requires a yum version which it can not 
   find
3. failed install
  
Actual results:
Install fails

Expected results:
Install succeeds

Additional info:

Comment 1 jurek.bajor 2011-08-02 14:20:27 UTC
I have the same problem on F15 32-bit.

YumEx update run aborted.

...
Dependency Resolution Errors:

Package: createrepo-0.9.9-4.fc15.noarch (updates)
    Requires: yum >= 3.2.29-8
    Installed: yum-3.2.29-7.fc15.noarch (@updates)
        yum = 3.2.29-7.fc15
    Available: yum-3.2.29-4.fc15.noarch (fedora)
        yum = 3.2.29-4.fc15

I am not very familiar with the procedures involved, so whatever it is worth ...
It could be a bug in AutoQA's depchecker.

Yum:
https://admin.fedoraproject.org/updates/yum-3.2.29-8.fc15
It is in testing status, with:
...
bodhi - 2011-07-31 03:52:50
This update has been pushed to testing.

Createrepo:
https://admin.fedoraproject.org/updates/createrepo-0.9.9-4.fc15?_csrf_token=2e20cb63642da7eae8e65821918a1c10d7a7c146
It is in stable status, with:
autoqa - 2011-07-29 20:44:55
AutoQA: depcheck test PASSED on i386.
...
bodhi - 2011-07-31 03:51:08
This update has been pushed to testing.
...
bodhi - 2011-08-02 02:07:07
This update has been pushed to stable.

So, it seems to me that when pushing and changing createrepo package from
testing to stable (and in general when pushing to change status) the AutoQA
step should be run (prior to) as well.

So, if this is AutoQA's depchecker bug, would you plz submit BZ report ?

JB

Comment 2 Gwyn Ciesla 2011-08-02 15:10:48 UTC
*** Bug 727582 has been marked as a duplicate of this bug. ***

Comment 3 Nathan Owe 2011-08-02 15:19:11 UTC
Confirming that I also am having this problem trying to update my system

Comment 4 Luke Macken 2011-08-03 04:42:03 UTC
yum-3.2.29-8 should be syncing to the mirrors right now.

https://admin.fedoraproject.org/updates/F15/FEDORA-2011-9865

Comment 5 Patrick 2011-08-03 05:49:34 UTC
The createrepo dep can now be satisfied cause yum-3.2.29-8 has shown up in updates. Problem solved. Thanks Luke.


Note You need to log in before you can comment on or make changes to this bug.