Bug 72757 - when i change the irq value of my ethernet card,the software popup a dialog box shows some messages.
when i change the irq value of my ethernet card,the software popup a dialog b...
Status: CLOSED DUPLICATE of bug 71503
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 10:22 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 10:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-27 10:22:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Traceback (innermost last):
  File "/usr/sbin/redhat-config-network", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/redhat-config-network", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/redhat-config-network", line 287, in save
    self.saveHardware()
  File "/usr/sbin/redhat-config-network", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 85579d0>
hw: <netconfpkg.HardwareList.Hardware instance at 850a1c8>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 850b208>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 852e9e8>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 850a1c8>]

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install redhat-config-network-1.0.0-1.i386.rpm
2.run by typing 'redhat-config-network' on the console under kde3.0
3.edit the ethernet card
4.change the irq from 'Unknown' to any other number
	

Actual Results:  see the summary

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-08-27 12:45:22 EDT

*** This bug has been marked as a duplicate of 71503 ***

Note You need to log in before you can comment on or make changes to this bug.