Bug 71503 - TB NCHardwareList.:288:save
TB NCHardwareList.:288:save
Status: CLOSED DUPLICATE of bug 65073
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 72757 (view as bug list)
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-08-14 10:41 EDT by Steve Wells
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-08 11:11:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wells 2002-08-14 10:41:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Used the gnome config utility to try to set the IRQ of the NIC to 10, then
applied, received message :

Please visit http://bugzilla.redhat.com/bugzilla/
File a bug against component redhat-config-network.  Thank you!

I am trying to make DOSEMU 1.0.2.1 recognize this card and wanted to make sure
all config options were correct....

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.go to Network configuration in the Gnome Interface
2.select hardware
3.select edit
4.select 10 in the IRQ box
5.select OK
6.select apply
7.error pops up here.
	

Actual Results:  an exception message box pops up containing the following:


Please visit http://bugzilla.redhat.com/bugzilla/
File a bug against component redhat-config-network.  Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8559488>
hw: <netconfpkg.HardwareList.Hardware instance at 84e6720>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 854e7d0>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84e6708>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 84e6720>]


Additional info:

I am very new to LINUX, as in this is the first time I have ever worked with it
and may not have something installed correctly...but I can't figure out what, as
I have reinastalled 5 times and still get this result...
Comment 1 Harald Hoyer 2002-08-19 09:18:25 EDT
sorry, in Linux you cannot reassign the IRQ so easily... The IRQ setting was for
old ISA cards..
Sorry also for the bug, you will recveive a notification where to download the
next version, that will fix this bug.
Comment 2 Trond Eivind Glomsrxd 2002-08-27 12:45:16 EDT
*** Bug 72757 has been marked as a duplicate of this bug. ***
Comment 3 Harald Hoyer 2002-10-23 05:38:27 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.
Comment 4 Harald Hoyer 2002-11-20 12:59:07 EST

*** This bug has been marked as a duplicate of 65073 ***

Note You need to log in before you can comment on or make changes to this bug.