Bug 727573 - Anaconda crashes when unpartitioned disks are present
Summary: Anaconda crashes when unpartitioned disks are present
Keywords:
Status: CLOSED DUPLICATE of bug 720070
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 13:48 UTC by masami256
Modified: 2011-08-23 20:30 UTC (History)
2 users (show)

Fixed In Version: anaconda-16.15-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 20:30:21 UTC


Attachments (Terms of Use)
That is anaconda.log (10.07 KB, text/x-log)
2011-08-02 13:50 UTC, masami256
no flags Details

Description masami256 2011-08-02 13:48:32 UTC
Description of problem:
I wanted to save anaconda log to disk image in case of something happen. Then I found that if there are formatted disk exists, Anaconda crashes after host name setup menu. 
I use virt-manager and qemu-kvm to find the issue.

I tested following pattern. Both result was crashed.
1. hda:ext4(10GB)
2. hda:not formatted(10GB) hdb:ext4(1GB)

I checked to use ext4 formatted image which is already installed F15, I couldn't reproduce it.

Version-Release number of selected component (if applicable):
16.14
Fedora-16-Alpha.TC1-x86_64-DVD.iso

How reproducible:
always

Steps to Reproduce:
1.qemu-img create hda.img 10G
2.mkfs.ext4 hda.img
3.run qemu-kvm/virt-manager with f16-alpha-tc1 iso and prepared image
4.select default value to go next menu
-> after host name setting, the crash happened
  
Actual results:
Exception occurred

Expected results:
Go to next menu

Additional info:

Comment 1 masami256 2011-08-02 13:50:03 UTC
Created attachment 516325 [details]
That is anaconda.log

Comment 2 Chris Lumens 2011-08-02 13:59:56 UTC
13:07:52,575 CRIT anaconda: anaconda 16.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 393, in _is_valid_disklabel
    label_type = disk.format.labelType
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 640, in is_valid_stage2_device
    desc=self.stage2_description):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 687, in bootable_chain_devices
    if self.is_valid_stage2_device(d, linux=False, non_linux=True)]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1275, in has_windows
    return len(self.bootable_chain_devices) != 0
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/timezone_gui.py", line 95, in getScreen
    self.utcCheckbox.set_active(not anaconda.bootloader.has_windows)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1267, in display_step
    new_screen = self.currentWindow.getScreen(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1154, in display_step
    return self.icw.display_step(step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 342, in dispatch
    rc = self.anaconda.intf.display_step(self.step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
    self.anaconda.dispatch.go_forward()
AttributeError: 'Ext4FS' object has no attribute 'labelType'

Comment 3 David Lehman 2011-08-23 20:30:21 UTC

*** This bug has been marked as a duplicate of bug 720070 ***


Note You need to log in before you can comment on or make changes to this bug.