This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720070 - AttributeError: 'Iso9660FS' object has no attribute 'labelType'
AttributeError: 'Iso9660FS' object has no attribute 'labelType'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:1b56e9a43c2125d60...
:
: 727573 728700 (view as bug list)
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-07-08 20:10 EDT by bsfmig
Modified: 2011-08-23 16:30 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-16.14.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 18:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (758.94 KB, text/plain)
2011-07-08 20:10 EDT, bsfmig
no flags Details

  None (edit)
Description bsfmig 2011-07-08 20:10:25 EDT
The following was filed automatically by anaconda:
anaconda 16.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 456, in _is_valid_disklabel
    label_type = disk.format.labelType
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 703, in is_valid_stage2_device
    desc=self.stage2_description):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 749, in bootable_chain_devices
    if self.is_valid_stage2_device(d, linux=False, non_linux=True)]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1338, in has_windows
    return len(self.bootable_chain_devices) != 0
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/timezone_gui.py", line 95, in getScreen
    self.utcCheckbox.set_active(not anaconda.bootloader.has_windows)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1269, in display_step
    new_screen = self.currentWindow.getScreen(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1156, in display_step
    return self.icw.display_step(step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 342, in dispatch
    rc = self.anaconda.intf.display_step(self.step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
    self.anaconda.dispatch.go_forward()
AttributeError: 'Iso9660FS' object has no attribute 'labelType'
Comment 1 bsfmig 2011-07-08 20:10:32 EDT
Created attachment 512018 [details]
Attached traceback automatically from anaconda.
Comment 2 bsfmig 2011-07-08 20:12:16 EDT
This occured just after clicking next on network hostname page.
Comment 3 David Lehman 2011-07-11 15:04:12 EDT
You must be the first to try a liveusb installation with anaconda's new bootloader code on x86. I'm working on a patch.
Comment 4 Chris Lumens 2011-08-08 11:14:38 EDT
*** Bug 728700 has been marked as a duplicate of this bug. ***
Comment 5 Tim Flink 2011-08-08 12:34:26 EDT
Discussed in the 2011-08-08 Fedora QA meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

The installer must boot (if appropriate) and run on all primary architectures from default live image, DVD, and boot.iso install media

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 6 Fedora Update System 2011-08-09 00:25:49 EDT
anaconda-16.14.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
Comment 7 Fedora Update System 2011-08-09 02:02:41 EDT
Package anaconda-16.14.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.3-1.fc16
then log in and leave karma (feedback).
Comment 8 Adam Williamson 2011-08-10 02:09:05 EDT
can you please check this with rc3? it should be fixed there. thanks!
Comment 9 Jóhann B. Guðmundsson 2011-08-10 06:08:07 EDT
This is fixed for me on the dvd rc3
Comment 10 bsfmig 2011-08-10 09:07:06 EDT
Trying to run alpha3-rc3 livecd in a VBox vm, and this issue seems to have been fixed.
Sorry but currently I'm unable to perform a liveusb installation on my laptop so I don't know if it is liveusb-specific.
Comment 11 Fedora Update System 2011-08-11 11:49:55 EDT
anaconda-16.14.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.4-1.fc16
Comment 12 Tim Flink 2011-08-15 10:50:13 EDT
There have been two reports of this being fixed, moving to VERIFIED
Comment 13 Fedora Update System 2011-08-15 12:55:41 EDT
anaconda-16.14.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16
Comment 14 Fedora Update System 2011-08-15 16:23:45 EDT
Package anaconda-16.14.5-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.5-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2011-08-16 16:14:52 EDT
anaconda-16.14.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.6-1.fc16
Comment 16 Adam Williamson 2011-08-17 01:30:29 EDT
moving back to verified, per comment #12.
Comment 17 Fedora Update System 2011-08-17 10:55:21 EDT
Package anaconda-16.14.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.6-1.fc16
then log in and leave karma (feedback).
Comment 18 Adam Williamson 2011-08-17 12:27:05 EDT
biff-baff!
Comment 19 Fedora Update System 2011-08-18 18:24:25 EDT
anaconda-16.14.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 David Lehman 2011-08-23 16:30:21 EDT
*** Bug 727573 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.