Bug 727680 - Missing drivers/usb/serial/option.ko in kernel 2.6.40-4.fc15.i686
Missing drivers/usb/serial/option.ko in kernel 2.6.40-4.fc15.i686
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 733022 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 16:36 EDT by Eduard Vopicka
Modified: 2011-08-24 09:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.0.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 22:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eduard Vopicka 2011-08-02 16:36:25 EDT
Description of problem: Missing drivers/usb/serial/option.ko 


Version-Release number of selected component (if applicable): 2.6.40-4.fc15.i686, probably also PAE and x86_64


How reproducible: Verify contents of kernel RPM


Steps to Reproduce:
[root@lin modules]# ls -l
total 8
drwxr-xr-x 6 root root 4096 Jul 14 14:13 2.6.38.8-35.fc15.i686
drwxr-xr-x 6 root root 4096 Aug  2 21:42 2.6.40-4.fc15.i686
[root@lin modules]# find . -name option.ko
./2.6.38.8-35.fc15.i686/kernel/drivers/usb/serial/option.ko
[root@lin modules]# 
  
Actual results: option.ko only in 2.6.38.8-35.fc15.i686, not in 2.6.40-4.fc15.i686


Expected results: option.ko in both kernels


Additional info: CONFIG_USB_SERIAL_OPTION is defined in config-generic of 2.6.40-4.fc15.i686, so why the option.ko module is missing?  Maybe this is somewhat related to https://bugzilla.redhat.com/show_bug.cgi?id=697122 ???

[vopicka@lin SOURCES]$ pwd
/REST/tmp/rpmbuild/SOURCES
[vopicka@lin SOURCES]$ grep CONFIG_USB_SERIAL_OPTION config-*
config-generic:CONFIG_USB_SERIAL_OPTION=y
[vopicka@lin SOURCES]$ 

Brgds,

Ed
Comment 1 Dave Jones 2011-08-02 18:17:42 EDT
this got inadvertently changed to built-in. I'll change it back to modular for the next update.
Comment 2 Eduard Vopicka 2011-08-03 10:17:08 EDT
Please are you sure it works properly when compiled into kernel? Not only that my scripts choked on missing option.ko, but also my CDMA modem is horribly slow with 2.6.40-4.fc15.i686 and preforms normally with 2.6.38.8-35.fc15.i686. I have tried about 6 times with each kernel and CDMA was always much slower with 2.6.40-4.fc15.i686.

OK, for the time being I am running 2.6.38.8-35.fc15.i686 and waiting for the next kernel update.

Brgds,

Ed
Comment 3 Fedora Update System 2011-08-08 20:04:28 EDT
kernel-3.0.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
Comment 4 Fedora Update System 2011-08-08 22:52:58 EDT
Package kernel-3.0.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.0.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-08-16 08:47:32 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 6 Fedora Update System 2011-08-17 22:30:24 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-08-22 10:49:48 EDT
kernel-3.0.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Eduard Vopicka 2011-08-22 15:15:20 EDT
It appears that kernel-2.6.40.3-0.fc15.i686 fixes this for F15. Not only tha the option.ko module is back, but also my CDMA modem runs at usual speed again. Thank you.
Comment 9 Josh Boyer 2011-08-24 09:52:12 EDT
*** Bug 733022 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.