Bug 72773 - lpd start: "NameError: name 'gettext' is not defined"
lpd start: "NameError: name 'gettext' is not defined"
Status: CLOSED DUPLICATE of bug 72177
Product: Red Hat Public Beta
Classification: Retired
Component: printconf (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 14:14 EDT by John Reiser
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 14:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2002-08-27 14:14:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
I see this message at every boot, and for manual start of lpd.
No printer has ever been attached at install or afterwards,
and I took no special action regarding printing, either at install or afterwards.
-----
# service lpd start
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 30, in ?
    _=gettext.gettext
NameError: name 'gettext' is not defined
No Printers Defined                                        [  OK  ]
# 
-----

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install "null" beta with no printer attached, but standard PC parallel port
present.
2. Boot, or "service lpd start" after boot.
3.
	

Actual Results:
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 30, in ?
    _=gettext.gettext
NameError: name 'gettext' is not defined
No Printers Defined                                        [  OK  ]


Expected Results:
Starting lpd:  No Printers Defined                         [  OK  ]


Additional info:
Comment 1 Tim Waugh 2002-08-27 14:16:39 EDT
This is already fixed in redhat-config-printer-0.4.22-1. 

*** This bug has been marked as a duplicate of 72177 ***

Note You need to log in before you can comment on or make changes to this bug.