Bug 72777 - Keyboard is not returned to initial state when coming from suspend
Keyboard is not returned to initial state when coming from suspend
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
: 76207 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 14:46 EDT by Richard Torkar
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 13:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Torkar 2002-08-27 14:46:23 EDT
Description of problem:

(This is a DELL L400 laptop)

When I close the lid on my laptop the computer is suspended to RAM.

Before it got suspended the keyboard worked fine,
i.e. when pressing and holding a key it gets repeated: sssssssssssss <- pressing
and holding s once.

When the laptop returns from suspend the key doesn't repeat: s <- pressing and
holding s.

Version-Release number of selected component (if applicable):
apmd-3.0.2-12

How reproducible:
Always

Steps to Reproduce:
1.Close the lid and the computer suspends to RAM
2.Open the lid and the keyboard is not correctly restored

Actual Results:  The key is pressed but not repeated after a suspend.

Expected Results:  The key that is pressed and hold down should be repeated as
it was before the suspend.
Comment 1 Richard Torkar 2002-09-03 11:52:06 EDT
The same goes for the mouse...
I can double-click on a windowlist to shade it.
BUT I can not double-click and drag the window as I could before I suspended the
laptop...


/Richard
Comment 2 Richard Torkar 2002-09-09 11:28:52 EDT

Hmm, this is strange.
If I log out of gnome and type into the user/passwd field in gdm the keys are
repeated. But directly when I have logged into gnome it doesn't work again (only
the first time I log into Gnome before a suspend it works).

Seems to me this might be a Gnome bug?

Comment 3 Owen Taylor 2002-12-12 09:50:19 EST
*** Bug 76207 has been marked as a duplicate of this bug. ***
Comment 4 LI Xianfeng 2002-12-15 10:13:38 EST
I have similar problem. My machine is a desktop. Before using Redhat7.3/8.0,
it worked OK on RH7.2

My machine BIOS power-saving option is to suspend after 15 minutes of idle.
After I disabled this suspension option, the keyboard problem disappeared.
Comment 5 Richard Torkar 2003-01-23 13:26:36 EST
In latest phoebe this is no longer the case.
I reported this initially.
So, relax :) Now it works!

Note You need to log in before you can comment on or make changes to this bug.