Bug 727797 - Hardware Profile is empty
Hardware Profile is empty
Status: CLOSED DUPLICATE of bug 722859
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 728089 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-08-03 05:18 EDT by Kamil Páral
Modified: 2011-08-25 16:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 16:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration (156.25 KB, image/png)
2011-08-03 05:18 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-08-03 05:18:53 EDT
Created attachment 516469 [details]
bug demonstration

Description of problem:
I tried to install system from Fedora 16 Alpha TC1. The Hardware Profile box is completely empty. I did not find any error on stderr nor in the logs.

Version-Release number of selected component (if applicable):
Fedora 16 Alpha TC1
firstboot-16.1-2.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. edit /etc/sysconfig/firstboot
2. run firstboot
Comment 1 Kamil Páral 2011-08-03 05:22:54 EDT
Proposing as NTH bug for F16, because this can't be fixed as a later update.
Comment 2 Martin Gracik 2011-08-04 02:26:49 EDT
*** Bug 728089 has been marked as a duplicate of this bug. ***
Comment 3 Charles R. Anderson 2011-08-16 01:23:48 EDT
Fedora 16 Alpha RC4
smolt-1.4.3-4.fc16

Running smoltSendProfile manually tracebacks:

[cra@t ~]$ smoltSendProfile -p
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 152, in <module>
    profile = smolt.get_profile()
  File "/usr/share/smolt/client/smolt.py", line 1415, in get_profile
    return Hardware()
  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
    _hardware_instance = _Hardware()
  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
    self.host = Host()
  File "/usr/share/smolt/client/smolt.py", line 283, in __init__
    self.systemMemory = Gate().process('ram_size', memory['ram'], 0)
TypeError: 'NoneType' object is not subscriptable
Comment 4 Orion Poplawski 2011-08-25 16:26:14 EDT

*** This bug has been marked as a duplicate of bug 722859 ***

Note You need to log in before you can comment on or make changes to this bug.