Bug 727805 - Spice client gets stuck when reconnecting during migration
Summary: Spice client gets stuck when reconnecting during migration
Keywords:
Status: CLOSED DUPLICATE of bug 727969
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client
Version: 6.2
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 09:40 UTC by Marian Krcmarik
Modified: 2011-08-03 21:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 21:18:45 UTC


Attachments (Terms of Use)

Description Marian Krcmarik 2011-08-03 09:40:52 UTC
Description of problem:
When migrating a guest, during final stage once spice client is reconnecting, The spice client gets stuck - does not finish reconnecting successfully and remains in "black" screen stage.
This behaviour is not happening with spice-client-0.8.0-2.el6.

Version-Release number of selected component (if applicable):
spice-client-0.8.2-2.el6.x86_64  

libvirt-0.9.4-0rc1.2.el6.x86_64
qemu-kvm-0.12.1.2-2.171.el6.x86_64
spice-server-0.8.2-3.el6.x86_64

Guest: WinXP
Client: RHEL6.2

How reproducible:
Always

Steps to Reproduce:
1. Connect to a guest using spice-client.
2. Start Migration (using libvirt in my case).
  
Actual results:
Spice client gets stuck during reconnecting and display only black screen
.
Expected results:
Display original guest screen.

Additional info:
Not happening on the same setup with spice client spice-client-0.8.2-2.el6.x86_64.

Comment 1 Marian Krcmarik 2011-08-03 09:46:25 UTC
Spicec log:

1312364642 INFO [6165:6165] Application::main: starting 0.8.2
1312364642 INFO [6165:6165] init_key_map: using evdev mapping
1312364644 INFO [6165:6165] MultyMonScreen::MultyMonScreen: platform_win: 88080385
1312364644 INFO [6165:6165] ForeignMenu::ForeignMenu: Creating a foreign menu connection /tmp/SpiceForeignMenu-6165.uds
1312364644 INFO [6165:6166] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6166] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6170] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6169] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6171] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6169] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6171] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6172] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6173] RedPeer::connect_to_peer: Connect failed: Connection refused (111)
1312364644 INFO [6165:6172] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6173] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6170] RedPeer::connect_unsecure: Connected to localhost 5900
1312364644 INFO [6165:6165] DisplayChannel::create_sw_canvas: display 0: using sw
1312364644 INFO [6165:6166] RedChannel::handle_notify: remote channel 1:0 warn!!! #0: keyboard channel is insecure
1312364669 INFO [6165:6165] Application::switch_host: host=YYYY port=5900 sport=65535
1312364669 INFO [6165:6166] RedPeer::connect_unsecure: Connected to YYYY 5900

Comment 2 Marian Krcmarik 2011-08-03 09:51:27 UTC
Migration itself seems to be successful. Manual reconnecting to a target host works fine. Port, hostname from spicec log in switch_host match with my manual reconnecting options, but when manually reconnecting It works indeed.

Comment 3 Alon Levy 2011-08-03 21:18:45 UTC

*** This bug has been marked as a duplicate of bug 727969 ***


Note You need to log in before you can comment on or make changes to this bug.