Bug 727822 - RFE: Gtk/IMModule support
Summary: RFE: Gtk/IMModule support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xsettings-kde
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 10:45 UTC by Akira TAGOH
Modified: 2011-10-03 17:58 UTC (History)
3 users (show)

Fixed In Version: xsettings-kde-0.12.2-2.fc16
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 17:58:15 UTC


Attachments (Terms of Use)
proposed patch to support Gtk/IMModule (3.02 KB, patch)
2011-09-08 03:04 UTC, Akira TAGOH
no flags Details | Diff

Description Akira TAGOH 2011-08-03 10:45:22 UTC
Description of problem:
This key is used to change the gtk immodule seamlessly though, the feature isn't provided for gtk+ applications on KDE desktop.

Version-Release number of selected component (if applicable):
xsettings-kde-0.12-3.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.run gedit say on kde
2.change IM with im-chooser
3.back to gedit and see which gtk immodule is used.
  
Actual results:
IM isn't changed

Expected results:
IM should be changed

Additional info:
the original data is stored to gtk-im-module key in org.gnome.desktop.interface in gsettings. xsettings-kde can pull the value there. hope the dependency issue wouldn't be a big deal since xsettings-kde already requires glib.

Please see plugins/xsettings/gsd-xsettings-manager.c in gnome-settings-daemon how GNOME do deal with it.

Comment 1 Akira TAGOH 2011-09-08 03:04:49 UTC
Created attachment 522032 [details]
proposed patch to support Gtk/IMModule

Comment 2 Akira TAGOH 2011-09-08 03:06:44 UTC
tested gedit on KDE. it can also detects the immodule changes when changing IM with im-chooser.

Comment 3 fujiwara 2011-09-12 09:02:00 UTC
*** Bug 737435 has been marked as a duplicate of this bug. ***

Comment 4 Akira TAGOH 2011-09-20 09:18:19 UTC
ping?

Comment 5 Rex Dieter 2011-09-22 13:29:24 UTC
Thanks!  I'll take care of applying the patch today.

Comment 6 Fedora Update System 2011-09-22 13:49:27 UTC
xsettings-kde-0.12.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xsettings-kde-0.12.2-2.fc16

Comment 7 A S Alam 2011-09-23 03:41:09 UTC
it is working in KDE desktop for gedit and kate as same, but I have question that when Right Click in Gedit and check Input Method, that was still showing Ibus even I disable it to none (with im-chooser), Is this bug? after logout and login again it is fine.

Comment 8 A S Alam 2011-09-23 03:42:12 UTC
it is fixed in fedora 16 (and rawhide also). Bug moved to 16 to track in Fedora 16

Comment 9 Fedora Update System 2011-09-24 20:48:05 UTC
Package xsettings-kde-0.12.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xsettings-kde-0.12.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xsettings-kde-0.12.2-2.fc16
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-10-03 17:58:10 UTC
xsettings-kde-0.12.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.