Bug 727869 - Configuration History times out when there are many resources.
Configuration History times out when there are many resources.
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon30-perf rhq-gui-timeouts rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-03 09:21 EDT by Robert Buck
Modified: 2013-08-05 20:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:32:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (64.21 KB, patch)
2011-08-29 14:39 EDT, Ian Springer
no flags Details | Diff

  None (edit)
Description Robert Buck 2011-08-03 09:21:12 EDT
For example, in the performance environment, it took 15 seconds to show the configuration history when there were many resources inventoried.
Comment 1 Ian Springer 2011-08-29 14:39:40 EDT
Created attachment 520448 [details]
fix
Comment 2 Ian Springer 2011-08-29 14:44:29 EDT
The attached patch fixes this issue by making AbstractConfigurationUpdate.configuration LAZY, rather than EAGER, fetch. With the change, the subsystem config history list view now loads in around 3 seconds. Since the change required significant refactoring of code which expected the configuration field to be eagerly fetched, we will hold off committing it until after the imminent RHQ 4.1 and JON 3.0 Beta releases.

Note, I tested that all of the config-related views in the GUI still work and that all domain and server-jar unit tests still pass. I still need to test:

1) CLI integration tests still pass
2) resource-config-changed alerts still work
Comment 3 Ian Springer 2011-09-15 14:07:34 EDT
Note: Make sure to provide detailed test steps for QE.
Comment 4 Ian Springer 2011-10-03 17:20:32 EDT
The patch has been merged in - [master 8368e38].

QE, please test that the following views load quickly and do not have any regressions:

1) resource Configuration > History subtab - list and detail views
2) resource Inventory > Connection Settings subtab
3) resource Inventory > Connection Settings History subtab
4) group Configuration > History subtab - list and detail views
5) group Inventory > Connection Settings subtab
6) group Inventory > Connection Settings History subtab
7) Reports > Configuration History subsystem view

Make sure each of the views contains at least one history item so you can test that it is loaded correctly.

Please also test that resource-configuration-changed alerts still work correctly.
Comment 5 Sunil Kondkar 2011-10-04 09:05:41 EDT
While verifying the resource Inventory > Connection Settings History subtab, encountered an exception in server log. Filed a separate bug:

https://bugzilla.redhat.com/show_bug.cgi?id=743271
Comment 6 Mike Foley 2012-02-07 14:32:07 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE
Comment 7 Mike Foley 2012-02-07 14:32:07 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.