Bug 727872 - find-debuginfo.sh should handle identical binaries via additional symlinks
Summary: find-debuginfo.sh should handle identical binaries via additional symlinks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Panu Matilainen
QA Contact: Patrik Kis
URL:
Whiteboard:
Depends On:
Blocks: 728996 729012 729022 729038 836966
TreeView+ depends on / blocked
 
Reported: 2011-08-03 13:48 UTC by Karel Klíč
Modified: 2016-07-25 08:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 836966 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:50:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0461 normal SHIPPED_LIVE rpm bug fix and enhancement update 2013-02-20 21:07:23 UTC

Description Karel Klíč 2011-08-03 13:48:50 UTC
Description of problem:
find-debuginfo.sh that is present in rpm-4.8.0-16.el6 does not handle several binaries with the same build id well. The symbolic link pointing from debuginfo back to the binary (/usr/lib/debug/.build-id/<aa>/<bbbbb>) points to only one of the identical binaries.

In this situation it is not possible to get the list of all packages required to analyze a coredump from the coredump itself. Coredumps contain build-ids, but debuginfo packages cannot be used to get the binaries (paths) that can be turned into packages (for example, when a package containing the symlink target is not available in a RHEL variant). This lowers the success rate of ABRT's retrace server, which is being used to analyze coredumps from customers.

The fix for this is already present in Fedora. find-debuginfo.sh in Fedora creates additional .2, .3,... symlinks to handle additional instances of binary with a build-id.

Please consider backporting the Fedora extension/fix to RHEL-6.

Steps to Reproduce:
1. Crash /bin/perl from perl-5.10.1-119.el6.i686, get a coredump.
2. Coredump contains build-id f848b9e8ff059b14becc9acb6dfaf49d5e5052b0
3. /usr/lib/debug/.build-id/f8/48b9e8ff059b14becc9acb6dfaf49d5e5052b0 points to /usr/bin/suidperl, which is not available.

Expected results:
/usr/lib/debug/.build-id/f8/48b9e8ff059b14becc9acb6dfaf49d5e5052b0 points to /usr/bin/suidperl

/usr/lib/debug/.build-id/f8/48b9e8ff059b14becc9acb6dfaf49d5e5052b0.2 points to /bin/perl

Comment 2 RHEL Product and Program Management 2011-10-07 16:04:47 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Panu Matilainen 2012-07-02 08:30:17 UTC
devel_ack for the rpm side, but gdb needs to be patched to support this as well.

Comment 12 errata-xmlrpc 2013-02-21 10:50:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0461.html


Note You need to log in before you can comment on or make changes to this bug.