Bug 729022 - Invalid symbolic links in debuginfo package
Invalid symbolic links in debuginfo package
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE - Apps
:
Depends On: 727872 836966
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2014-08-05 16:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-05 16:03:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:51 EDT
A problem related to debuginfo was found in the java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo package includes a symbolic link to each binary that has the debugging symbols stored there. For java-1.6.0-openjdk, 11 symbolic links do not point to the right binary, and that makes it impossible to use build ids from a coredump to get a list of packages required by it. Usually, this is a packaging error caused usually by placing identical binary into several locations instead of creating a symlink. If one copy of the binary is SUID/SGID, it is not possible to use symlink. You can add a dependency on bug #727872 and rebuild java-1.6.0-openjdk when that bug is fixed.

- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/1e/8339e2439739e2df3262cfc6282b19dc57f15a
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/rmid
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/rmid
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/14/853253be400604bf9bebb821c9a2142dbe4db0
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/unpack200
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/unpack200
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/84/527fa4c72b31b4568c79f0bd0ed2fe81e8f497
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/pack200
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/pack200
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/dc/54903d661b96740ad94d5d7e964ddba82a1393
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/rmiregistry
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/rmiregistry
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/1c/8f96730d8f279037a6f175317786c3e79e4d0c
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/orbd
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/orbd
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/10/52c94ac2b516487146e4c168bdc62556937fb4
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/policytool
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/policytool
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/a0/aada5d6771246a7963789a465dfd673a8b30a0
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/tnameserv
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/tnameserv
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/73/a99abaae57abf6204d05c8df6db3de2793c7a3
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/keytool
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/keytool
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/48/c577a2f1b94e9cb112c89fdc2fe695414ab72a
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/servertool
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/servertool
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/68/5a294dac7609674125e05da5d9d4ed12e12385
- affected binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/jexec
  affected package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.8.el6_1.i686
  referenced binary: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/lib/jexec
  referenced package: java-1.6.0-openjdk-devel-1.6.0.0-1.39.1.9.8.el6_1.i686
  debuginfo symlink: /usr/lib/debug/.build-id/8b/52e1794d7abb9336dbf2931d6e12723450ef29

This issue has been solved in Fedora by /usr/lib/rpm/find-debuginfo.sh creating additional symlinks for identical binaries. However, symlinks should be used instead of duplicating a binary when possible.

(This bug was detected and filed by a script.)
Comment 2 Deepak Bhole 2011-08-08 12:00:13 EDT
Thanks for the pointer to 727872. I will add a dependency on it.

We do not use any setuid/setguid. The duplicated binaries are a result of upstream JDK build and I think it would be best left untouched unless unavoidable.
Comment 3 RHEL Product and Program Management 2011-10-07 10:54:05 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Deepak Bhole 2014-01-09 10:53:27 EST
Adding Pavel from QE on our side to cc:

Pavel, please see above bug. I don't think this is really an issue and do not want to add symlinks as it changes what upstream distributes and apps might rely on there being binaries rather than symlinks in some places.

Are you okay with closing this issue?
Comment 6 Deepak Bhole 2014-08-05 16:03:53 EDT
No movement here for over 18 months. Coupled with the fact that we do not want to break upstream layout, I am going to close this.

Note You need to log in before you can comment on or make changes to this bug.