Bug 727990 - rts5209: staging/rts_pstor: Realtek PCIe Card reader not supported [10ec:5209]
Summary: rts5209: staging/rts_pstor: Realtek PCIe Card reader not supported [10ec:5209]
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
: 789738 807612 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 21:00 UTC by Gianluca Sforna
Modified: 2013-12-07 21:06 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 14:25:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gianluca Sforna 2011-08-03 21:00:05 UTC
I have a laptop (HP Pavillion G6) with a PCIe card reader from Realtek which is not working at all (I insert the card, nothing shows in /var/log/messages)

Version-Release number of selected component (if applicable):
2.6.40-4

Some references:
https://bugzilla.kernel.org/show_bug.cgi?id=31692
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/698006

Comment 1 Sascha Zantis 2011-08-04 07:01:50 UTC
I have the same card reader. The problem is that drivers from staging are not integrated in Fedora repositories, as far as I know, in difference to Ubuntu for example. I installed the package kmod-staging-2.6.40-4.fc15.x86_64.x86_64 from rpmfusion and the card reader works. This package is in rpmfusion-free-updates.

Regards
Sascha

Comment 2 Gianluca Sforna 2011-08-08 13:02:27 UTC
Confirmed, after installing kmod-staging the card reader works as expected.

I'm leaving this open to track proper resolution in Fedora official kernels.

Comment 3 Sascha Zantis 2011-08-08 18:52:20 UTC
Won't happen until the drivers leave the staging-tree, I guess. And that won't happen in Linux 2.6.40/3.0.

Comment 4 Josh Boyer 2011-10-11 13:28:12 UTC
Moving this bug to rawhide.  We'll leave it open until the drivers move out of staging.

Comment 5 Sergey V. Udaltsov 2012-01-14 18:20:22 UTC
So far, with the latest kernel in FC16, the issue is still there. Even kmod-staging does not help on x86_x4 (the rpm has no files)

Comment 6 Sergey V. Udaltsov 2012-01-14 19:18:56 UTC
My apologies, installing kmod-staging required reboot. Now the card can be mounted. So, please integrate the module into the base kernel.

Comment 7 Sascha Zantis 2012-01-14 19:24:12 UTC
(In reply to comment #6)
> My apologies, installing kmod-staging required reboot. Now the card can be
> mounted. So, please integrate the module into the base kernel.

As I said before (2011-08-08), this will not happen until those drivers leave the staging tree in the kernel. This is up to the kernel developers, not the Fedora maintainers. Fedora does not integrate staging drivers in the kernel.

Comment 8 Josh Boyer 2012-02-02 15:16:22 UTC
Putting this in ASSIGNED state so it doesn't keep showing up as new.

The rts_pstor driver is still in staging, but it does seem to be actively worked on.

Comment 9 Josh Boyer 2012-02-13 15:39:08 UTC
*** Bug 789738 has been marked as a duplicate of this bug. ***

Comment 10 Josh Boyer 2012-03-28 13:08:27 UTC
*** Bug 807612 has been marked as a duplicate of this bug. ***

Comment 11 Ivo Sarak 2013-02-24 18:23:47 UTC
It seems not to work even on F18.

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)

Comment 12 Gustavo Maciel Dias Vieira 2013-03-05 12:27:30 UTC
The rts_pstor driver has been removed from staging in kernel 3.8 and another driver (rtsx_pci) is able to handle this hardware. I've tested it with the recent kernel-3.8.1-201.fc18.x86_64 and it works.

Comment 13 Josh Boyer 2013-03-05 14:25:59 UTC
(In reply to comment #12)
> The rts_pstor driver has been removed from staging in kernel 3.8 and another
> driver (rtsx_pci) is able to handle this hardware. I've tested it with the
> recent kernel-3.8.1-201.fc18.x86_64 and it works.

Excellent find.  I believe the driver is actually called rtsx_pci_ms (the rtsx_pci driver is something it depends on.)  This is available in all current kernels.

Comment 14 Hedi 2013-12-07 18:35:03 UTC
I have a problem with installing kmod-staging when i try yum install kmod-staging
i always get "No package kmod-stanging available"

Comment 15 Denis Ovsienko 2013-12-07 21:06:29 UTC
I confirm this issue resolved in Fedora 19 regular kernels. Engaging with kernel staging area isn't the recommended way to address this problem, it's better to upgrade the distribution instead.


Note You need to log in before you can comment on or make changes to this bug.