Bug 728009 - Lost HDMI audio on radeon HD 4670
Summary: Lost HDMI audio on radeon HD 4670
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 729119 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 22:25 UTC by Xavier Bachelot
Modified: 2011-10-21 01:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-21 01:08:09 UTC


Attachments (Terms of Use)

Description Xavier Bachelot 2011-08-03 22:25:17 UTC
Description of problem:
After upgrade to the latest F15 kernel, HDMI audio is not working anymore.

Version-Release number of selected component (if applicable):
2.6.40-4.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Use any software that is producing sound
2.
3.
  
Actual results:
no sound.

Expected results:
sound.

Additional info:
lspci extract :
01:00.0 VGA compatible controller: ATI Technologies Inc RV730XT [Radeon HD 4670]
01:00.1 Audio device: ATI Technologies Inc RV710/730

last known working kernel : kernel-2.6.38.8-35.fc15.x86_64

Comment 1 pasqual milvaques 2011-08-04 16:29:37 UTC
the same error happens to me with a radeon hd 3430

in /var/log/messages appear this messages when trying to play something:
Aug  4 18:26:33 yaddith pulseaudio[2600]: ratelimit.c: 43 events suppressed
Aug  4 18:26:34 yaddith pulseaudio[2600]: asyncq.c: q overrun, queuing locally
Aug  4 18:26:34 yaddith pulseaudio[2600]: asyncq.c: q overrun, queuing locally
Aug  4 18:26:34 yaddith pulseaudio[2600]: asyncq.c: q overrun, queuing locally
Aug  4 18:26:34 yaddith pulseaudio[2600]: asyncq.c: q overrun, queuing locally
Aug  4 16:26:40 yaddith rtkit-daemon[1431]: Successfully made thread 2629 of process 2629 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.

It seems that pulseaudio is crashed when trayinng to play something and automatically restarts

Comment 2 speedygonzalez 2011-08-08 18:20:03 UTC
I have a HD 4350 and i have the same error after the kernel update. 

And videos (only tried youtube (flash and html5)) played too fast.

Comment 3 Xavier Bachelot 2011-08-14 21:07:25 UTC
Actually, not a real bug, HDMI audio is now disabled by default.
Adding radeon.audio=1 to the kernel line in grub.conf will re-enable it.

See https://bugzilla.kernel.org/show_bug.cgi?id=39832 for some more details.

Comment 4 speedygonzalez 2011-09-09 15:54:05 UTC
*** Bug 729119 has been marked as a duplicate of this bug. ***

Comment 5 Josh Boyer 2011-10-21 01:08:09 UTC
I'm going to close this one out as this was an intentional upstream change.  As Xavier noted, radeon.audio=1 should get HDMI back.


Note You need to log in before you can comment on or make changes to this bug.