Bug 728292 - Type error with Apache plug-in
Type error with Apache plug-in
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Mike Foley
:
: 736136 (view as bug list)
Depends On:
Blocks: rhq41-ui rhq42
  Show dependency treegraph
 
Reported: 2011-08-04 11:31 EDT by Mike Foley
Modified: 2012-02-07 14:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2011-08-04 11:31:34 EDT
Description of problem:  Type error with Apache plug-in 


Version-Release number of selected component (if applicable):


How reproducible:
100% (also reproduced by stefan)

Steps to Reproduce:
1.  install Apache with mod_cluster http://www.jboss.org/mod_cluster/downloads/1-1-2
2.  discover and inventory with RHQ
3.  try to configure 
  
Actual results:
failure to configure.  exceptions in the message center

Expected results:
RHQ able to configure .

Additional info:

Globally uncaught exception
Severity :	
Error
	
Time :	
Thursday, August 4, 2011 10:43:09 AM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): this.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_val$result is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:141339 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:156882 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html lineNumber: 141339
--- STACK TRACE FOLLOWS ---
(TypeError): this.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_val$result is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:141339 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:156882 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/2AC7D9EB58DFE83D15C35314F098760F.cache.html lineNumber: 141339
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.handleEvent(Unknown source:0)
    at Unknown.SJOWContentBoundary(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 1 Lukas Krejci 2011-08-12 12:36:00 EDT
I *think* that this is because the plugin intentionally throws an exception in loadConfiguration() when "Enable Augeas" connection property is set to false in the Apache server's plugin config.

I think GUI gets confused by this but maybe it's something different - this is just an uneducated guess - I didn't actually look at the source code yet.

Note that when the plugin threw an exception from loadConfiguration() we used to display an error message in the JSF GUI which would give the user some hints as to why the plugin failed to load the config.
Comment 2 Lukas Krejci 2011-08-31 12:55:55 EDT
The exception disappears when augeas support is enabled in the connection settings of the apache server resource.

I'm lowering the priority of this bug because this is mostly a GUI nuissance. The underlying code behaves as expected.

Note that in RHQ 3 we used to display an error message from the agent that would have had shown the reason why the config failed to load. As far as I can see, this is missing in the GWT user interface.
Comment 3 Heiko W. Rupp 2011-09-28 12:01:15 EDT
We should not leave stack traces escape into the UI
Comment 4 Lukas Krejci 2011-10-12 11:06:42 EDT
commit fafa0f2e7221dce298a77e3d83b69e1f65e64aea
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Wed Oct 12 16:55:01 2011 +0200

    BZ 728292 - Restore the behaviour from RHQ3 where we showed just an info
    message when the plugin returned a null resource config or threw
    an exception during loadConfiguration().
Comment 5 Mike Foley 2011-10-18 16:56:03 EDT
*** Bug 736136 has been marked as a duplicate of this bug. ***
Comment 6 Mike Foley 2011-11-10 13:19:58 EST
verified jon 3 branch
Comment 7 Mike Foley 2012-02-07 14:29:43 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 8 Mike Foley 2012-02-07 14:30:21 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.