Bug 728378 - Youtube-dl no longer compatible with Youtube's backend
Summary: Youtube-dl no longer compatible with Youtube's backend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/rg3/youtube-dl/iss...
Whiteboard:
: 728645 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 21:01 UTC by skreech2
Modified: 2011-08-22 14:53 UTC (History)
4 users (show)

Fixed In Version: youtube-dl-2011.08.04-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-05 03:50:15 UTC


Attachments (Terms of Use)

Description skreech2 2011-08-04 21:01:26 UTC
Description of problem:
Youtube has changed the backend for Youtube which has broken youtube-dl

Version-Release number of selected component (if applicable):
2011.03.29

How reproducible:
Try to use the application

Steps to Reproduce:
1. Go to youtube for any video and copy the video's URL
2. Run youtube-dl against the url

  
Actual results:
Get a ERROR: no fmt_url_map or conn information found in video info message

Expected results:
A progress bar for the file.

Additional info:
https://github.com/rg3/youtube-dl/issues/135 details the problem and a patch for it

Comment 1 Fedora Update System 2011-08-04 21:42:23 UTC
youtube-dl-2011.08.04-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/youtube-dl-2011.08.04-1.fc15

Comment 2 Fedora Update System 2011-08-04 21:42:31 UTC
youtube-dl-2011.08.04-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/youtube-dl-2011.08.04-1.fc14

Comment 3 Fedora Update System 2011-08-04 21:42:40 UTC
youtube-dl-2011.08.04-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/youtube-dl-2011.08.04-1.fc16

Comment 4 Fedora Update System 2011-08-05 03:50:10 UTC
youtube-dl-2011.08.04-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-08-05 03:54:05 UTC
youtube-dl-2011.08.04-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Rahul Sundaram 2011-08-06 16:04:47 UTC
*** Bug 728645 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-08-22 14:53:10 UTC
youtube-dl-2011.08.04-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.