Bug 728403 - Review Request: libepc - Easy Publish and Consume library
Summary: Review Request: libepc - Easy Publish and Consume library
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 01:22 UTC by Haïkel Guémar
Modified: 2011-08-22 15:25 UTC (History)
3 users (show)

Fixed In Version: libepc-0.4.0-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 15:25:18 UTC
fedora: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Haïkel Guémar 2011-08-05 01:22:24 UTC
Spec URL: http://hguemar.fedorapeople.org/packages/libepc.spec
SRPM URL: http://hguemar.fedorapeople.org/packages/libepc-0.4.0-1.fc16.src.rpm
Description: A library to easily publish and consume values on networks

This is a deprecated package, accordingly to fedora deprecated packages process, i submit a re-review of libepc. It is required by glom and still maintained (same upstream maintainer).

scratch build of the package: http://koji.fedoraproject.org/koji/taskinfo?taskID=3253389
rpmlint output:
$ rpmlint -iv libepc-0.4.0-1.fc16.src.rpm 
libepc.src: I: checking
libepc.src: I: checking-url http://live.gnome.org/libepc/ (timeout 10 seconds)
libepc.src: I: checking-url http://ftp.gnome.org/pub/gnome/sources/libepc/0.4/libepc-0.4.0.tar.bz2 (timeout 10 seconds)
1 packages and 0 specfiles checked; 0 error

$ rpmlint -iv libepc-0.4.0-1.fc16.x86_64.rpm 
libepc.x86_64: I: checking
libepc.x86_64: I: checking-url http://live.gnome.org/libepc/ (timeout 10 seconds)
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
s, 0 warnings.

$ rpmlint -iv libepc-ui-0.4.0-1.fc16.x86_64.rpm 
libepc-ui.x86_64: I: checking
libepc-ui.x86_64: I: checking-url http://live.gnome.org/libepc/ (timeout 10 seconds)
libepc-ui.x86_64: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

1 packages and 0 specfiles checked; 0 errors, 1 warnings.

$ rpmlint -iv libepc-devel-0.4.0-1.fc16.x86_64.rpm
libepc-devel.x86_64: I: checking
libepc-devel.x86_64: I: checking-url http://live.gnome.org/libepc/ (timeout 10 seconds)
libepc-devel.x86_64: W: invalid-url URL: http://live.gnome.org/libepc/ <urlopen error timed out>
The value should be a valid, public HTTP, HTTPS, or FTP URL.

1 packages and 0 specfiles checked; 0 errors, 1 warnings.

Comment 1 Remi Collet 2011-08-06 05:41:16 UTC
=== FORMAL REVIEW ===
 -=N/A  x=Check  !=Problem,  ?=Not evaluated

=== REQUIRED ITEMS ===
 [x] Rpmlint output:
libepc-ui.x86_64: W: no-documentation
 [x] Package is named according to the Package Naming Guidelines.
 [x] Spec file name must match the base package %{name}, in the format
%{name}.spec.
 [x] Package meets the Packaging Guidelines
 [x] Package is licensed with an open-source compatible license and meets other
legal requirements as defined in the legal section of Packaging Guidelines.
 [x] License field in the package spec file matches the actual license.
     License type: LGPLv2+
 [x] If (and only if) the source package includes the text of the license(s) in
its own file, then that file, containing the text of the license(s) for the
package is included in %doc.
 [x] Spec file is legible and written in American English.
 [x] Sources used to build the package matches the upstream source, as provided
in the spec URL.
	md5sum : c7fde118546d09d747af7b08cb52bfad  libepc-0.4.0.tar.bz2
 [x] Package successfully compiles and builds into binary rpms on at least one
supported architecture.
     Tested on: f15 x86_64
 [x] Package is not known to require ExcludeArch
 [x] All build dependencies are listed in BuildRequires, except for any that
are listed in the exceptions section of Packaging Guidelines.
 [x] The spec file handles locales properly.
 [x] ldconfig called in %post and %postun if required.
 [x] Packages don't bundle copies of system librarie
 [x] Package is not relocatable.
 [x] Package must own all directories that it creates.
 [x] Package requires other packages for directories it uses.
 [x] Package does not contain duplicates in %files.
 [x] Permissions on files are set properly.
 [x] Package consistently uses macros.
 [x] Package contains code, or permissable content.
 [x] Large documentation files are in a -doc subpackage, if required.
 [x] Package uses nothing in %doc for runtime.
 [x] Header files in -devel subpackage, if present.
 [x] Static libraries in -static subpackage, if present.
 [x] Development .so files in -devel subpackage, if present.
 [x] Fully versioned dependency in subpackages with %{?_isa}, if present.
 [x] Package does not contain any libtool archives (.la).
 [-] Package contains a properly installed %{name}.desktop file if it is a GUI
 [x] All filenames in rpm packages must be valid UTF-8
 [x] Package does not own files or directories owned by other packages.

=== SUGGESTED ITEMS ===
 [x] Final requires
libepc
 libavahi-client.so.3()(64bit)  
 libavahi-common.so.3()(64bit)  
 libavahi-glib.so.1()(64bit)  
 libc.so.6()(64bit)  
 libc.so.6(GLIBC_2.14)(64bit)  
 libc.so.6(GLIBC_2.2.5)(64bit)  
 libc.so.6(GLIBC_2.4)(64bit)  
 libgio-2.0.so.0()(64bit)  
 libglib-2.0.so.0()(64bit)  
 libgmodule-2.0.so.0()(64bit)  
 libgnutls.so.26()(64bit)  
 libgnutls.so.26(GNUTLS_1_4)(64bit)  
 libgobject-2.0.so.0()(64bit)  
 libgthread-2.0.so.0()(64bit)  
 libpthread.so.0()(64bit)  
 libpthread.so.0(GLIBC_2.2.5)(64bit)  
 librt.so.1()(64bit)  
 libsoup-2.4.so.1()(64bit)  
 libuuid.so.1()(64bit)  
 libuuid.so.1(UUID_1.0)(64bit)  
libepc-ui
 libatk-1.0.so.0()(64bit)  
 libavahi-client.so.3()(64bit)  
 libavahi-common.so.3()(64bit)  
 libavahi-glib.so.1()(64bit)  
 libc.so.6()(64bit)  
 libc.so.6(GLIBC_2.2.5)(64bit)  
 libcairo.so.2()(64bit)  
 libepc(x86-64) = 0.4.0-1.fc15.remi
 libepc-1.0.so.3()(64bit)  
 libfontconfig.so.1()(64bit)  
 libfreetype.so.6()(64bit)  
 libgdk-x11-2.0.so.0()(64bit)  
 libgdk_pixbuf-2.0.so.0()(64bit)  
 libgio-2.0.so.0()(64bit)  
 libglib-2.0.so.0()(64bit)  
 libgmodule-2.0.so.0()(64bit)  
 libgnutls.so.26()(64bit)  
 libgobject-2.0.so.0()(64bit)  
 libgthread-2.0.so.0()(64bit)  
 libgtk-x11-2.0.so.0()(64bit)   
 libm.so.6()(64bit)  
 libpango-1.0.so.0()(64bit)  
 libpangocairo-1.0.so.0()(64bit)  
 libpangoft2-1.0.so.0()(64bit)  
 libpng12.so.0()(64bit)  
 libpthread.so.0()(64bit)  
 librt.so.1()(64bit)  
 libsoup-2.4.so.1()(64bit)  
 libuuid.so.1()(64bit)  
libepc-devel
 avahi-ui-devel(x86-64) >= 0.6
 glib2-devel(x86-64) >= 2.15.1
 gnutls-devel(x86-64) >= 1.4
 gtk2-devel(x86-64) >= 2.10
 libepc(x86-64) = 0.4.0-1.fc15.remi
 libepc-1.0.so.3()(64bit)  
 libepc-ui(x86-64) = 0.4.0-1.fc15.remi
 libepc-ui-1.0.so.3()(64bit)  
 libsoup-devel(x86-64) >= 2.3
 libuuid-devel >= 1.36
 pkgconfig(avahi-client)  
 pkgconfig(avahi-glib)  
 pkgconfig(gtk+-2.0)  
 pkgconfig(libepc-1.0)  
 pkgconfig(libsoup-2.4)  
[x] Final provides
libepc
 libepc-1.0.so.3()(64bit)  
 libepc = 0.4.0-1.fc15
 libepc(x86-64) = 0.4.0-1.fc15
libepc-ui
 libepc-ui-1.0.so.3()(64bit)  
 libepc-ui = 0.4.0-1.fc15
 libepc-ui(x86-64) = 0.4.0-1.fc15
libepc-devel
 pkgconfig(libepc-1.0) = 0.4.0
 pkgconfig(libepc-ui-1.0) = 0.4.0
 libepc-devel = 0.4.0-1.fc15
 libepc-devel(x86-64) = 0.4.0-1.fc15
 [x] Latest version is packaged.
 [-] If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it. 
 [-] The description and summary sections in the package spec file should contain
     translations for supported Non-English languages, if available.
 [x] Reviewer should test that the package builds in mock.
     Tested on: mock fc15 i686 + Koji 
	http://koji.fedoraproject.org/koji/taskinfo?taskID=3255769
 [x] The package should compile and build into binary rpms on all supported architectures.
     Tested on: i686 + x86_64
 [-] Package functions as described.
 [x] If scriptlets are used, those scriptlets must be sane. 
 [x] If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin 
     consider requiring the package which provides the file instead of the file itself. 
 [-] your package should contain man pages for binaries/scripts. 
     If it doesn't, work with upstream to add them where they make sense.
 [x] The placement of pkgconfig(.pc) files is correct.
 [-] %check is present and the tests pass
 [x] f15/rawhide rpmdiff are ok


========
APPROVED
========

Comment 2 Haïkel Guémar 2011-08-06 08:06:09 UTC
@remi: thank you for the review.

Comment 3 Haïkel Guémar 2011-08-06 08:07:07 UTC
Package Change Request
======================
Package Name: libepc
New Branches: f16
Owners: hguemar
InitialCC: 

This package was deprecated, following our deprecated package ownership claim policy, i announced my intention on the mailing-list, and made libepc re-reviewed.

Comment 4 Gwyn Ciesla 2011-08-06 20:22:08 UTC
Git done (by process-git-requests).

Comment 5 Haïkel Guémar 2011-08-07 09:24:36 UTC
@jon: the scm request went fine for f16 but devel branch still is deprecated (for usual request, it is implict, but it may be different for deprecated packages ?). Could you fix that or should i open a ticket at fedora-instracture trac.

Comment 6 Haïkel Guémar 2011-08-07 09:26:19 UTC
Package Change Request
======================
Package Name: libepc
New Branches: devel
Owners: hguemar
InitialCC:

Comment 7 Gwyn Ciesla 2011-08-08 10:08:56 UTC
Git done (by process-git-requests).

Comment 8 Fedora Update System 2011-08-09 07:37:35 UTC
libepc-0.4.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libepc-0.4.0-1.fc16

Comment 9 Fedora Update System 2011-08-09 21:53:05 UTC
Package libepc-0.4.0-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libepc-0.4.0-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libepc-0.4.0-1.fc16
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-08-22 15:25:13 UTC
libepc-0.4.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.