Bug 72841 - Application craashes when given a parameter it doesn't understand
Summary: Application craashes when given a parameter it doesn't understand
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 72844 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-28 10:52 UTC by Mike MacCana
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version: 0.94
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 04:13:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2002-08-28 10:52:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
Good work on the app - its *really* slick. 

I was looking for documentation on redhat-config-packages. Since it doesn't have a man page or anything in /usr/share/doc, I tried:

redhat-config-packages -help

The application then crashed ungracefully:

[root@localhost SPECS]# redhat-config-packages -help
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 114, in ?
    (args, extra) = getopt.getopt(sys.argv[1:], 't:', ['tree=','isodir='])
  File "/usr/lib/python2.2/getopt.py", line 74, in getopt
    opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
  File "/usr/lib/python2.2/getopt.py", line 124, in do_shorts
    if short_has_arg(opt, shortopts):
  File "/usr/lib/python2.2/getopt.py", line 140, in short_has_arg
    raise GetoptError('option -%s not recognized' % opt, opt)
getopt.GetoptError: option -h not recognized


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run redhat-config-packages with an argument it doesn't understand
2.Watch the output
	

Additional info:

Comment 1 Jeremy Katz 2002-08-28 20:38:47 UTC
--help should work in 0.94.  I've also added a README file to CVS which will be
in the next build

Comment 2 John Thacker 2006-04-22 04:13:29 UTC
Long fixed, RH 8 not supported, and s-c-p isn't shipped anymore.  (Pirut
replaced s-c-p.)  Closing.

Comment 3 John Thacker 2006-04-22 04:13:58 UTC
*** Bug 72844 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.