Bug 728646 - Can't download video.
Summary: Can't download video.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: quvi
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nicoleau Fabien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 728647 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 00:36 UTC by DiEOrLivE
Modified: 2011-08-31 01:38 UTC (History)
3 users (show)

Fixed In Version: quvi-0.2.16.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 01:31:17 UTC


Attachments (Terms of Use)

Description DiEOrLivE 2011-08-06 00:36:27 UTC
Description of problem: Can't download video.


Version-Release number of selected component (if applicable): clive-2.3.0.3-1.fc15.noarch


How reproducible: $ clive http://www.youtube.com/watch?v=INuD2D7R8bk
Checking ...error: /usr/share/quvi/lua/website/youtube.lua:114: no match: fmt_url_map


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michael S. 2011-08-12 00:12:06 UTC
Here is a fix from upstream : 
http://sourceforge.net/apps/trac/quvi/ticket/63

Comment 2 Michael S. 2011-08-12 10:57:57 UTC
Backporting the whole release requiers to rebuild totem ( as the major changed ).

Comment 3 Nicoleau Fabien 2011-08-14 17:58:42 UTC
Hi,
yes Michael, since quvi 0.2.17, there is a so name changed. 

I'll patch version 0.2.16 to fix this.

Fabien

Comment 4 Nicoleau Fabien 2011-08-14 18:05:25 UTC
*** Bug 728647 has been marked as a duplicate of this bug. ***

Comment 5 Nicoleau Fabien 2011-08-15 15:15:09 UTC
Problem : the patch provided is from 0.2.18 to 0.2.19. The 0.2.169 version of youtube.lua is different, the patch can't be applied. 

I'll open a ticket (0.2.17 should have been 0.3.0 imo)

Comment 6 Nicoleau Fabien 2011-08-15 15:29:00 UTC
Here is the ticket : https://sourceforge.net/apps/trac/quvi/ticket/70

Comment 7 Fedora Update System 2011-08-18 17:09:19 UTC
quvi-0.2.16.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/quvi-0.2.16.1-1.fc14

Comment 8 Fedora Update System 2011-08-18 17:12:07 UTC
quvi-0.2.16.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/quvi-0.2.16.1-1.fc15

Comment 9 Fedora Update System 2011-08-19 21:55:55 UTC
Package quvi-0.2.16.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quvi-0.2.16.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/quvi-0.2.16.1-1.fc15
then log in and leave karma (feedback).

Comment 10 Volker Fröhlich 2011-08-29 21:55:56 UTC
Any link from Youtube:

http://www.youtube.com/watch?v=HosTy3X-gLA

leads to

"Expected Perl-style regular expression, e.g. /pattern/flags"

Comment 11 Michael S. 2011-08-29 22:44:48 UTC
to comment #10, it work for me.

Comment 12 Volker Fröhlich 2011-08-29 22:57:28 UTC
Then it probably is NomNom's fault. Could you try to rebuild and install this package?

https://bugzilla.redhat.com/show_bug.cgi?id=708711#c9

Comment 13 Nicoleau Fabien 2011-08-30 10:56:13 UTC
It works for mee too. Do you use clive, cclive, ? nomnom ?
Whitch versions ?
Please try :
"cclive http://www.youtube.com/watch?v=HosTy3X-gLA"

Comment 14 Nicoleau Fabien 2011-08-30 10:58:11 UTC
I have the error with nomnom, but not with clive/cclive (that nomnom uses oO).

For mee, it's not a quvi bug

Comment 15 Volker Fröhlich 2011-08-30 20:03:51 UTC
It is as you say: "cclive http://www.youtube.com/watch?v=HosTy3X-gLA" works, NomNom does not.

Comment 16 Fedora Update System 2011-08-31 01:31:12 UTC
quvi-0.2.16.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-08-31 01:38:07 UTC
quvi-0.2.16.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.