Bug 728681 - abrt fails to download debuginfo because of "TypeError: %d format" in grabber.py
Summary: abrt fails to download debuginfo because of "TypeError: %d format" in grabber.py
Keywords:
Status: CLOSED DUPLICATE of bug 730422
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 742214 (view as bug list)
Depends On:
Blocks: ABRTF17
TreeView+ depends on / blocked
 
Reported: 2011-08-06 11:05 UTC by Thomas Meyer
Modified: 2015-02-01 22:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-03 09:20:26 UTC


Attachments (Terms of Use)

Description Thomas Meyer 2011-08-06 11:05:14 UTC
Description of problem:
abrt catched a core dump and then it tries to download the corresponding debuginfo files, but files because of a python TypeError:
--- Running analyze_LocalGDB ---
Analyzing coredump 'coredump'
Coredump referenziert 232 Debuginfo-Dateien, 232 davon sind nicht installiert 
Nach erforderlichen Paketen in den Softwarebeständen wird gesucht
Pakete für 6 Debuginfo-Dateien können nicht gefunden werden
Herunterzuladende Pakete: 116
298.31Mb werden heruntergeladen, installierte Größe: 1262.10Mb
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1695, in _progress_update
    self.opts.progress_obj.update(downloaded)
  File "/usr/lib/python2.7/site-packages/yum/callbacks.py", line 91, in update
    BaseMeter.update( self, amount_read, now )
  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 141, in update
    self._do_update(amount_read, now)
  File "/usr/lib/python2.7/site-packages/yum/callbacks.py", line 113, in _do_update
    self.updateProgress(name,frac,fread,frtime)
  File "/usr/bin/abrt-action-install-debuginfo", line 172, in updateProgress
    % (self.downloaded_pkgs + 1, self.total_pkgs, name, pct)

Version-Release number of selected component (if applicable):

$ yum list installed abrt*

Installierte Pakete
abrt.i686                                         2.0.3-1.fc15                   @updates
abrt-addon-ccpp.i686                              2.0.3-1.fc15                   @updates
abrt-addon-kerneloops.i686                        2.0.3-1.fc15                   @updates
abrt-addon-python.i686                            2.0.3-1.fc15                   @updates
abrt-cli.i686                                     2.0.3-1.fc15                   @updates
abrt-desktop.i686                                 2.0.3-1.fc15                   @updates
abrt-devel.i686                                   2.0.3-1.fc15                   @updates
abrt-gui.i686                                     2.0.3-1.fc15                   @updates
abrt-libs.i686                                    2.0.3-1.fc15                   @updates
abrt-plugin-bugzilla.i686                         2.0.3-1.fc15                   @updates
abrt-plugin-logger.i686                           2.0.3-1.fc15                   @updates
abrt-plugin-mailx.i686                            2.0.3-1.fc15                   @updates
abrt-plugin-reportuploader.i686                   2.0.3-1.fc15                   @updates
abrt-plugin-rhtsupport.i686                       2.0.3-1.fc15                   @updates

Comment 1 Jiri Moskovcak 2011-10-10 13:50:10 UTC
Does this problem still occur on your system?

Comment 2 Jiri Moskovcak 2011-10-10 14:16:06 UTC
*** Bug 742214 has been marked as a duplicate of this bug. ***

Comment 3 Thomas Meyer 2011-10-10 16:18:56 UTC
Sorry, but I did upgrade this machine to Fedora 16 beta over the weekend. I don't know if the error still occurs.

Comment 4 Jiri Moskovcak 2011-10-11 06:07:41 UTC
Ok, closing this bug as it seems to be fixed, feel free to reopen it if it happens again.

Comment 5 Jiri Moskovcak 2011-10-11 11:46:08 UTC
Just tried it and the bug is not fixed.

reproducer:

0. clean /var/cache/abrt-di/
1. crash something
2. run LANG=de_DE.UTF-8 abrt-gui
3. generate backtrace

Comment 6 Jiri Moskovcak 2011-10-13 12:45:27 UTC
I found the problem - it's caused by the German translation file, the translator switched %s with %i, so the code is getting string where it should get integer, will build a new version with the fix asap. The workaround is to run abrt-gui with the C locale:

$ LANG=C abrt-gui

Comment 7 Thomas Meyer 2011-10-15 11:41:58 UTC
Same as bug 730422. Still present in FC16.

Comment 8 Jiri Moskovcak 2011-11-03 09:20:26 UTC

*** This bug has been marked as a duplicate of bug 730422 ***


Note You need to log in before you can comment on or make changes to this bug.