Bug 730422 - [abrt] abrt-addon-ccpp-2.0.3-1.fc15: abrt-action-install-debuginfo:172:updateProgress:TypeError: %d format: a number is required, not str
Summary: [abrt] abrt-addon-ccpp-2.0.3-1.fc15: abrt-action-install-debuginfo:172:update...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:906dec333e414cf378a911672cf...
: 728681 751125 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 20:49 UTC by Thomas Meyer
Modified: 2015-02-01 22:54 UTC (History)
9 users (show)

Fixed In Version: abrt-2.0.7-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-16 19:53:11 UTC


Attachments (Terms of Use)

Description Thomas Meyer 2011-08-12 20:49:15 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python -u /usr/bin/abrt-action-install-debuginfo --size_mb=4096
comment:        This error occurs everytime abrt tries to download a debuginfo file. I fixed the relevant python script manually to report this bug via abrt...
component:      abrt
executable:     /usr/bin/abrt-action-install-debuginfo
kernel:         3.0.1
os_release:     Fedora release 15 (Lovelock)
package:        abrt-addon-ccpp-2.0.3-1.fc15
reason:         abrt-action-install-debuginfo:172:updateProgress:TypeError: %d format: a number is required, not str
time:           Sat Aug  6 10:49:47 2011
uid:            491
username:       abrt

backtrace:
:abrt-action-install-debuginfo:172:updateProgress:TypeError: %d format: a number is required, not str
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1695, in _progress_update
:    self.opts.progress_obj.update(downloaded)
:  File "/usr/lib/python2.7/site-packages/yum/callbacks.py", line 91, in update
:    BaseMeter.update( self, amount_read, now )
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 141, in update
:    self._do_update(amount_read, now)
:  File "/usr/lib/python2.7/site-packages/yum/callbacks.py", line 113, in _do_update
:    self.updateProgress(name,frac,fread,frtime)
:  File "/usr/bin/abrt-action-install-debuginfo", line 172, in updateProgress
:    % (self.downloaded_pkgs + 1, self.total_pkgs, name, pct)
:TypeError: %d format: a number is required, not str
:
:Local variables in innermost frame:
:frac: 0.9581119903888845
:name: 'gstreamer-plugins-good-debuginfo-0.10.29-1.fc15.i686.rpm'
:self: <__main__.MyDownloadCallback instance at 0x93e1eac>
:fread: '4.2 M'
:pct: 95
:ftime: '00:00'
:t: 1312620587.195344

Comment 1 Jiri Moskovcak 2011-11-03 09:20:26 UTC
*** Bug 728681 has been marked as a duplicate of this bug. ***

Comment 2 Jiri Moskovcak 2011-11-03 15:48:28 UTC
*** Bug 751125 has been marked as a duplicate of this bug. ***

Comment 3 Jiri Moskovcak 2011-11-30 16:22:53 UTC
Fixed in git (commit:28682377a79ca848570c2ea1d06a8d46983bca05)

Comment 4 Fedora Update System 2011-12-10 11:05:34 UTC
abrt-2.0.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.7-2.fc16

Comment 5 Fedora Update System 2011-12-11 21:57:06 UTC
Package abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.7-2.fc16 libreport-2.0.8-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16990/libreport-2.0.8-3.fc16,abrt-2.0.7-2.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-12-16 19:53:11 UTC
abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.