Bug 728696 - [abrt] xen-4.1.1-2.fc15: image.py:46:<module>:Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')
[abrt] xen-4.1.1-2.fc15: image.py:46:<module>:Error: (1, 'Internal error', 'x...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
abrt_hash:73273c7f65db8b865b6c8bc764a...
:
: 757293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-06 10:09 EDT by Marek Michał Mazur
Modified: 2011-12-04 16:05 EST (History)
10 users (show)

See Also:
Fixed In Version: xen-4.1.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-03 21:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marek Michał Mazur 2011-08-06 10:09:05 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/sbin/xend
comment:        running xend
component:      xen
executable:     /usr/sbin/xend
kernel:         2.6.40-4.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        xen-4.1.1-2.fc15
reason:         image.py:46:<module>:Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')
time:           Sat Aug  6 16:07:35 2011
uid:            500
username:       marek

backtrace:
:image.py:46:<module>:Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')
:
:Traceback (most recent call last):
:  File "/usr/sbin/xend", line 16, in <module>
:    from xen.xend.server import SrvDaemon
:  File "/usr/lib64/python2.7/site-packages/xen/xend/server/SrvDaemon.py", line 26, in <module>
:    import relocate
:  File "/usr/lib64/python2.7/site-packages/xen/xend/server/relocate.py", line 28, in <module>
:    from xen.xend import XendDomain
:  File "/usr/lib64/python2.7/site-packages/xen/xend/XendDomain.py", line 36, in <module>
:    from xen.xend import XendOptions, XendCheckpoint, XendDomainInfo
:  File "/usr/lib64/python2.7/site-packages/xen/xend/XendCheckpoint.py", line 20, in <module>
:    from xen.xend import balloon, sxp, image
:  File "/usr/lib64/python2.7/site-packages/xen/xend/image.py", line 46, in <module>
:    xc = xen.lowlevel.xc.xc()
:Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')
:
:Local variables in innermost frame:
:TMEM_DESTROY_POOL: None
:TRIGGER_POWER: None
:xen: None
:XEN_API_VM_POWER_STATE_SHUTTINGDOWN: None
:TMEM_READ: None
:DOMAIN_SHUTDOWN_REASONS: None
:DOM_STATE_HALTED: None
:TMEM_FLUSH_OBJECT: None
:DOMAIN_CRASH: None
:TRIGGER_RESET: None
:TMEM_NEW_PAGE: None
:TMEMC_FREEZE: None
:platform: None
:TMEM_NEW_POOL: None
:TRIGGER_S3RESUME: None
:string: None
:HVM_PARAM_CALLBACK_IRQ: None
:DUMPCORE_IN_PROGRESS: None
:__file__: None
:DOM_STATE_UNKNOWN: None
:XEN_API_ON_NORMAL_EXIT: None
:VmError: None
:xenopts: None
:signal: None
:XEN_API_VBD_MODE: None
:NR_PCI_DEV: None
:TMEM_CONTROL: None
:x: None
:HVMRequired: None
:osdep: None
:auxbin: None
:TMEM_GET_PAGE: None
:NR_PCI_FUNC: None
:XEN_API_ON_CRASH_BEHAVIOUR: None
:xswatch: None
:XEN_API_VDI_TYPE: None
:LAST_SHUTDOWN_REASON: None
:re: None
:REVERSE_DOMAIN_SHUTDOWN_REASONS: None
:TMEMC_DESTROY: None
:XEN_API_VM_POWER_STATE_SUSPENDED: None
:math: None
:fcntl: None
:__builtins__: {'bytearray': <type 'bytearray'>, 'IndexError': <type 'exceptions.IndexError'>, 'all': <built-in function all>, 'help': Type help() for interactive help, or help(object) for help about object., 'vars': <built-in function vars>, 'SyntaxError': <type 'exceptions.SyntaxError'>, 'unicode': <type 'unicode'>, 'UnicodeDecodeError': <type 'exceptions.UnicodeDecodeError'>, 'memoryview': <type 'memoryview'>, 'isinstance': <built-in function isinstance>, 'copyright': Copyright (c) 2001-2010 Python Software Foundation.
:All Rights Reserved.
:
:Copyright (c) 2000 BeOpen.com.
:All Rights Reserved.
:
:Copyright (c) 1995-2001 Corporation for National Research Initiatives.
:All Rights Reserved.
:
:Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
:All Rights Reserved., 'NameError': <type 'exceptions.NameError'>, 'BytesWarning': <type 'exceptions.BytesWarning'>, 'dict': <type 'dict'>, 'input': <built-in function input>, 'oct': <built-in function oct>, 'bin': <built-in function bin>, 'SystemExit': <type 'exceptions.SystemExit'>, 'StandardError': <type 'exceptions.StandardError'>, 'format': <built-in function format>, 'repr': <built-in function repr>, 'sorted': <built-in function sorted>, 'False': False, 'RuntimeWarning': <type 'exceptions.RuntimeWarning'>, 'list': <type 'list'>, 'iter': <built-in function iter>, 'reload': <built-in function reload>, 'Warning': <type 'exceptions.Warning'>, '__package__': None, 'round': <built-in function round>, 'dir': <built-in function dir>, 'cmp': <built-in function cmp>, 'set': <type 'set'>, 'bytes': <type 'str'>, 'reduce': <built-in function reduce>, 'intern': <built-in function intern>, 'issubclass': <built-in function issubclass>, 'Ellipsis': Ellipsis, 'EOFError': <type 'exceptions.EOFError'>, 'locals': <built-in function locals>, 'BufferError': <type 'exceptions.BufferError'>, 'slice': <type 'slice'>, 'FloatingPointError': <type 'exceptions.FloatingPointError'>, 'sum': <built-in function sum>, 'getattr': <built-in function getattr>, 'abs': <built-in function abs>, 'exit': Use exit() or Ctrl-D (i.e. EOF) to exit, 'print': <built-in function print>, 'True': True, 'FutureWarning': <type 'exceptions.FutureWarning'>, 'ImportWarning': <type 'exceptions.ImportWarning'>, 'None': None, 'hash': <built-in function hash>, 'ReferenceError': <type 'exceptions.ReferenceError'>, 'len': <built-in function len>, 'credits':     Thanks to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
:    for supporting Python development.  See www.python.org for more information., 'frozenset': <type 'frozenset'>, '__name__': '__builtin__', 'ord': <built-in function ord>, 'super': <type 'super'>, 'TypeError': <type 'exceptions.TypeError'>, 'license': See http://www.python.org/2.7/license.html, 'KeyboardInterrupt': <type 'exceptions.KeyboardInterrupt'>, 'UserWarning': <type 'exceptions.UserWarning'>, 'filter': <built-in function filter>, 'range': <built-in function range>, 'staticmethod': <type 'staticmethod'>, 'SystemError': <type 'exceptions.SystemError'>, 'BaseException': <type 'exceptions.BaseException'>, 'pow': <built-in function pow>, 'RuntimeError': <type 'exceptions.RuntimeError'>, 'float': <type 'float'>, 'MemoryError': <type 'exceptions.MemoryError'>, 'StopIteration': <type 'exceptions.StopIteration'>, 'globals': <built-in function globals>, 'divmod': <built-in function divmod>, 'enumerate': <type 'enumerate'>, 'apply': <built-in function apply>, 'LookupError': <type 'exceptions.LookupError'>, 'open': <built-in function open>, 'quit': Use quit() or Ctrl-D (i.e. EOF) to exit, 'basestring': <type 'basestring'>, 'UnicodeError': <type 'exceptions.UnicodeError'>, 'zip': <built-in function zip>, 'hex': <built-in function hex>, 'long': <type 'long'>, 'next': <built-in function next>, 'ImportError': <type 'exceptions.ImportError'>, 'chr': <built-in function chr>, 'xrange': <type 'xrange'>, 'type': <type 'type'>, '__doc__': "Built-in functions, exceptions, and other objects.\n\nNoteworthy: None is the `nil' object; Ellipsis represents `...' in slices.", 'Exception': <type 'exceptions.Exception'>, 'tuple': <type 'tuple'>, 'UnicodeTranslateError': <type 'exceptions.UnicodeTranslateError'>, 'reversed': <type 'reversed'>, 'UnicodeEncodeError': <type 'exceptions.UnicodeEncodeError'>, 'IOError': <type 'exceptions.IOError'>, 'hasattr': <built-in function hasattr>, 'delattr': <built-in function delattr>, 'setattr': <built-in function setattr>, 'raw_input': <built-in function raw_input>, 'SyntaxWarning': <type 'exceptions.SyntaxWarning'>, 'compile': <built-in function compile>, 'ArithmeticError': <type 'exceptions.ArithmeticError'>, 'str': <type 'str'>, 'property': <type 'property'>, 'GeneratorExit': <type 'exceptions.GeneratorExit'>, 'int': <type 'int'>, '__import__': <built-in function __import__>, 'KeyError': <type 'exceptions.KeyError'>, 'coerce': <built-in function coerce>, 'PendingDeprecationWarning': <type 'exceptions.PendingDeprecationWarning'>, 'file': <type 'file'>, 'EnvironmentError': <type 'exceptions.EnvironmentError'>, 'unichr': <built-in function unichr>, 'id': <built-in function id>, 'OSError': <type 'exceptions.OSError'>, 'DeprecationWarning': <type 'exceptions.DeprecationWarning'>, 'min': <built-in function min>, 'UnicodeWarning': <type 'exceptions.UnicodeWarning'>, 'execfile': <built-in function execfile>, 'any': <built-in function any>, 'complex': <type 'complex'>, 'bool': <type 'bool'>, 'ValueError': <type 'exceptions.ValueError'>, 'NotImplemented': NotImplemented, 'map': <built-in function map>, 'buffer': <type 'buffer'>, 'max': <built-in function max>, 'object': <type 'object'>, 'TabError': <type 'exceptions.TabError'>, 'callable': <built-in function callable>, 'ZeroDivisionError': <type 'exceptions.ZeroDivisionError'>, 'eval': <built-in function eval>, '__debug__': True, 'IndentationError': <type 'exceptions.IndentationError'>, 'AssertionError': <type 'exceptions.AssertionError'>, 'classmethod': <type 'classmethod'>, 'UnboundLocalError': <type 'exceptions.UnboundLocalError'>, 'NotImplementedError': <type 'exceptions.NotImplementedError'>, 'AttributeError': <type 'exceptions.AttributeError'>, 'OverflowError': <type 'exceptions.OverflowError'>}
:VTPM_DELETE_SCRIPT: None
:HVM_PARAM_ACPI_S_STATE: None
:DOM_STATE_CRASHED: None
:HVM_PARAM_VIRIDIAN: None
:XEN_API_VM_POWER_STATE_HALTED: None
:__name__: None
:XEN_API_ON_CRASH_BEHAVIOUR_LEGACY: None
:DOM_STATES: None
:DOM_STATE_SHUTDOWN: None
:thread: None
:DOM_STATE_SUSPENDED: None
:XS_POOLROOT: None
:XEN_API_VM_POWER_STATE_PAUSED: None
:DOMAIN_HALT: None
:NR_PCI_DEVFN: None
:os: None
:HVM_PARAM_HPET_ENABLED: None
:TRIGGER_TYPE: None
:XendError: None
:DOMAIN_SUSPEND: None
:HVM_PARAM_PAE_ENABLED: None
:HVM_PARAM_BUFIOREQ_PFN: None
:xstransact: None
:HVM_PARAM_STORE_PFN: None
:TMEMC_FLUSH: None
:log: None
:errno: None
:XEN_API_ON_CRASH_BEHAVIOUR_FILTER: None
:TMEMC_QUERY_FREEABLE_MB: None
:DOMAIN_REBOOT: None
:__doc__: None
:oshelp: None
:MINIMUM_RESTART_TIME: None
:XEN_API_VM_POWER_STATE: None
:HVM_PARAM_TIMER_MODE: None
:DEV_MIGRATE_STEP1: None
:DEV_MIGRATE_STEP3: None
:DEV_MIGRATE_STEP2: None
:XEN_API_VBD_TYPE: None
:HVM_PARAM_BUFPIOREQ_PFN: None
:TMEMC_SET_CAP: None
:DEV_MIGRATE_TEST: None
:XS_VMROOT: None
:DOM_STATE_RUNNING: None
:TMEMC_SET_WEIGHT: None
:traceback: None
:XendOptions: None
:utils: None
:HVM_PARAM_STORE_EVTCHN: None
:TRIGGER_INIT: None
:XEN_API_VM_POWER_STATE_UNKNOWN: None
:AUTO_PHP_SLOT: None
:HVM_PARAM_VHPT_SIZE: None
:HVM_PARAM_VPT_ALIGN: None
:DOM_STATES_OLD: None
:RESTART_IN_PROGRESS: None
:__package__: None
:TMEMC_SET_COMPRESS: None
:SHUTDOWN_TIMEOUT: None
:XEN_API_VM_POWER_STATE_CRASHED: None
:XEN_API_VM_POWER_STATE_RUNNING: None
:DOMAIN_POWEROFF: None
:restart_modes: None
:XEN_API_TASK_STATUS_TYPE: None
:glob: None
:TMEMC_LIST: None
:sys: None
:HVM_PARAM_IOREQ_PFN: None
:TMEMC_THAW: None
:TMEM_XCHG: None
:arch: None
:XEN_API_CONSOLE_PROTOCOL: None
:TMEM_WRITE: None
:TMEM_PUT_PAGE: None
:TRIGGER_NMI: None
:DOM_STATE_PAUSED: None
:HVM_PARAM_NVRAM_FD: None
:time: None
:y: None
:TMEM_FLUSH_PAGE: None
Comment 1 Pratyush Sahay 2011-11-10 03:48:41 EST
Package: xen-4.1.1-8.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Trying to create a Xen virtual system
Comment 2 Pratyush Sahay 2011-11-10 04:05:31 EST
Package: xen-4.1.1-8.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Trying to start Xen hypervisor
Comment 3 Majid Azimi 2011-11-10 17:31:52 EST
Package: xen-4.1.1-8.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I don't know
Comment 4 Pratyush Sahay 2011-11-10 21:12:23 EST
Package: xen-4.1.2-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Starting Xen hypervisor
Comment 5 Eric Blake 2011-11-11 13:32:58 EST
Package: xen-4.1.2-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Running 'make check' on libvirt.git
Comment 6 Eric Blake 2011-11-18 17:27:39 EST
(In reply to comment #5)
> Package: xen-4.1.2-1.fc16
> Architecture: x86_64
> OS Release: Fedora release 16 (Verne)
> 
> Comment
> -----
> Running 'make check' on libvirt.git

I've just pushed a patch to libvirt.git that will avoid calling '/usr/sbin/xend status' on a non-Xen kernel; that still doesn't fix the problem of xend causing an ABRT crash every time someone attempts to use it in a non-Xen context, but at least libvirt's testsuite is no longer tickling the problem.
Comment 7 Fedora Update System 2011-11-21 16:48:57 EST
xen-4.1.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xen-4.1.2-2.fc16
Comment 8 Michael Young 2011-11-21 16:53:16 EST
xen-4.1.2-2.fc16 should return an ordinary error rather than produce a python backtrace if xend is run when hypervisor is absent.
Comment 9 Fedora Update System 2011-11-22 20:03:02 EST
Package xen-4.1.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xen-4.1.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16285/xen-4.1.2-2.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-12-03 21:42:50 EST
xen-4.1.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Michael Young 2011-12-04 16:05:09 EST
*** Bug 757293 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.