Bug 728772 - Libvirt broken large file support [rawhide]
Summary: Libvirt broken large file support [rawhide]
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Eric Blake
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 728992 729194
TreeView+ depends on / blocked
 
Reported: 2011-08-07 11:02 UTC by Laurent Defert
Modified: 2011-09-29 16:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 728992 729194 (view as bug list)
Environment:
Last Closed: 2011-09-29 16:51:33 UTC


Attachments (Terms of Use)
Patch to bring back large file support (908 bytes, patch)
2011-08-07 11:02 UTC, Laurent Defert
no flags Details | Diff

Description Laurent Defert 2011-08-07 11:02:32 UTC
Created attachment 517037 [details]
Patch to bring back large file support

Description of problem:
Using the latest git version (as of Aug. 7 2011), libvirt cannot open VM image whose size is superior to 2Go (on my system at least). It appears the regression has been introduced in commit 70e05fa6d033eeebaf7e072233b45d334d6139d8.
The attached patch partly reverts this commit to fix large file support (not sure wether it's the right way to fix it, since it's supposed to be handled by the gnulib).

Version-Release number of selected component (if applicable):
Since 0.9.4

How reproducible:
Always

Steps to Reproduce:
1. Start a VM whose size is > 2Go.

Actual results:
Get this error:
12:57:21.637: 26033: error : virDomainDiskDefForeachPath:11380 : unable to open disk path /home/virtkvm/storage/VM1.img: Value too large for defined data type

Comment 1 Daniel Veillard 2011-08-08 07:27:09 UTC
This is likely to be a portability issue, what is the system you are using
and can you post the relevant part of the config.log configure ouput,

 thanks,

Daniel

Comment 2 Eric Blake 2011-08-08 14:44:58 UTC
Gnulib already invokes AC_SYS_LARGEFILE; re-adding it to configure.ac shouldn't be changing anything.

Comment 3 Eric Blake 2011-08-08 14:51:28 UTC
Oh - I see - this is a nasty bug in gnulib:
http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=7c185762
introduced modules/largefile, but mistakenly has 'configure.ac' listed twice, instead of the intended 'configure.ac-early' for AC_REQUIRE([AC_SYS_LARGEFILE]) and 'configure.ac' empty.  As a result, gnulib-tool is no longer invoking AC_SYS_LARGEFILE.

Comment 4 Eric Blake 2011-08-08 14:59:19 UTC
Regression introduced in libvirt commit 1c93fbbb, since that is the one that updated the gnulib submodule to include gnulib commit 7c18576.

Laurent's patch is appropriate for applying in backports where a full gnulib update is not appropriate.

Comment 5 Eric Blake 2011-09-29 16:51:33 UTC
F15 is too old to be affected, and F16 and rawhide have now been rebased to 0.9.6, so I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.