Bug 729194 - Libvirt broken large file support [rawhide]
Summary: Libvirt broken large file support [rawhide]
Keywords:
Status: CLOSED DUPLICATE of bug 728992
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 728772
Blocks: 728992
TreeView+ depends on / blocked
 
Reported: 2011-08-09 02:37 UTC by Daniel Veillard
Modified: 2011-08-09 06:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 728772
Environment:
Last Closed: 2011-08-09 06:00:32 UTC


Attachments (Terms of Use)

Description Daniel Veillard 2011-08-09 02:37:19 UTC
+++ This bug was initially created as a clone of Bug #728772 +++

Created attachment 517037 [details]
Patch to bring back large file support

Description of problem:
Using the latest git version (as of Aug. 7 2011), libvirt cannot open VM image whose size is superior to 2Go (on my system at least). It appears the regression has been introduced in commit 70e05fa6d033eeebaf7e072233b45d334d6139d8.
The attached patch partly reverts this commit to fix large file support (not sure wether it's the right way to fix it, since it's supposed to be handled by the gnulib).

Version-Release number of selected component (if applicable):
Since 0.9.4

How reproducible:
Always

Steps to Reproduce:
1. Start a VM whose size is > 2Go.

Actual results:
Get this error:
12:57:21.637: 26033: error : virDomainDiskDefForeachPath:11380 : unable to open disk path /home/virtkvm/storage/VM1.img: Value too large for defined data type

--- Additional comment from veillard@redhat.com on 2011-08-08 03:27:09 EDT ---

This is likely to be a portability issue, what is the system you are using
and can you post the relevant part of the config.log configure ouput,

 thanks,

Daniel

--- Additional comment from eblake@redhat.com on 2011-08-08 10:44:58 EDT ---

Gnulib already invokes AC_SYS_LARGEFILE; re-adding it to configure.ac shouldn't be changing anything.

--- Additional comment from eblake@redhat.com on 2011-08-08 10:51:28 EDT ---

Oh - I see - this is a nasty bug in gnulib:
http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=7c185762
introduced modules/largefile, but mistakenly has 'configure.ac' listed twice, instead of the intended 'configure.ac-early' for AC_REQUIRE([AC_SYS_LARGEFILE]) and 'configure.ac' empty.  As a result, gnulib-tool is no longer invoking AC_SYS_LARGEFILE.

--- Additional comment from eblake@redhat.com on 2011-08-08 10:59:19 EDT ---

Regression introduced in libvirt commit 1c93fbbb, since that is the one that updated the gnulib submodule to include gnulib commit 7c18576.

Laurent's patch is appropriate for applying in backports where a full gnulib update is not appropriate.

Comment 1 Daniel Veillard 2011-08-09 02:40:11 UTC
Patch posted upstream but for RHEL-6.2 we will instead use the patch
provided in Bug #728772 as it doesn't require to updte gnulib

https://www.redhat.com/archives/libvir-list/2011-August/msg00285.html

Daniel

Comment 3 Daniel Veillard 2011-08-09 06:00:32 UTC

*** This bug has been marked as a duplicate of bug 728992 ***


Note You need to log in before you can comment on or make changes to this bug.