This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 728775 - grub2 --class xen: initramfs missing, booting under XEN fails (found on Fedora 16)
grub2 --class xen: initramfs missing, booting under XEN fails (found on Fedor...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 738010 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-07 07:43 EDT by Marko Ristola
Modified: 2011-09-30 14:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: grub2-1.99-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 14:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
While searching initrd files, search initramfs-_kernel_version_.img too (743 bytes, patch)
2011-08-07 07:43 EDT, Marko Ristola
no flags Details | Diff

  None (edit)
Description Marko Ristola 2011-08-07 07:43:01 EDT
Created attachment 517041 [details]
While searching initrd files, search initramfs-_kernel_version_.img too

Description of problem:

grub2-mkconfig generates initramfs-less boot entries for "--class xen"
Effect is that XEN kernels are not bootable.

/etc/grub.d/20_linux_xen searches /boot/initrd-* style files.
Unfortunately in Fedora 16 install the files are named
/boot/initramfs-*. Thus "--class xen" entries don't have initrd at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Install xen package on current Fedora 16.
2. Run grub2-mkconfig -o /boot/grub2/grub.cfg
3. Test if men uentries on /boot/grub2/grub.cfg for XEN include initramfs lines.
  
Actual results:

initramfs is not introduced on "--class xen". Trying to boot them fails.

Expected results:

initramfs is included on "--class xen" menu entries.
Booting XEN loads initramfs.

Additional info:
Comment 1 Konrad Rzeszutek Wilk 2011-09-13 10:30:03 EDT
The patch definitely did the trick for me.

So Tested-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

can be certainly added.
Comment 2 Andy Burns 2011-09-14 01:05:53 EDT
*** Bug 738010 has been marked as a duplicate of this bug. ***
Comment 3 Andy Burns 2011-09-14 01:14:28 EDT
The patch in my DUPE ought to be in a marginally more acceptble format (diff -Naur) but in any case this is a trivial one-liner ...
Comment 4 Fedora Update System 2011-09-14 16:28:50 EDT
grub2-1.99-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grub2-1.99-6.fc16
Comment 5 Fedora Update System 2011-09-15 17:19:20 EDT
Package grub2-1.99-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-1.99-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/grub2-1.99-6.fc16
then log in and leave karma (feedback).
Comment 6 W. Michael Petullo 2011-09-16 11:19:19 EDT
I just tested this new package on Fedora Beta RC1 and see that grub2-mkconfig now creates the proper initramfs lines. So, this seems fixed.
Comment 7 Fedora Admin XMLRPC Client 2011-09-16 15:08:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Konrad Rzeszutek Wilk 2011-09-29 17:56:43 EDT
Works now
Comment 9 Fedora Update System 2011-09-30 14:49:00 EDT
grub2-1.99-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.