Bug 738010 - Missing initramfs in grub stanza causes dom0 to panic during boot
Summary: Missing initramfs in grub stanza causes dom0 to panic during boot
Keywords:
Status: CLOSED DUPLICATE of bug 728775
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 15:57 UTC by Andy Burns
Modified: 2011-09-14 05:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 05:05:53 UTC


Attachments (Terms of Use)
Fix xen dom0 stanzas (559 bytes, patch)
2011-09-13 19:51 UTC, Andy Burns
no flags Details | Diff

Description Andy Burns 2011-09-13 15:57:40 UTC
Description of problem:
========================
Installed FC16alpha with updates as of 13-SEP-2011
boots sucessfully as bare metal, but by default fails to boot as dom0

If I manually add an extra "module" for the initramfs to the grub stanza for Fedora/Xen it boots OK.

Version-Release number of selected component (if applicable):
=============================================================
kernel.x86_64     3.1.0-0.rc5.git0.0.fc16
xen.x86_64        4.1.1-3.fc16
grub2.x86_64      1:1.99-5.fc16

How reproducible:
=================
every time so far

Steps to Reproduce:
===================
1. Select Xen 4.1.1 submenu from grub2
2. Select Fedora16 option and allow to boot
  
Actual results:
===============
Xen loads, kernel loads, then

BUG: scheduling while atominc: swapper/1/10000002
Kernel pamnic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Pid: 1, comm: swapper Not tainted 3.1.0-0.rc5.git0.0.fc16.x86_64


Expected results:
==================
Boots dom0


Additional info:
================
My last experience of Xen dom0 with Fedora was back on FC8, since then I've used Centos5 as dom0 with Xen 4.1.0 from gitco.de, obviously lots of relevant changes have occured since FC8 in terms of Kernel, grub2, xen/pvops, systemd that I may be unaware of, but it suggests a missing section from  
/etc/grub.d/20_linux_xen

Default grub stanza that boots OK as baremetal
==============================================

menuentry 'Linux, with Linux 3.1.0-0.rc5.git0.0.fc16.x86_64' --class gnu-linux --class gnu --class os {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod raid
        insmod mdraid09
        insmod part_msdos
        insmod part_msdos
        insmod ext2
        set root='(md0)'
        search --no-floppy --fs-uuid --set=root c9d6e8f9-1a41-452c-a4a0-26ecddc25dbb
        echo    'Loading Linux 3.1.0-0.rc5.git0.0.fc16.x86_64 ...'
        linux   /vmlinuz-3.1.0-0.rc5.git0.0.fc16.x86_64 root=/dev/mapper/vgr1-fc16_root ro quiet rhgb
        echo    'Loading initial ramdisk ...'
        initrd  /initramfs-3.1.0-0.rc5.git0.0.fc16.x86_64.img
}


Xen stanza that causes error
============================

submenu "Xen 4.1.1" {
menuentry 'Linux, with Xen 4.1.1 and Linux 3.1.0-0.rc5.git0.0.fc16.x86_64' --class gnu-linux --class gnu --class os --class xen {
        insmod raid
        insmod mdraid09
        insmod part_msdos
        insmod part_msdos
        insmod ext2
        set root='(md0)'
        search --no-floppy --fs-uuid --set=root c9d6e8f9-1a41-452c-a4a0-26ecddc25dbb
        echo    'Loading Xen 4.1.1 ...'
        multiboot       /xen-4.1.1.gz placeholder
        echo    'Loading Linux 3.1.0-0.rc5.git0.0.fc16.x86_64 ...'
        module  /vmlinuz-3.1.0-0.rc5.git0.0.fc16.x86_64 placeholder root=/dev/mapper/vgr1-fc16_root ro quiet rhgb
}


Fixed Xen stanza
================

submenu "Xen 4.1.1" {
menuentry 'Linux, with Xen 4.1.1 and Linux 3.1.0-0.rc5.git0.0.fc16.x86_64' --class gnu-linux --class gnu --class os --class xen {
        insmod raid
        insmod mdraid09
        insmod part_msdos
        insmod part_msdos
        insmod ext2
        set root='(md0)'
        search --no-floppy --fs-uuid --set=root c9d6e8f9-1a41-452c-a4a0-26ecddc25dbb
        echo    'Loading Xen 4.1.1 ...'
        multiboot       /xen-4.1.1.gz placeholder
        echo    'Loading Linux 3.1.0-0.rc5.git0.0.fc16.x86_64 ...'
        module  /vmlinuz-3.1.0-0.rc5.git0.0.fc16.x86_64 placeholder root=/dev/mapper/vgr1-fc16_root ro quiet rhgb
        echo    'Loading initial ramdisk ...'
        module  /initramfs-3.1.0-0.rc5.git0.0.fc16.x86_64.img
}

Comment 1 Andy Burns 2011-09-13 19:13:06 UTC
Further comments ...

I can see in the /etc/grub.d/20_linux_xen script that there is code in place which *ought* to add the initramfs module, but for sone reason it is not being triggered, any clue why?

Also the "BUG: scheduling while atomic: swapper/1/10000002" error still occurs, but is only feetingly displayed, provided the reootfs can be found.

Comment 2 Andy Burns 2011-09-13 19:51:00 UTC
Created attachment 522992 [details]
Fix xen dom0 stanzas

I've figured out that the search list of possible initrd/ramfs names was missing the correct format, attached patch which makes the  

/etc/grub.d/20_linux_xen 

helper script do the right thing.

Comment 3 Andy Burns 2011-09-14 05:05:53 UTC
I believe I've encountered the same problem as this existing bug, my fix is identical, can this get actioned?

*** This bug has been marked as a duplicate of bug 728775 ***


Note You need to log in before you can comment on or make changes to this bug.