Bug 728851 - Shortcut navigating with keys (Alt+j/k/up/down) or mouse in Chrome can lose focus on editor window
Shortcut navigating with keys (Alt+j/k/up/down) or mouse in Chrome can lose f...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3-alpha-3
Unspecified Linux
unspecified Severity medium
: ---
: 1.7
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-08 02:56 EDT by David Mason
Modified: 2012-09-12 20:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120706-0026)
Doc Type: Bug Fix
Doc Text:
Cause: Conflicting of keyboard shortcut with focus event in editor. Consequence: Editor lost focus with the used of keys (Alt+j/k/up/down). Users need to click on the editor again to start translation. Fix: See https://bugzilla.redhat.com/show_bug.cgi?id=836051 Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2011-08-08 02:56:22 EDT
User-Agent:       Mozilla/5.0 (X11; Linux i686 (x86_64)) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.124 Safari/534.30

When moving from one editor window to another in Chrome, whether using navigation key shortcuts or by clicking in the target cell, the editor window for the new cell opens but immediately loses focus. A user cannot type in the cell until they have used Tab / Alt+Tab or a mouse click to move focus to the cell.

Reproducible: Sometimes

Steps to Reproduce:
Appears to vary between different computers
1.Sign in and open webtrans editor in Chrome
2.Select and focus first target cell (currently requires two clicks)
3.Select the next target cell with
   a. mouse click;
   b. Alt+k;
   c. Alt+down; OR
   d. Ctrl+Enter
4. Try to type in the editor cell or use one of the key shortcuts
Actual Results:  
Editor window opens for second target cell, but loses focus so typing and key shortcuts don't work.

Expected Results:  
Typing immediately after selecting a target cell appends typed characters to any existing content. Key shortcuts work.

This appears to correspond with the "Saved changes to translation unit" message appearing in the blue bar near the project/document name.
Comment 1 David Mason 2011-08-08 03:01:46 EDT
On another machine, the bug could only be reproduced by typing Alt+j followed by Alt+k in rapid succession.
Comment 2 Sean Flanigan 2011-08-08 03:20:57 EDT
Do you mean bug 728854?  I think that's actually a different problem, because it makes the editor cell go away.

In *this* bug, the editor cell is there, it just doesn't have focus.
Comment 3 David Mason 2011-08-08 19:21:37 EDT
You're right, the behaviour is different between this and bug 728854.
Comment 4 Sean Flanigan 2011-09-07 00:33:47 EDT
Assigning to Scrum product owner for prioritisation.
Comment 5 Alex Eng 2012-07-03 21:46:25 EDT
Problem fixed along with implementation in 

https://bugzilla.redhat.com/show_bug.cgi?id=836051
Comment 6 Ding-Yi Chen 2012-07-05 22:50:37 EDT
VERIFIED with Zanata version 1.7-SNAPSHOT (20120706-0026) on
Google Chrome 20.0.1132.34 beta
Chromium 17.0.963.79

Note You need to log in before you can comment on or make changes to this bug.