Bug 728962 - LUKSError: luks device not configured
Summary: LUKSError: luks device not configured
Keywords:
Status: CLOSED DUPLICATE of bug 727814
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 13:42 UTC by Kamil Páral
Modified: 2011-08-08 15:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 15:07:51 UTC


Attachments (Terms of Use)
logs (490.00 KB, application/x-tar)
2011-08-08 13:42 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2011-08-08 13:42:05 UTC
Created attachment 517218 [details]
logs

Description of problem:
I performed one installation, that went wrong somehow (didn't boot). I run second installation, but after clicking "Create custom layout" I got:

09:37:21,851 CRIT anaconda: anaconda 16.14.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/luks.py", line 166, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 84, in getLUKSPassphrase
    device.format.setup()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1175, in handleUdevLUKSFormat
    self.__passphrases)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1598, in handleUdevDeviceFormat
    self.handleUdevLUKSFormat(info, device)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1031, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1832, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1789, in populate
    self._populate(progressWindow)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 473, in reset
    cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/autopart_type.py", line 157, in getNext
    self.anaconda.storage.reset()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1194, in nextClicked
    rc = self.currentWindow.getNext ()
LUKSError: luks device not configured

I cancelled the request for disk password at the beginning of the installation, if that's important.

Version-Release number of selected component (if applicable):
anaconda-16.14.2
F16 Alpha RC1

Comment 1 David Lehman 2011-08-08 15:07:51 UTC

*** This bug has been marked as a duplicate of bug 727814 ***


Note You need to log in before you can comment on or make changes to this bug.