Bug 727814 - F16 Alpha TC1 installer crash | LUKSError: luks device not configured
F16 Alpha TC1 installer crash | LUKSError: luks device not configured
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:d878de1b1b21beddb0e26b994e5...
: CommonBugs
: 728962 731211 (view as bug list)
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept 741538
  Show dependency treegraph
 
Reported: 2011-08-03 06:12 EDT by Michael Schwendt
Modified: 2011-10-03 05:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-16.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 21:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2011-08-03 06:12:37 EDT
Description of problem: Anaconda crashes and therefore refuses to continue if (at least one?) LUKS passphrase prompt is cancelled. Normally I cancel them all because the encrypted partitions/LVs are not needed during installation. When just for testing I entered the passphrase for a shared /home LV, Anaconda also crashed.

After choosing "Create custom layout", Anaconda re-examined the storage devices
once more, then crashed:

  LUKSError: luks device not configured


Couldn't save/report the backtrace with the included helper tool, because that one failed, too (mentioned the symptoms on test list).

Version-Release number of selected component (if applicable):
Anaconda in F16 TC1 netinstall ISO image

How reproducible:
Always
Comment 1 Michael Schwendt 2011-08-03 10:29:08 EDT
Confirming:

* If I fill in all LUKS passphrase prompts, installer proceeds without crashing later on.

* Unrelated to the crash? : if I enter a secondary (alternative) passphrase for my /home partition, I need to type it in twice, and Anaconda proceeds but later on doesn't recognise the partition. It displays type "unknown" instead of ext4.
Comment 2 David Lehman 2011-08-04 11:44:59 EDT
Try adding updates=http://dlehman.fedorapeople.org/updates-727814.0.img to your boot command line and let me know the results. Thanks.
Comment 3 Michael Schwendt 2011-08-04 12:15:02 EDT
Tested "cancelling all passphrase dialogs", and that

   works for me

when using the updates image. Will also test entering a passphrase for just one of the several encrypted partitions.

I've filed a separate ticket about the issue with alternative passphrases: bug 728301
Comment 4 Michael Schwendt 2011-08-04 13:20:46 EDT
Unlocking just one encrypted partition (and cancelling the others) also works with the updates image.
Comment 5 David Lehman 2011-08-08 11:07:51 EDT
*** Bug 728962 has been marked as a duplicate of this bug. ***
Comment 6 David Lehman 2011-08-16 20:59:07 EDT
*** Bug 731211 has been marked as a duplicate of this bug. ***
Comment 7 Adam Williamson 2011-08-17 02:24:55 EDT
Worth noting this for Alpha. It keeps biting me in the ass...
Comment 8 Tim Flink 2011-09-01 13:18:54 EDT
Discussed in the 2011-08-26 blocker review meeting. Rejected as a Fedora 16 beta blocker because it doesn't violate any of the beta release criteria [1].

Accepted as NTH because it's annoying and a fix is ready.

[1] https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 9 Michael Schwendt 2011-09-02 11:24:49 EDT
To clarify the original report:

1) Cancelling _all_ LUKS passphrase made Anaconda crash.

2) Filling in only one LUKS passphrase prompt also made Anaconda crash.

Then dlehman offered an updates.img for testing, and it passed both test-cases.
Comment 10 Tim Flink 2011-09-02 11:33:34 EDT
Hrm, it looks like we may have misunderstood the impact of the bug.

This is listed as fixed with anaconda-16.15-1 which is pre beta TC1. I assume that the fix is in the 16.16-1 that is in TC1.

Is this still present in beta TC1?
Comment 11 Adam Williamson 2011-09-22 21:09:37 EDT
Re-tested and confirmed fixed in Beta TC1. I can safely proceed past partitioning step after cancelling the passphrase dialog for an encrypted partition from an F15 install on the target disk.

Note You need to log in before you can comment on or make changes to this bug.