Bug 729023 - Debuginfo package issues in openoffice.org
Debuginfo package issues in openoffice.org
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks: 727919
  Show dependency treegraph
 
Reported: 2011-08-08 11:19 EDT by Karel Klíč
Modified: 2013-03-03 18:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 11:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2011-08-08 11:19:53 EDT
Several problems related to debuginfo were found in the openoffice.org-3.2.1-19.6.el6_0.5 package. These issues might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Debuginfo symbolic links pointing to another path
-------------------------------------------------
Debuginfo package includes a symbolic link to each binary that has the debugging symbols stored there. For openoffice.org, 8 symbolic links do not point to the right binary, and that makes it impossible to use build ids from a coredump to get a list of packages required by it. Usually, this is a packaging error caused usually by placing identical binary into several locations instead of creating a symlink. If one copy of the binary is SUID/SGID, it is not possible to use symlink. You can add a dependency on bug #727872 and rebuild openoffice.org when that bug is fixed.

- affected binary: /usr/lib/broffice.org3/program/simpress.bin
  affected package: broffice.org-impress-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/sdraw.bin
  referenced package: openoffice.org-draw-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/67/77adff6b4fba762868b8fc94ebcc23ea8b6fbd
- affected binary: /usr/lib/broffice.org3/program/swriter.bin
  affected package: broffice.org-writer-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/swriter.bin
  referenced package: openoffice.org-writer-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/d5/cd1064c9fc61ddfaf05b65b603ee791cc1cbb0
- affected binary: /usr/lib/broffice.org3/program/sdraw.bin
  affected package: broffice.org-draw-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/sdraw.bin
  referenced package: openoffice.org-draw-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/67/77adff6b4fba762868b8fc94ebcc23ea8b6fbd
- affected binary: /usr/lib/broffice.org3/program/soffice.bin
  affected package: broffice.org-brand-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/soffice.bin
  referenced package: openoffice.org-brand-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/34/6dadfb048105a3437edb8fd5792cc528dbabcb
- affected binary: /usr/lib/broffice.org3/program/libnpsoplugin.so
  affected package: broffice.org-brand-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/libnpsoplugin.so
  referenced package: openoffice.org-brand-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/3d/e88c0e2f27eaa764d01910ecec678c31579073
- affected binary: /usr/lib/broffice.org3/program/unopkg.bin
  affected package: broffice.org-brand-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/unopkg.bin
  referenced package: openoffice.org-core-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/9d/1706196d7fc021fc2a447a9a949afe5e984a22
- affected binary: /usr/lib/openoffice.org3/program/simpress.bin
  affected package: openoffice.org-impress-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/sdraw.bin
  referenced package: openoffice.org-draw-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/67/77adff6b4fba762868b8fc94ebcc23ea8b6fbd
- affected binary: /usr/lib/broffice.org3/program/scalc.bin
  affected package: broffice.org-calc-3.2.1-19.6.el6_0.5.i686
  referenced binary: /usr/lib/openoffice.org3/program/scalc.bin
  referenced package: openoffice.org-calc-3.2.1-19.6.el6_0.5.i686
  debuginfo symlink: /usr/lib/debug/.build-id/7e/526e24d5a901a7972b4d0e682cc8f49d29beca

This issue has been solved in Fedora by /usr/lib/rpm/find-debuginfo.sh creating additional symlinks for identical binaries. However, symlinks should be used instead of duplicating a binary when possible.

Source file missing in debuginfo package
----------------------------------------
Multiple source files that were used by the compiler to generate a binary are missing from the debuginfo package. This is usually caused by the build script creating temporary source files during the build and deleting them after usage, or by moving source files between directories. Missing source files in debuginfo packages make debugging of crashes more difficult.

debuginfo package: openoffice.org-debuginfo-3.2.1-19.6.el6_0.5.i686
  debuginfo file: /usr/lib/debug/usr/lib/openoffice.org/basis3.2/program/libhwp.so.debug
    missing source: /usr/src/debug/OOO320_m19/hwpfilter/source/lex.yy.c
    missing source: /usr/src/debug/OOO320_m19/hwpfilter/source/grammar.y
    missing source: /usr/src/debug/OOO320_m19/hwpfilter/source/lexer.l

Please consider changing the package build script (if that is the cause of this issue) to keep the source files on their compilation place, so rpmbuild can find them when generating debuginfo package.

No .debug_info section in a debug file
--------------------------------------
When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

path: /usr/lib/debug/usr/lib/openoffice.org/ure/lib/libstlport_gcc.so.debug
package: openoffice.org-debuginfo-3.2.1-19.6.el6_0.5.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)
Comment 2 Caolan McNamara 2011-08-08 11:31:27 EDT
There's reasons for all the above.

a) soffice.bin ldd-linked to different things to give prelink a chance to optimize based on what they load. simpress.bin and sdraw.bin happen to have the same libs, so appear to be the same
b) duplicate between /path/to/openoffice and /path/to/broffice is because of different branding for the Brazilian OpenOffice.org version, which is sort out of my control. Though this brand is deceased now at of a few weeks ago

lex stuff is hard to fix, and stlport thing is effectively gone away in head.

all in all, I don't want to rock the boat on these for OOo in RHEL-6. We will be making an effort to get LibreOffice in to RHEL-6 relatively soon, and that'll address the majority of these as a side effect.
Comment 3 RHEL Product and Program Management 2011-08-08 11:35:16 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.